Question about 2005 Chrysler PT Cruiser

1 Answer

2005 Cruiser will not go over 2000rpm once oper. temp. is reached

Changed oil, plugs and wires. Checked exhaust pressure both when cold (Operating correctly) and at operating temperature (2000 rpm cut out). Both time there is no change in output pressure and no excessive heat from the cat. Fuel pump is working but have no idea of pressure.

Check engine light is on but I can't pull the code till this afternoon.

Posted by on

  • Mike Sutton May 11, 2010

    This has a trans fault the trans is in limp mode or default mode to prevent further damage. Have the code pulled and I can help u further.

×

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 1,341 Answers

You need to have a diagnostic done and get the error code to solve this problem,else it will be much harder to solve..

Posted on Sep 05, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My 1989 Chrysler New Yorker 3.0L V6 won't stay running in gear. I have replaced the fuel pump, filter, ignition wires, plugs, cap, rotor, coil. It will start right up and run when cold, but when it


Forgetting all you have done & why

What is or was the main issue & when did it start
& under what conditions ?

Does the thermostat open ?
Does it reach 195 or more coolant temp?
Does it go into Closed Loop? (Oxygen Sensors
in control of fuel)
Any OBD Codes in any system?
Fuel Pressure Correct as well as Volume
& under a load while driving

Sounds like you were going to say it only has a problem
AFTER it reaches operating coolant temp

SO- none of what you did appears to be related

First-- you find & resolve all problems. THEN do your
Preventative Maintenance-spark plugs,filters,etc.

Check or test the switch on the transaxle, that is for gear
selection,whatever you have there

May be the only problem you ever had or one of two problems

Only runs when cold-- in park only?
Won't run hot or cold-- in ANY gear?

Can you even drive it at all?

How about an Idle air control solenoid/valve
on or near the throttle body-got one of them?

Nov 21, 2014 | 1989 Chrysler New Yorker

1 Answer

1984 olds cutlass supreme brougham. Drives good until operating temp is reached. It starts to cut out. Changed plugs,wires,cap,rotor. Checked timing. Still cuts out. No smoke from exhaust. Changed fuel...


I would be suspecting a faulty condenser and coil as when they reach operating temperature they start to break down electrically.. Check that the auto choke is coming off and not tending to over fuel the engine

Feb 16, 2014 | Cars & Trucks

1 Answer

Why is my cadillac 4.5 engine smoking


What color smoke ? Blue = oil burning , black = too much fuel (rich) white = coolant - blown head gasket ,cracked head or block . White also could be caused fuel running through the engine , no combustion !
What Your Exhaust Smoke Is Trying To Tell You

Stuck Open Fuel Injector how to fix

Jun 13, 2017 | Cadillac DeVille Cars & Trucks

1 Answer

The oil pressure jumps up to the max when I give it the gas right now. Could that be because its 20 degress outside or should I get it checked.


It is related to the outside temp and the cold temp of the oil. Cold engines with cold oil will read a higher pressure. The pressure should go down to normal when operating temp is reached.

Jan 11, 2011 | 2002 Jeep Grand Cherokee

3 Answers

Volvo 850 smoke coming from exhaust manifold


Not to worry. Run the engine up to operating temp before jumping to conclusions and let the heat burn off any excess oil. A leaf will not do any damage.Do not let the engine overheat while idling and if the oil light comes on switch off immediately.
The smoke from the exhaust is oil deposited by oily assembly hands just burning off. It should dissipate after about 15 minutes at most.(or 5 miles' drive)

Jun 07, 2010 | 1994 Volvo 850

4 Answers

My 2005 dodge magnum sxt AWD is having starting problems. It has happened twice so far. I start the car and then it dies. start again and it dies again. try again and it won't even start. I've checked...


I'll be honest, it sounds like the transmitter in the key isnt reading. A key remake without the factory transmitter will start the car, but only keep it running for a few seconds before cutting power to the motor. your electronics will still run....This may be too obvious, but honestly, thats what it sounds like.

Mar 30, 2010 | Dodge Magnum Cars & Trucks

2 Answers

Oil pressure drops after worm up


let vehicle reach normal operating temp. remove oil pressure sensor replace with manual oil press. gauge run engine and monitor oil pressure go from there dependent upon findings

Mar 17, 2010 | 2000 Jeep Grand Cherokee

2 Answers

99 explorer cooling system empty in two days. no signs of water leaking except at the lower housing of the thermostat. no signs of water in the oil. the lower housing does not seem to be cracked nor the...


Have you checked inside vehicle to ensure there is no heater core leak? If not leak found there and leak at thermostat housing is not severe once at normal operating temp, issue could be with a cylinder head crack to an exhaust valve which generally vents coolant to exhaust with very little or none showing in oil.

Feb 11, 2010 | 1999 Ford Explorer

1 Answer

Engine misses, new plugs in it today, still misses


sounds like you could have a leaky valve..

i unpluge 1 plug wire at a time and see if 1 doesnt seem to change the sound of the engin to much. then you will know what plug is doing it and check those valves "exhaust/intake"..

or even check to see if that plug may have oil on it for that could be valve seals or oil ring on piston that would cause a miss..

Jul 08, 2009 | 1993 Chevrolet C1500

1 Answer

Very bad idol and run condition.


sounds like a possible water temp issue... check your thermostat and/or water temp sensor. when you first start your engine the computer uses the water temp reading to do a 'cold start' scenario, more fuel. once you reach normal operating temp the fuel should be cut back. if the thermostat is not opening and closing properly this can cause strange readings from the water temp sensor (which is mounted near the thermostat)... unlikely the sensor is bad, but a possibility... more likely the thermostat.

Mar 23, 2009 | 1993 Ford F150 SuperCab

Not finding what you are looking for?
2005 Chrysler PT Cruiser Logo

94 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chrysler Experts

yadayada
yadayada

Level 3 Expert

76109 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8270 Answers

Are you a Chrysler Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...