Question about Ford Freestyle

1 Answer

My freestyle engine light has been on and e had codes ran said maf sensor we replaced it but the car is still idiling rough and stalling out at low rpms and also when you start it it keeps dying. We have also changed the fuel filter as well...What else could be the problem?

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 1,986 Answers

EGR or TPS could be an issue as well

Posted on Sep 04, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1999 Chevy 2500 p/u trouble codes P0102 & p0107


Sounds like the Mass Air-Flow Sensor may be toast. I think you are on the right track. My scanner does not see MAF either. good luck.

Mar 18, 2017 | 1999 Chevrolet C2500

1 Answer

My 2000 Buick LeSabre was recently serviced and they replaced the MAF sensor. 3 days later It ran rough after starting. It smoothed out after that. Not wanting to spend another $400.00 I bought a...


I would say no its not normal may need to change O2 sensor or the cat. showing the missfire could be from the O2 sensor. ez test if it happends agian is unpulg the O2 and see if the idile changes if it dosent replace O2 sensor.

Jul 05, 2011 | Buick LeSabre Cars & Trucks

1 Answer

I have a code 66 motor runs rough and idles up and down check engine light when sshift in 1st gear bucks and jerks stalls out


Code 66: Mass Air Flow sensor circuit below minimum voltage.
I recommend you replace the MAF sensor

Apr 27, 2011 | Ford Mustang Cars & Trucks

1 Answer

I have a 99 ford contour, my check engine light came on and ran the code p0102 which is the MAF sensor. I replaced the MAF and my car still runs horrible (idles rough and wants to stall around 10% idle)....


Your new MAFS is not plug and play... you must clear all learnt data / fuel trim from ECU

Here is how:

Disconnect battery on + side, hold the + lead to earth (body, engine or chassis) this diffuses the system. Leave disconnected for 10 minutes, reconnect, start car and take on a 12 mile minimum drive (this is know as a drive cycle) pull over safely, switch off engine (new data now stores in ECU), start engine and happy motoring :o)

Lloyd

Aug 18, 2010 | 1999 Ford Contour

2 Answers

Engine light on 2002 mazda protege is on even after changing o2


Try cleaning the Mass Airflow (MAF) Sensor. My 2002 Protege check engine light came on and it started stalling at stoplights if I didn't keep the engine revved a little. Manager at AutoZone checked the computer code for the light (P0171?), and it said it was running lean. He suggested I try the MAF sensor cleaner they have ($6.99) rather than replacing the 02 sensor, etc.; it made a *significant* difference. (I think I need to do it again to get it totally cleaned out, but the can is for at least 4 cleanings.) The MAF sensor is the large component that air goes through right after the air filter. If you don't have the repair manual for the car (search online for PDF's), you search for the part online to see what it looks like. Mainly, it's a tube about 4" across with some small wire things inside. The cleaner can said it was a 10 minute job; mine took 20 minutes, but only because the tube leading from the MAF sensor to whatever is next (a kind of bent elbow tube, with a couple of accordian-style ripples) tore, and I had to duct-tape that up to seal it. (Still haven't gotten that replaced - found them online for ~$40. Maybe this weekend...)

Apr 01, 2009 | 2002 Mazda Protege

3 Answers

2000 bonneville w/3600 v-6 and 99000 miles never had problems, original owner. stalls sporadically but no codes come up on diagnostic. acts like a loose connection, feels like running out of fuel. NEED...


i had the same problem a few months ago. check your fuel filter. mine was on the car for some time and after replaceing it, car runs great. hope this helps. i would also check your air cleaner. if to dirty will run rich and with a dirty fuel filter your car will stall.

Mar 23, 2009 | 2000 Pontiac Bonneville

2 Answers

1999 pontiac grand prix . will not run


If you unplug the MAF sensor it should run using the default mapping. I'm having the same problem, but I want to figure out why it won't run with the sensor connected.

Jul 03, 2008 | 1999 Pontiac Grand Prix

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

118 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

75822 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

fordexpert

Level 3 Expert

5501 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...