Question about 1996 Chevrolet Beretta

2 Answers

#9 fuse blows anytime the Heating or A/C is turned on, disabling the gauge cluster, however the fan for both still runs.

Posted by on

Ad

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Having the same problem with #9 fuse any Solutions?

Posted on Aug 02, 2010

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 298 Answers

Hi you need to check the blower it's the only thing that the AC and the heater has in common check the blower by direct voltage and you'll see if it's good or not good luck

Posted on Sep 03, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I just bought a 03 cavalier today. here's what happened, let the car run as I looked it over, I let the car run, no over heating. I bought it, put 10$ of gas it was 1/8 the ten brought it to 3/4, little...


Hi Vanessa; It appears that your problem is a very common complaint with MANY Cavalier and Sunfire models (2001-2005).

Many remedies or solutions include doing the following:
  • Check for a bad ground connection
    • check the existing ground strap for any oxidation (green stuff)
    • partially broken or fully broken ground strap
      • ground strap from the battery to engine block
      • ground strap from the engine block to the frame or firewall
    Replace the strap(s)

  • Check the cluster gauges for poor or missing solder connections; or some that may have loosened.
Re-solder the connections or replace the instrument cluster with either a new, rebuilt, or used instrument cluster from either the OEM, third party vendor, or junk yard.

  • Check the fuse panel for blown fuses; service manual notes (depending upon style model) that there are either 1 or 2 fuses that controls the instrument gauge cluster; (maybe marked CLUSTER or CLS/PCM; or BCMCL).
  • In the event the fuse(s) are not blown:
    • Disconnect the battery ground cable from the battery
    • Remove the fuse(s); turn ignition key cylinder to AUX position (not "start" or "run" positions), wait about 30 seconds, to fully discharge remaining capacitor voltage to any of the car's electronic control modules.
    • Reconnect the ground cable to the battery
    • and re-insert the fuses that were removed
Hopefully this will resolve the problem. Unfortunatley, I have read where some car owners have replaced their instrument gauge clusters 3 times; which leads me to believe one of two things; either there is a serious defect in the manufacture of these instruments (but I have not seen any mandatory or voluntary recall by NHTSA or GM) or because of some sort of owner related fault...like improper battery jumping procedures- causing a voltage spike, etc.

Hope this helps.

Mar 08, 2015 | Cars & Trucks

1 Answer

I have a 1986 chevy truck, the gauge/idle fuse blowes when you turn the key. The gas gauge and other gauges dont work but runs good. Any suggestions


It could be a short in the instrument cluster-maybe one of the non-working gauges. You could pull the cluster out and try to find it, or just try another cluster from a salvage yard.

Nov 19, 2013 | 1994 Chevrolet Suburban

1 Answer

Radiator fan not working in 93 Dodge Spirit V-6. Temp gauge in instrument cluster inside works fine. Is there a separate or dedicated coolant temp sensor for rad fan, different than the temp sensor...


in fuse box there should be a relay marked "fan" swap it for another relay say from heater and see if this fixes problem, also check if fan spins freely, it may be causing fuse to blow if it is a bit old& seized

Sep 22, 2013 | 1993 Dodge Spirit

1 Answer

Why does my lexus es300 keep blowing the gauges fuse


I don't know if you've fixed it yet but check the shifter position switch (usually located below the shifter). Just unplug it, replace the fuse and see what happens. The problem is either in that switch or in the wiring between that switch and the gauge cluster.

If that doesn't work you'll need to get a wiring diagram for the gauge cluster, pull the cluster out, and clip the wires for the shifter position switch one at a time until you clip the one and the fuse doesn't blow anymore.

That should solve the problem for you.

Aug 12, 2012 | 1993 Lexus Es 300

1 Answer

The parking light fuse blow as soon as you turn on the switch


its not the bulbs, to much current is running through the fuse. your going to have to chase it with a volt meter but its probally the switch

Mar 15, 2012 | Chevrolet Silverado 1500 Cars & Trucks

1 Answer

INSTRUMENT CLUSTER AND BLOWER MOTOR QUIT TOGETHER.


Belief it or not your problem may be at one off your electric fans, also a possibility your a/c compressor coil shorted, so disconnect your a/c condenser fan and your a/c compressor check them for short and replace has needed, here is the logic every time you turn your heater on defrost it will cycle your a/c and it will blow your fuse, there is a circuit breaker on fuse box by left kick panel way up make sure it is in good condition push on it and you will feel it click if trigger, is not spring back it may be at fault to, replace it. good luck

Mar 22, 2017 | Toyota Cars & Trucks

2 Answers

Temp gauge on dash panel goes from cold to hot without engine run


cluster or wiring problems find a good cluster and switch it out see if that works if it dosnt take to a mechanic and get your wiring checked it also might be a fuse with cross wiring

Jul 18, 2009 | 1997 Dodge Neon

1 Answer

Gauges blow fuses,brake and turn signal lights dont work


all my gauges quit working and my turnsignals checked all my fuses under the hood and dash whats my problem?

Mar 11, 2009 | 1994 Chevrolet Suburban

1 Answer

Cluster Fuse is Blowing


Pull the cluster out and have it rebuilt.

Mar 14, 2017 | 1993 Buick Regal

Not finding what you are looking for?
1996 Chevrolet Beretta Logo

Related Topics:

66 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76070 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8266 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...