Question about 1996 GMC Sonoma

1 Answer

My truck misses when it is first started and run ok when it warms up. It is a 4.3 motor automatic.

Posted by on

  • casey kivela May 11, 2010

    I would have a few questions. Does it happen every time it sits for 4+ hours? Do you have a small loss of coolant? Have you looked at the spark plugs?

×

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Brigadier General:

    An expert that has over 10,000 points.

  • Master
  • 4,088 Answers

Do you get black exhaust smoke when first started? If so, then there is too much fuel at first which probably fouls several spark plugs, but as the engine warms up, the plugs start firing again. If no black smoke--is the check engine light ON? Read the code(s) if so and follow the clues.

Posted on Aug 02, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get to try the service completely Free afterwhich it costs $6 per call and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

4.6l. After warm-up, why does it run rough with missing?


Could be spark or fuel.
Weak or worn spark plugs, weak coil, dirty injector, and so on.

Jan 05, 2016 | 2001 Ford Mustang GT

1 Answer

3.0l engine. OK when cold. When it warms up, why does it miss and flatten out under load?


Sorry to say, If you had the work done at a shop. shops just don't give your new, remanned,or used motor or transmission the best shot at living a long or extended life. Unless new. But ts is still marginal.

Jun 30, 2015 | 1990 Nissan Pathfinder

1 Answer

Miss fire when cold stops as motor warms code po301


Coolant getting into #1cylinder could cause this.

Oct 10, 2017 | 2007 Toyota Avalon

1 Answer

991 Nissan Pathfinder XE-V6, @160,000 miles, Automatic Transition, 4x4. Replaced left side exhaust manifold gasket, new cap & roter @2500 miles ago, new Platinum plugs @10,000 ago Truck star


run the fault codes to find which sensor is failing from internal heat build up
when allowed to cool it works fine until it gets hot again

Mar 26, 2017 | 1991 Nissan Pathfinder

2 Answers

97 cavalier starts and runs ok from a cold start after a few minutes of warm up it starts to run rough and miss. If i try to drive it it will start out ok but won't shift automaticly but shifts fine m


Sounds like possibly more than on problem, crankshaft position sensor, or ignition module likely on starting prob which maybe affecting shifting due to hard code in ecm, or shift prob could be shift solenoid in valve body of transmission. Both parts readily available from local parts store

Nov 27, 2011 | 1997 Chevrolet Cavalier

1 Answer

Cold starts ok warms up shakes and stalls


check engine coolant temperature when it gets warmer, or at operating temperature, and verify that the temperature gauge is showing warmed up to operating temperature. If the coolant temperature sensor tells the computer the engine is cold it will over fuel and miss and the engine will die. When cooled down it will run fine until it warms up. Also could be coil if it starts missing after warmed up.

Aug 18, 2009 | 1990 Ford Bronco II

1 Answer

Run for a while then starts missing


fuel filter ,air filter , loose plug wire , loose vaccum hose under motor cover, fuel pump starting to loose its pressure

May 12, 2009 | 1997 Cadillac Eldorado

1 Answer

Engine Missing / Hesitation Cold Weather


run the fault codes
check for problem ambient temp sensor, baro sensor , maf/vaf sensor problems

Apr 07, 2017 | 2002 Chevrolet Silverado 1500

1 Answer

Honda Misses.


Pin point the dead hole and check that injector.

Dec 23, 2008 | 1995 Honda Accord

Not finding what you are looking for?
1996 GMC Sonoma Logo

Related Topics:

166 people viewed this question

Ask a Question

Usually answered in minutes!

Top GMC Experts

yadayada
yadayada

Level 3 Expert

76630 Answers

Freddy

Level 3 Expert

1311 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Are you a GMC Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...