Question about 1994 Toyota 4Runner

1 Answer

MY FRIEND HAS A 94 4-RUNNER AND THE H2O SENSOR WAS BAD ON IT.SO HE BOUGHT ONE BUT IT WAS A GENERIC ONE. SO THE COLORS ON THE BACK OF THE PLUG ARE DIFFERENT THAN ON THE FACTORY ONE.NOW HE DOSNT KNOW HOW TO HOOK IT UP COZ HE THREW THE OLD ONE AWAY. CAN U TELL ME WHICH WIRE GOES TO WHERE ON THIS PLUG? THREE OF THE WIRES ARE THE SAM COLOR HEY SAYS? IT RUNS LIKE HELL! AND IT KEEPS THROWING A CODE COZ OF IT!

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Toyota Master
  • 641 Answers

H2O is water I am assuming you meant HO2 which is heated oxigen snsr. whith the universal snsr there sould be a paper to which you match your old snsr to and then you could match the wires to the universal one. My recomendation is to put a direct fit snsr on.

Posted on Aug 02, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get to try the service completely Free afterwhich it costs $6 per call and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1998 dodge ram 1500 po132 engine light wont go off after replacing h2o sensors


the h2o sensor may not be the only problem, some thing else is setting off the sensor, a pin hole in the hose, a loose connection, cracked lines, plug lines, blockage of sensor that controls the h2o unit, look at the whole picture, housing, gasket is that area, too much h2o, not enough h2o, gases mixtures + h20's, make sure you have the air pressures sucking and pushing through the line.
you are going to have to a service manual and general information how the h20 system works in that vehicle. test points.

www.ask.com/year/mfg.name/make/model/how/does/H20/system/works/on/vehicle/

Sep 18, 2015 | 1998 Dodge Ram

1 Answer

1994 cutlass Ciera... I just swapped engines 3.1 from a 96 to a 94...everything went great, except the temperature gage doesn't work. I see in the 94 there is a sending unit on the back head just...


Your 94 engine has separate coolant temp sensor and gauge sender. The 96 engine incorporates both in the engine coolant temp sensor. The coolant temp sensor is near the t-stat, below the throttle body. Check to see how many wires are in this plug. If it only has two, you may be able to use the plug from the 96 motor and wire it into the wire where the original sensor was. You should be able to just color match. Not sure if you can get away with this but the 96 plug should have a third wire, and it's woth a try.

Aug 22, 2011 | 1996 Oldsmobile Cutlass Ciera

1 Answer

Generic code PO171 system 2 lean bank 1 generic


This can be caused by a faulty mass air flow sensor

Jul 06, 2010 | 1999 Ford Taurus

2 Answers

Check engine lite comes back on


I had the same problem on a 03 Avalon. It is the connector that comes with the "generic" sensor you bought. It tests fine, but the computer somehow sees the resistance in the connector. I even cut it out and soldered the connections, still no luck. Took car to a local shop and they said they had the same issue with generic sensors and quit using them. Bought the Bosch sensor with the factory plug (best price is on amazon.com) and problem solved.

Jul 06, 2009 | 1997 Toyota Camry

1 Answer

Emissions and vacum hose routing for a 94 toyota 4runner 3.0


Check this link. You will get what you need http://www.eautorepair.net/ Rate me if this helps.

May 18, 2009 | 1994 Toyota 4Runner

1 Answer

Maf sensor


yes get another plug from a junk yard and splice the wires toghter buy color to color

Jul 24, 2008 | 1994 Toyota Pickup

Not finding what you are looking for?
1994 Toyota 4Runner Logo

58 people viewed this question

Ask a Question

Usually answered in minutes!

Top Toyota Experts

yadayada
yadayada

Level 3 Expert

76630 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8499 Answers

Are you a Toyota Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...