Question about 1996 Jeep Cherokee Country

1 Answer

Hooked up a two-way radio,now speedometer, rpm, gas gages don't work

Posted by on

  • aprilgillis1 Aug 14, 2009

    All of a sudden, it works now. Did check for blown fuses, all fine. Power for two-way radio from cigerate lighter.

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

  • Expert
  • 206 Answers

I'd check for
(1) blown fuse (owner's manual should list which fuse is for the instrument panel - may list it as IP fuse)
(2) broken wire or loose wire in area where you obtained power for the new accessory.

Where did you get power for the 2-way radio?

If you find a blown fuse, replace, and it immediately blows again, unhook the 2-way radio, replace fuse, and see if that works.

Posted on Aug 05, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My 2000 Chevy s15 Rpm and Gas Gauge is not working


I didn't see an s15 in that model year, in my database?
If the speedometer works but the tach doesn't, I think something is wrong with instrument cluster?
GM has had a problem with fuel gage sending units. The sending units are not hard wired to instrument cluster, they send signal to pcm, the pcm sends serial data to instrument cluster, telling the cluster the gage settings.
It may be possible to use different size resistors in place of the fuel level sending unit, to see if fuel gage reacts properly to different resistors, if the gage reacts properly, then I think the problem is the fuel gage sending unit.

Nov 02, 2016 | Chevrolet Cars & Trucks

1 Answer

Rpm and speedometer gages goes crazy and radio goes out then car stops wait about an hour starts back are get ajump off what could be wrong?


If you have a light on the dash, you should get it scanned. Get code and post it. If you don't, disconnect the battery for 30 seconds, then hook back up.

Apr 14, 2016 | 1990 Honda Accord

1 Answer

Wiper dont work speedometer dont work radio and heat blower dont work rpm gage drives between 3-4 bright lights dont work automatic windows and locks dont work


sounds like might b a main fuse. do u have a kick panel and a box under the hood? sometimes a main relay or fuse will cause many electric things to go out.

Mar 26, 2014 | 2001 Chrysler Town & Country

1 Answer

Radio fuse


there might be a fuse for the windows i doubt it there will be one for the radio but the speedometer do you mean the light wont work or the sppedometer itself if its the speedometer itself then it is the speed sensor and the gas guage its the sending unit or if its the light then if all the other lights work and those dont then take the instrument cluster off and replace those bulbs

Sep 18, 2013 | 1998 Oldsmobile Aurora

1 Answer

Lights behind speedometer and gas gage, don't work


You probably have a light out . Can you remove the panel that covers thesex displays.

Feb 10, 2013 | Cars & Trucks

1 Answer

My rpm gage is not working, my speedometer is not working, my gas gage is not working, and my oil gage is not working, and my temperature gage is not working pretty much when i start up my car and drive it...


I'd wager that the fuse that controls the gauges is shot, or one of the internal connectors got unplugged (Fuse sounds more likely). Radio, Lights, and Turn Lamps are usually on seperate circuits.

Dec 28, 2010 | Ford Explorer Cars & Trucks

2 Answers

Electrical system issues


I believe what happened is the battery died and the computer lost its memory, you didn't hook the jumper cables up backwards at all did you even for a minute?
Does it run now do you have a battery meter what does it read?

Aug 15, 2008 | 2007 Kia Rio 5 Sx M/T Hatchback

Not finding what you are looking for?
1996 Jeep Cherokee Country Logo

Related Topics:

98 people viewed this question

Ask a Question

Usually answered in minutes!

Top Jeep Experts

yadayada
yadayada

Level 3 Expert

75797 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8140 Answers

Are you a Jeep Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...