Question about 1996 Chevrolet Suburban

1 Answer

Just replaced starter on 1996 k1500 5.7 v8. Check engine lights go on and off and it misses at about 50 MPH. It runs smooth at lower speeds.

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 12 Answers

One of the vaccum lines might be disconnected to the reed valve, It sounds like the emissions system is giving problems.

Posted on Jul 31, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2007 V8 diesel sport. Missing badly at idle (650 RPM) when cold, runs smoothly if revs raised to 1000 RPM. Does not appear to miss under full power, and will generally run smoothly at idle when warm.


most likely bad injector tips
have them serviced and raise the idle to 750 rpms as the lower idle speed may not be raising the combustion pressure temperature to ignite badly sprayed fuel ( diesel has to be atomized not squirted )

Dec 01, 2016 | Cars & Trucks

2 Answers

Check engine light on engine acts as if missing new plugs wires and #5 spark pack missing again 6cyl 4x4 3.4 185000 miles


was it running this way before you changed the plugs? just a shot in the dark here possibly a defective spark plug, rare but not impossible. if it was running fine before changing them. Other wise I would take it to autozone and pull codes if it is P0350 #5 misfire we would use the process fuel, fire and compression. is there any engine coolant around any cylinders? Have you checked the coil packs? could be a bad coil pack. if no evidence of fluid around them proceeded to check for spark, fuel then compression. post back results or new post with more deductions. iis it no spark no fuel or bad compression.

Dec 25, 2014 | 1996 Toyota T100

1 Answer

Possible TPS problem


is the check engine light on and have you check for trouble codes ?

Jan 31, 2014 | 1996 Buick LeSabre

2 Answers

My 1996 buick lesabre thumps when accelerating over around 50 mph, usually when entering the freeway. Already replaced all 3 coil packs, fuel, oil and air filters. Is it worth it to replace the spark


I would want to know where the noise is coming from first.
If you had a cylinder not firing, you should get a check engine light with a trouble code stored in the computer.
It could be something hitting the exhaust pipes, a weak motor mount, or any number of other things.
Does it feel like it involves the fact you are at that speed, or the fact the engine is working very hard ?

Jan 23, 2013 | 1999 Buick LeSabre

1 Answer

1996 honda odyssey - after warm up, at highway speed 65 mph and accellerating (up a hill etc) makes a vibration or engine missing. It gets steadily worse, happens at lower speeds and in lower gear as


If the engine is misfiring you would have a blinking check engine light and a fault code stored for the cylinder that is misfir9ing is that the case? If it was me I would replace the spark plug wires, they are cheap and most likely the problem.

Jul 10, 2017 | 1996 Honda Odyssey

1 Answer

Replaced starter 1996 5.7 V8 now it misfires at 50 mph


reed valves are usually in 2 stroke engines, they are a valve that controls air fuel intake on carburetors..
why asking?

Jul 31, 2009 | 1996 Chevrolet Suburban

3 Answers

200 lincoln engine problem


I was having the same problem between 40 and 50 as well as the miss fires after changing a coil that was miss firing one it reached running temp. the problem vanished so check your coils.

Feb 02, 2009 | 2000 Lincoln LS

1 Answer

Car runs rouhg at 50 mph


o.k... question... when you punch it... does the car barely go... and the engine reve up? if you gently press the gas... does is act the way it's suppose to? if that's what you have... change out the fuel pressure regulator... and the fuel injector... see if that doesn't work for you... o.k... good luck to you

Sep 27, 2008 | 2000 Chevrolet Blazer

Not finding what you are looking for?
1996 Chevrolet Suburban Logo

Related Topics:

86 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75817 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8180 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...