Question about Chevrolet Malibu

1 Answer

2006 chevy 2500 hd. Only the cluster gauges won't light up.

All other gauges such as AC/Heater & radio outside the cluster work as expected, they even dim. Just got the truck, had other chevys, so "maybe" i'm not controling it right, but I think there is a issue. Anyone heard of this before? I have not pulled the cluster to look for the problem yet.

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

Hello
i'm having trouble with the cluster in my 2500HD truck
1. the RPM and Oil gear works some of the time.
2. the drivers side windows wil not work and the relay to the secetion gets very hot.

Posted on Sep 06, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 1997 jeep laredo everything was ok but when i replaced my radio with a aftermarket radio my cluster works just no gauges


You might have loosend up one of the connection on the back panel of the instrumentos cluster
Verify to make sure all conectores all fit in place

Oct 02, 2016 | 1997 Jeep Grand Cherokee

2 Answers

01 chevy 2500 hd my gauges going off and on and battery light comes on and abs and brake lights comes


check the belt for your alternator may be loose .and check the output of your alternator should be 14.1.

Dec 23, 2013 | 2000 GMC New Sierra 1500

1 Answer

What's your problem?back up lights on a 2002 chevy silverado 2500 HD doesn't work, i have checked the bulbs and fuses, they are good ,,, how do i fix them?


disconect the reverse light switch wires from the gearbox & bridge. If the lights come on it is a faulty switch.

Oct 12, 2012 | Cars & Trucks

2 Answers

2006 chevy 2500 HD the trailer breaks don't work


the braking system is not installed a the factory just the wire from the plug to the fire wall you need to add the fuse and control box

Apr 21, 2012 | 2006 Chevrolet Silverado 2500HD 2WD

2 Answers

After i start my chevy malibu maxx all the dashboard lights go on, the radio shuts off and the gas gauge goes down to e.it is as if the car has lost power the car does not stall after a few seconds all the...


We had a similar situation. It took the dealer a few days to figure out it was an issue with the wiring harness(es) in the center console - around or behind the transmission shifter.

Sep 25, 2009 | 2004 Chevrolet Malibu Maxx

1 Answer

2003 chevy S10. some gauges & light don't work & the radio only works when you turn off truck


When these gauges start going on GM autos it is almost always a new instrument cluster. On 2002 to 2006 GM's we replace 5-10 per week. (We have over 220,000 vehicles in our fleet)

Jul 04, 2009 | 2000 Chevrolet S-10

2 Answers

On my 1999 chevy silverado the only gauges that work are the oil pressure gauge and the temperature gauge. nothing else is working cot even the speedometer or the RPM gauge.


The stepping motors in the gauges go bad. Do a search on ebay for CHEVY SILVERADO INSTRUMENT CLUSTER for cheaper repair options, dealer costs $300.00

Jun 04, 2009 | 1999 Chevrolet Silverado 1500

1 Answer

Gauges for 99 Pontiac Grand Am Not working right.


This is a ground problem. There are cluster grounds on the bolts that bolt the engine and trans together. You will have two of them one in the front under the front engine mounting bracket and one towards the back of the car almost right under the EGR. This is a common problem and requires a quite a bit of time to get to the two bolts to clean the connections on the grounding clusters. I ran into this problem after replacing my engine and it took me several hours before I finally found this problem. Good luck!

Feb 06, 2009 | 1999 Plymouth Voyager

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

223 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76649 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8522 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...