Question about 2000 Chevrolet Blazer

1 Answer

I have an electrical problem with my 2000 blazer. The temp guage is going up, the coolant is not getting hot, if you turn on the heat, the temp goes down and the heat in the vehic. stays warm for a min. or two then the air kicks on by itself, then the temp guage goes up again

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 161 Answers

Thermostat problem

Posted on Aug 27, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

I have a 2005 blazer and the heat guage is not working. The fan blows out hot air but no reading from the guage.


R you talking about the temp gage on the dash? Maybe a problem with instrument cluster? Also, check coolant temp sensor.

Feb 02, 2015 | Cars & Trucks

1 Answer

My temperature guage stays in the middle, is this ok?


Yes, the temperature gauge should normally stop in the middle, between the cold and hot points on the gauge. When the engine is cold the thermostat will be closed and will keep recirculating the coolant in the engine block until it warms up sufficiently. Then the temperature of the warm coolant will cause the thermostat to open the channel to the radiator to get rid of excess heat, which should stop the coolant from over heating. So the effect of the thermostat keeps the coolant at a fairly stable temperature. When the coolant runs low, it can't transfer enough heat to the radiator and the coolant and engine then over heats. Watch for radiator leaks under your car after you have been driving it. If the coolant goes low again fairly quickly you could have a leak in a hose or the radiator itself.

Apr 19, 2013 | 2003 Mazda Protege

1 Answer

Blows cold air when heat is on


If temp. Gauge goes way up check the intake gasket may be blown out and leaking. Take a flash light and shine it under throttle body and look for coolant. Check radiator to make sure it is full only check radiator when engine is cold DON'T OPEN WHEN HOT can cause burns.

Feb 13, 2013 | 2001 Chevrolet Blazer

1 Answer

What does it mean if the heat is blowing out cold air?


a list of things to check
1) check both heater hoses coming out of the firewall to see if both are hot, if one is cold try flushing out the heater core, than do a back flush, if that dont work check temp guage on the dash, temp guage is low, change thermostat, check for coolant leaks

Oct 03, 2010 | 1998 Chevrolet Blazer

1 Answer

Temp goes to HOT, seems like it's over heating.


flush the radiatior and replace the fan sensor switch do not mix coolents use what the car calls for in owners manal mixing will gel and miss up your car coolent system

May 04, 2010 | 1999 Chrysler LHS

1 Answer

Temp Gauge Reads Hot all the time and i have heat


as soon as you turn it on after it has been shut off for how long? you could have a bad sensor. if you have a sohc (single overhead cam) engine you have a coolant temp sensor. if you have a dohc (double overhead cam) engine you have a cylinder head temp sensor. either way you will need to start with everything cooled off, drain the coolant, remove and replace the sensor. for the sohc engine you have to remove the ignition coil to get to the sensor, for the dohc you have to remove the alternator. in both engines you are supposed to torque the bolts that hold the sensor in place to 89 in-lbs, tight enough to not have a coolant leak at that point, and not so tight that you stretch the bolts or break them off in the block. if you still have a problem after you replace the sensor then you probably have a bad water pump. hope that helps.

May 26, 2009 | 2000 Ford Focus

2 Answers

2000 Mercury Villager w/ heat, no heat, & temp gauge flux


you have air trapped in the system.
Park facing uphill (on car ramps if you have them).
with cold engine, remove radaitor cap and fill radiator.
Fill reservoir.
leave cap on loose.
Turn on heater.
start engine and run until upper radiator hose gets hot (meaning thermostat has opened).
Check coolant level and top off. Repeat until temp gauage reads normal and heat is coming from heater ducts.

go here for villager/quest help.

http://autos.groups.yahoo.com/group/villagerquest/

Apr 29, 2009 | 2000 Mercury Villager

1 Answer

GUAGE SHOWS HOT


is it ever low in coolant? i agree with emissionwiz sounds like your getting airpockets do you have heat when this starts?

Nov 09, 2008 | 2002 Chevrolet Avalanche

Not finding what you are looking for?
2000 Chevrolet Blazer Logo

Related Topics:

113 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75744 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8123 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...