Question about 1997 Ford Mustang Cobra

1 Answer

I can't start car after an oil change. Car was running just fine before the oil change.

Posted by on

  • kensoly Aug 01, 2009

    Thank you very much problem is fixed Mustang is back on the road. What a relief!

  • kensoly Aug 01, 2009

    Thank you so much for the advice. Problem is fixed and the Mustang is back on the road. What a relief!

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 20 Answers

Check that the low oil sensor or wiring to it was not damaged during the oil change.. It will not start if the computer thinks there is no oil.

Posted on Jul 30, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1987 CAMARY SOME TIME STARTING OUT FILLS LIKE IN REAL LOW GEAR BUT AFTER THAT IT IS FINE


I suggest that you take it to a professional , if after running the car it runs fine, it could be very well the transmission. You can also check when you start the car, if it takes too long to start, then you better have the timing belt check. But it's hard to pinpoint the problem without looking at it.

Oct 10, 2014 | 1987 Toyota Camry

1 Answer

07 petrol citroen xsara picasso judder/loss power after 1/4 mile from cold


service the car, put correct engine oil in it and also change gear box oil

Apr 03, 2013 | 2007 Citroen Xsara Picasso

1 Answer

I have 2001 acura 3.2tl with 200,000 miles on it. it runs fine i did a tune up used original spark plugs, new air filter and i even changed 4 ignition coils. Only problem i had with this car is when...


Plug the block heater in , End get a good battery for it, get awinter battery, Not a california battery, Then it might start, If the engine has seen it,s better days, End don,t use snake oil in it, Use real oil.

Nov 10, 2012 | 2001 Acura 3.2TL

1 Answer

I have a 97 Chevy Lumina. It has 276,*** miles on it. I bought it used 4 months ago. It was running excellent then the service engine soon light, low coolant light, and change oil soon light started coming...


The fact that the oil was low would not be from the oil pump, but from wear in the engine. If it is not smoking when you start it or as you drive, you can probably keep it running by just keeping the oil level checked at each fuel fill-up. As for the car shutting off, you didn't say if the engine seized or got real hot. A low oil pressure problem should have triggered a warning light before the problem got to the point where you lost the engine.

If the car ran after you added the oil, you got lucky and need to always check it.

Aug 08, 2011 | 1997 Chevrolet Lumina

2 Answers

2003 tdi, 54 k miles, bought car new, had manifold cleaned, new glow plugs and harness. car has been driven only short commutes for 3 years. Heavy blue smoke at startup, then it clears right up. No...


valve seals are going. when car sits excess oil gets past the valve seals then when you staRT up it burns the oil off then runs fine and no more blue smoke. It is fine to run like that had the same in a dodge caravan 1996 6cyl. ran another 100 000 km. and still ran fine got rid of it for other reasons.

Nov 20, 2009 | 2003 Volkswagen Jetta TDI

2 Answers

It crancks but dont start it has gasoline, mybfrien changed the oil 1 week ago 10-40 is the kind that he used


The type of oil will not affect the cars ability to start, If the car ran fine before the oil change I expect a wire from a sensor or coil has been disturbed. I'd check under the hood for any loose or removed connections.
I hope this may have helped,
Tom

Oct 15, 2009 | 1992 Geo Metro

1 Answer

Chrysler 300m, Oil lite comes on then engine ticks then cuts off


Is an oil pressure problem, inside the oil pan have an pump strainer , maybe its dirty
clean

May 17, 2017 | 2000 Chrysler 300M

1 Answer

CHANGE OIL LIGHT COMES ON EVERY TIME I START THE CAR


Hi wende,

Turn on the ignition, without the motor running, fully press and release accelerator three times within five seconds>start car.


anaanymous

Oct 16, 2008 | 2006 Saturn ION

1 Answer

1984 gl 1500 laser


hey ive had a simular problem on a old car,replace ur ignition coil
hope this is of help to you
cheers alvin

Jul 14, 2008 | Ford Laser Cars & Trucks

Not finding what you are looking for?
1997 Ford Mustang Cobra Logo

Related Topics:

111 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

75817 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

fordexpert

Level 3 Expert

5495 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...