Question about 2001 Mazda 626

1 Answer

Lost pulse earth to no 2 and no4 perrol injectors .This happened after fitting sh engine

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I have same issue does anyone have a fix please help.

Posted on Dec 06, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get to try the service completely Free afterwhich it costs $6 per call and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

3 Answers

I have a xc90 04 model with a 2.5 L 5 cylinder the code PO302 mise fire I did a full tune up coils , plugs ,but the number 2 cylinder is not firing . I swap coils still no fire . Checked wires and gr


if you have spark at the plug on #2 then check the injector for voltage and ground you may have a bad injector or plugged or dirty injector. it could also be a vacuum leak at the intake were it meets the head at cyl#2.

Oct 03, 2014 | 2004 Volvo XC90

1 Answer

2006 mercury montego 3.0 no fuel to front 3 cylinders engine runs on back 3 cylinders


As there is a common fuel pump that feeds both banks, I assume there is fuel pressure to the injectors. If there is spark but no fuel, it means injectors are not pulsing. For all three on one bank to be faulty, I would look for damaged wiring or a bad earth. All three would have a common earth so that is where I would start.


Try putting a test light across the two wires on an injector- while it is cranking or running, it should pulse. Try on a good injector to see what the result should be. If you try on one of the dead cylinders and there is nothing, then you either have no earth or no pulse. Test continuity with a multimeter to earth and try earthing you r test light and checking for pulse- this should give you and idea as to where you need to start looking.


Was this after a repair or did the fault just occur?

May 15, 2014 | Cars & Trucks

2 Answers

P0304


cod p0304 refers to cylinder 4- misfire detected==causes--engine mechanical fault--wiring---ignition/ fuel system--injector---ECT/MAF sensor--ecm. I would be looking at a faulty injector in no4 cylinder unless you have a burnt valve. Have a compression test done to eliminate mechanical failure.

Jul 19, 2013 | Isuzu Rodeo Cars & Trucks

1 Answer

Not firing on number 4 cylinder


Hi,you probably have a compression or injector issue.If it will reach swap the injector wire(2 pin clip)to the next cylinder and see if it starts to miss or even swap the whole injector with one of the front ones to see if the miss follows the injector.If no4 continues to miss grab a compession guage and do a test.It should have a minimum of 140psi at cranking speed.A burnt valve is often the culprit,the clue is popping at the exhaust at idle is an exhaust valve,puffing or chuffing in the intake is an intake valve.This is a head off job,and you should do a full valve service guides etc while off.Also on re assembly check all vacuum pipes and fittings as leaks kill valves.Also if it has just started doing this it may be a vacuum leak near no4.Sometimes the brake booster or hose,it needs to be fixed soon as valves are burnt quickly

Jan 26, 2013 | 1994 Nissan Maxima

1 Answer

I have a 1988 300zx non turbo 3.0 just replaced the ecu thinking it was the problem but its not. My car will turn over and it sparks, tested the fuel pressure and it makes 42lbs so thats not the problem...


The pulse to switch the coils comes from the crankshaft sensor via the ecu. Pulse to switch injectors comes from the CAMshaft sensor via the ecu. Check injector wiring plugs and confirm there is an ignition live of 12v at one side. Other side should have an earth pulse when cranking.Once you know which is missing you can trace the fault backwards. ( if no ignition live then check wiring, relay, fuse etc) if no earth switching check camshaft sensor and wiring.

May 29, 2011 | 1988 Nissan 300ZX

1 Answer

Cant gas to go through injectors


injector pulse is conrolled by the computer and the spark is controlled by the inghtion mudule. even though the spark is happening the computer gets it's pulse information for the inghtion module too. So the ingtion module ( in the distrubutor ) can be bad on the injector circuit. If the fuel pressure is too low the fuel won't flow either. On Vortec engines the fuel pressure has to be 50 PSI or higher or it won't even start. The throttle body engines have to have 20. If not the fuel pumps hose inside the fuel tank may have a whole in it so the pressureized fuel from the pump just leaks back into the tank as the pump is in the tank. This happens alot. The injectores ( in the throttle boby) ( you did'nt mention the engine in yopurs) should have power on the one wire with the key on. The other wire should have a pulsing ground as the engine is cranked. To test this, connect a test light to the battery positive and the pointer to the wire and crank the engine if the light flashes the circuit is good and if the power is good this circuit is'nt the cause of your problem. On the throttle bobvy engines theirs a tap in the fuel line going to the the throttle bady near the back of the intake. a pressure gauge can be connected here to check the pressure. some don't have this fitting and you have to remove the fuel filter and put a tee connection wher the filter was and check the pressure there,. The fuel filter is inside the frame rail on the drivers side 1/2 way down the side on the truck, towards the center of the truck. Fuel pressure is a common problem.

Mar 19, 2011 | 1988 Chevrolet C1500

1 Answer

Constant power to all 4 injectors


thats how it should be constant power on one wire and the engine ECU (computer) supplies earth on other wire at correct moment to enable the injector(squirt fuel) open.
can test if this is happening with injector noide light or some diode test lights to see if light flickers on and off (pulses dimmly)

Oct 31, 2009 | 2000 Daewoo Lanos

1 Answer

Ok i had a p0302 and then i changed plug wires coil packs the icm injectors camshaft sensor and now i can a p0301 code.. and when i clear the code it will come back with the same code or else a p0300.. im...


1. Freeze Powertrain Control Module (PCM) and see if the problem can be duplicated.

2. Wiggle tug test wiring for #2 injector.

3. Scope the #2 injector for a glitch when the misfire happens. 1. Test for the Exhaust Gas Recirculation (EGR)/coolant adapter gasket leaking EGR gases past the gasket.

2. Connect a vacuum pump to the MAP sensor, block the vacuum source, reset fuel trims, start the engine and add typical vacuum to the MAP sensor and check operation.

3. Test the spark output with 2 High Energy Ignition (HEI) testers, at 25 KV air gap each, at the spark plug wires to ground at wires 2 and 3, then 1 and 4 at cranking speed and engine running.

4. Test the fuel injector pulse width at the injectors compared to the scanner data.

5. Disconnect the O2 sensor, reset the fuel trims, test the system operation in open loop, test injector pulse width. Compare to the closed loop operation injector pulse width and engine operation.

6. Test the Powertrain Control Module (PCM) powers and grounds during the problem.

Oct 13, 2009 | 1996 Chevrolet Cavalier

1 Answer

Citroen xsara vts lost injector pulse on cylinder 2 and 3,replacment e.c.u not helped what else can it be?


no 4 injector is the sensor pick up.last one that gave me problems i put in dealer,700+euros for a new injector on no4 ,just didnt have the right software and i wasnt paying 5000+euros for the software to do one motor

Sep 22, 2009 | 2005 Peugeot 405

2 Answers

Car will not start - Daewoo Nubira


my daewoo nubira sedan year 2000 model will not start foe some reason i try to hit the button on my immobilizer to switch it off but it does nothing and that red light near the dash keeps flashing anyone no how to solve this problem?

Jul 06, 2009 | 2002 Daewoo Lanos

Not finding what you are looking for?
2001 Mazda 626 Logo

Related Topics:

87 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mazda Experts

yadayada
yadayada

Level 3 Expert

76630 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8499 Answers

Are you a Mazda Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...