Question about 1999 Pontiac Firebird

1 Answer

Replaced maf sensor and ran fine for 3wks then started to run rough and check engine light came on its the po102. this maf cant be bad again can it?

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,627 Answers

The only way to know for sure is to get the codes again and see if their is a different code or the same one.

Posted on Jul 28, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Rough idle


This could be the O2 sensor or the MAF sensor. Try disconnecting the MAF sensor and if the idling seems normal, the MAF sensor is bad. Yet, it is always better to get the codes read if the CEL in blinking.

May 08, 2013 | Cars & Trucks

1 Answer

MAF sensor on 1996 Ford Ranger.


To review - the MAF contains a hot film panel that the ECM uses to measures air flow. PO102 is low signal from MAF.
If the air filter is dirty, the air passage is restricted, or leaking, the reading to the ECM will be out of range. A vac leak elsewhere on the engine will also affect the reading.
Also, if there is a problem with the wiring between the sensor and the ECM the reading will be out of range.
Yes you could have a defective MAF too.

Jun 26, 2012 | Cars & Trucks

1 Answer

I have a 2003 suburban that was working fine until today. I drove it to the store with no problem then upon leaving I started it and it was very rough at idle. when I put it in gear it died. I continued...


Find out why the check engine light is on. The first couple of things that pop into my mind is low fuel pressure or a bad or dirty MAF sensor. You will need a fuel pressure gauge to check fuel pressure. I can get you the spec if you need it. You can also try unplugging the MAF sensor and see if it will start/idle. If it does take it for w drive. If performance is improved check the MAF to see if it is dirty. It can be cleaned with MAF sensor cleaner available at your local auto parts store.

Aug 16, 2011 | 1998 Chevrolet K1500

1 Answer

G.M.C. Savana 5.7 cranks Problem with the 1997 Savana G.M.C. Savana 5.7 cranks but will not start. Its getting spark and fuel but still does not start.. Ran fine yesterday. obd2 code came up as po102 map...


I was putting you in a thinking position.
Yes,if you disconnect the MAF-it will not start. Or if the computer has no input or control over airflow,as a result of a defective sensor.

Now, without your vehicle and some testing, I don't know if it is bad.
You suggested it wouldn't matter and would start.
Only replace it ,if you get it tested, and there is a problem. There is nothing you can do, and good luck finding a repair shop, that will do anything but replace it, and hope for the best,at your expense.

Sep 21, 2010 | 2000 GMC Savana

1 Answer

G.M.C. Savana 5.7 cranks but will not start. Its getting spark and fuel but still does not start.. Ran fine yesterday. obd2 code came up as po102 map sensor. I don't think this is the problem. Van should...


Let go with your theory

You get a PO102 MAF code.( Mass Air Flow Sensor)
Lets say the sensor is somehow not working correctly,and as you say,it has spark and fuel

I would guess, you think, the engine would be happy, having no idea how much air it is getting. Kind off like the computer will somehow overlook it is controlling an air pump in the first place.

Sep 21, 2010 | 1997 GMC Savana

1 Answer

Had a po102 code on a 2002 3800 engine chevy check voltage at 12 volts.cleaned sensor. reset code now it says po102 pd with no engine,but engine stalls when driving


HI, The DTC set PO102 is for your MAF (mass air flow) sensor. this sensors measures the air moving past it my heating a fine wire much like one inside a light bulb. Even cleaning these will not get the contaminates off. That little wire gets very hot and if dirt gets on it it will bake to it then this throws off its readings for your computer. If you checked and you have your 5 volt reference for this sensor the only other thing is to replace it. You can get re-manufactured one now at any major parts store. Good luck

Aug 28, 2010 | 2002 Chevrolet Monte Carlo

2 Answers

CODE PO102 after Mass Air Flow Sensor replaced


Most faultcodes don't disappear automaticly, the have to be 'reset' manually after repairing. It sounds like the code didn't get erased after replacing the MAF. You could try to disconnect the battery for 10 minutes (disconnect and reconnect the negative (-) pole), which should erase the code.

Whenever the engine light still comes back on after that, there probably still is some (other) problem ...

Aug 24, 2009 | 2002 Pontiac Grand Prix

3 Answers

2000 bonneville w/3600 v-6 and 99000 miles never had problems, original owner. stalls sporadically but no codes come up on diagnostic. acts like a loose connection, feels like running out of fuel. NEED...


i had the same problem a few months ago. check your fuel filter. mine was on the car for some time and after replaceing it, car runs great. hope this helps. i would also check your air cleaner. if to dirty will run rich and with a dirty fuel filter your car will stall.

Mar 23, 2009 | 2000 Pontiac Bonneville

1 Answer

1998 Plymouth Breeze


change your sparkplug wires that will salve yor problem

Sep 16, 2008 | 1998 Plymouth Breeze

2 Answers

1999 pontiac grand prix . will not run


If you unplug the MAF sensor it should run using the default mapping. I'm having the same problem, but I want to figure out why it won't run with the sensor connected.

Jul 03, 2008 | 1999 Pontiac Grand Prix

Not finding what you are looking for?
1999 Pontiac Firebird Logo

179 people viewed this question

Ask a Question

Usually answered in minutes!

Top Pontiac Experts

yadayada
yadayada

Level 3 Expert

75197 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7782 Answers

Are you a Pontiac Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...