Question about 1997 Chevrolet Corvette

1 Answer

My 79 vette tends to pull to the right while im driving at highwa

Y speed every time i hit the gas ; andgoes to the left when i let off the gas. it feels like the rear differential is loose and moving. this cars complete suspension is new. i had it on a lift and cant find anything loose; please help .

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Chevrolet Master
  • 6,982 Answers

What is "y speed???" I can't understand that part...
You problem may have a bit to do with the posi unit (differential) Try doing a "burnout" then take a good look at the tracks (footprint) you made. If one is substantially longer than the other, posi plates on one side may have either failed or are sticking. Also, try adding some positive caster (2-3degrees) to both front wheels...this helps keep the car going in a straight line. If you drive it really hard, you also may want to look into changing from rubber stock suspension bushings to something a bit harder....gives a harsher ride but keeps stuff from "wrapping up" under load.

Posted on Jul 28, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

204 Jeep Gr. Ch. i 6 at speed, take my foot off gas and it pulls right, give it gas, pulls back to left. Why?


a very serious problem
do not drive it like that,
tires inflated
wheel bearing loose
tie rods about to fail and huge danger,
ball joints,
get the car checked now. great danger awaits..

Mar 11, 2017 | 2004 Jeep Grand Cherokee

2 Answers

My car is making an awful groaning grinding noise noise when it starts. The noise stops after it starts. Put my foot on the brake it starts again. put thr car in reverse no problem put it in,drive it...


It's your exhaust mounts or broken exhaust bolts. It does it in drive st idle n under load because the motor is sitting in rubber mounts made to dampen vibration. Therefore the motor tilts to the left in reverse pulling the exhaust away from your under carraige, and to the right in drive causing the loose exhaust to vibrate against something. Check your heat shields also. They fall apart n do the same noise. Piece of cake.

Sep 24, 2012 | Cars & Trucks

2 Answers

Our 2005 Jeep Liberty pulls right when accelerating and pulls left when we let up on the accelerator - hit the gas again and pulls right again. When maintaining speed It drives straight and true


I have the exact same problem with my 05 CRD, thought it was the motor or tranny mounts but both are in excellent condition. The problem started just after turning 100,000 mi. I don't have the answer, just wanted to let you know that you are not alone on this issue, hopefully someone will post a solution soon!

May 14, 2011 | 2005 Jeep Liberty

1 Answer

When im driving my 02 tahoe, sometimes when i stop and make a left turn pressing the accelerator to give it gas to speed up to like 5 or 10 miles per hr and when i let the gas goes reaching to that speed....


slip and grab in your transmission put some lucas transmission slip-stop in and run in park position at 3000 rpms for 5 min then change into reverse and see what happens

Jul 29, 2010 | Chevrolet Tahoe Cars & Trucks

1 Answer

When i push gas pedal my stearing wheel sudenly pulling left and then when i release gas it is go back. and this car has 5 speed manual transmition.


Front wheel drive ? it would seem that the right wheel is not pulling it's weight for what ever reason. In order for this to be corrected you will have to have the right front wheel hub and transmission inspected. That is what is causing it. The left wheel is being forced to do all of the work.

Feb 16, 2010 | 1996 Nissan Maxima

1 Answer

79 vette i changed the power assisted steering hoses


Sounds like you blew out the rack.Double check that you installed the correct hoses and fluid on/in the vehicle. Bleed the unit by turning the steering wheel from stop to stop while the vehicle is running until there is no foaming or bubbles in the resovoir. If this
doesn't cure it then take it to a shop and have them pressure test the pump and rack . The tester can be pricey and the procedure is a little dangerous. If you have the tester by all means use the service manual and it will tell you the correct procedure for hooking up the tester and how to use it. But be careful and wear safety lenses and gloves.Power steering fluid is very hot and the pressures are high. If you determine that it is the rack replacing this is an adventure and your gonna need a wheel alignment after its done. I suggest you take it to a shop where the Tech's are ASE Certified. Good luck and keep me posted

Oct 23, 2009 | 1980 Chevrolet Corvette

1 Answer

2000 grand cherokee v8 struggles to start and stalls when slowing


i think your exhaust might have a leak which is heating up your oil when this happens the engine suffocates and wants to die.

Dec 02, 2008 | 2000 Jeep Grand Cherokee

1 Answer

92 Maxima Putters and sometimes even no gas sometimes


Yes I can help you. Change your coolant temperature sensor and all will be well. Only use Nissan, Bosch, or NGK part.

Nov 14, 2008 | 1995 Nissan Maxima

2 Answers

Idle? Fuel Pump? Tune Up? Sensor? Please Help!


don't know the answer to this; but we have the same prob with our 97 contour; when starting out and driving at times to it "misses" alot and the check engine light has been on for over 2 years! lol

Aug 28, 2008 | 1997 Ford Contour

1 Answer

2002 CRV EX Japan build


change the rear diff oil, with genuine honda oil, it works guarenteed .
post back and let me know how you go.
ben

Jul 28, 2008 | 2000 Honda CR-V

Not finding what you are looking for?
1997 Chevrolet Corvette Logo

Related Topics:

51 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76109 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8269 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...