Question about Cars & Trucks

1 Answer

91 Chevy K1500 350 engine 5.7l Drove the truck about 3-5 miles came back home and turned the truck off, this is what the problem I am having----- the coolant reservoir gurgles after shut down. What could be the problem? Changed thermostat also took it out, new heater core,engine coolant sensor, also changed the radiator cap and checked for any leaks in the hoses. Still gurgling.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Master:

    An expert who has achieved Level 3.

  • Cars & Trucks Master
  • 300 Answers

Is The Radiator Fan Coming on ? More Info please !! Also theres a free app its Called 6ya.com will connect you to a expert instantly !!

Posted on Aug 12, 2017

5 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 393 Answers

SOURCE: smell antifreeze, no leaks, gurgleing behind drivers side dash.

there is air in system causing gurgling/set heater to defrost and check for sweet smell. do while stopped if core is leaking windshield will fog up and be hard to clear.

Posted on Feb 28, 2009

Nomodo4u
  • 863 Answers

SOURCE: Dodge 2002 Grand Caravan V6 3.3 engine overheating/no cabin heat.

Replace the bad radiator hose first.  Second- get you special formulated anti-freeze dye from the auto store and pour it into the radiator.  Third- make sure you got all the air pockets out of your system, cause the coolant system won't work with air pockets in it.  Fourth- Check for leaks by looking for the colored dye.  If it's not the radiator hose, then could possibly be a pin hole in your radiator.  Would suggest replacing all the radiator hoses at the same time while you got the coolant system disconnected, cause you don't want to have to come back and replace another hose in a few months.

Posted on Nov 06, 2009

Testimonial: "Helpful & quick feedback! Thanks! "

jturcotte
  • 8152 Answers

SOURCE: temperature gauge went up. put coolant in

Please see my tip at http://www.fixya.com/cars/r5929960-s_thermostat and let me know if you have questions

Posted on Sep 09, 2010

  • 335 Answers

SOURCE: 1999 mercury grand marquis occasionally overheats,

Check the antifreeze for oil, pull your dipstick out, see if antifreeze is in oil or smells sweet or over full, sounds like you may of a bad head gasket. You can also check this by having a compression test done on the cylinders.

Posted on Feb 20, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Pathfinder troubleshooting


What have you replaced recently? One man in UK replaced a relay unit in the igniton wiring with one that fit and worked perfectly for 11 minutes and 46 seconds exactly, then all power in the engine was lost. Turn the key to off, turn on, start engine, perfect for another 11 minutes and 46 seconds, ad infinitum.he drove 1100 miles including motorways with this fault, on, off, on, off....
At home he found that the relay that fitted perfectly was the type of relay for the rear window Heater on a French brand of car..the one which turns off after 11 minutes and 46 seconds.
it's a long shot but did you?........
Please get back to us with the solution as it may help someone in the future.......

Jul 12, 2014 | 1993 Nissan Pathfinder

1 Answer

Clunk sound when start up then later engine failure


this is called, Engine stall.
it has many causes.
1: lost DC power to the EFI system (corroded fuses?)
2: bad engine compression for many reasons but not doing the 60k service is #1 , for ever.
3: bad spark (and timing)
4: bad fueling, too much or too little.
we use simple cheap tools to find this problem
after doing the 60k mile service.

its old car, most i see are trash, 10 or more show stoppers.
bad. all ignored by owners. #1 is the 60k skipped.
i just restored a 91. and it had 20 stoppers.

Dec 21, 2012 | 1991 Geo Storm

1 Answer

1997 Plymouth Breeze Engine keeps shutting off.


You need to do an OBD2 engine control module fault code test to see if the fault is recorded in the memory of the computer control module. Autozone and others do this testing for free.

Jun 24, 2017 | 1997 Plymouth Grand Voyager

1 Answer

On my trip form Houston to San Antonio last saturday around 2pm in the afternoon, While driving at over 70 mph constantly for about 1 hour the engine light came on and the red flash siymbol came on in my...


go t auto zone and have them run a diagnostic for free when the light is on , that will tell you the problem easy , or you can buy an OBD scanner,

Jul 25, 2011 | 2004 Dodge Ram 1500

1 Answer

My chevy s10's radiator blew I replaced it... Drove about 8 miles home. Truck sat overnight. Drove about 10 miles the next day and it wouldn't start back up. The dealership says it's either a blow head...


the head could be cracked also. check the oil if its milky then its the head gasket or head probably. if no then when its running is there alot white smoke that also could be a cracked head or head gasket.the first is antifreeze leeking into the oil system usually cracked head. the second is antifreeze leeeking into the cylinder
so no external leek

Jul 06, 2010 | 2001 Chevrolet S-10

1 Answer

Drove home - 45 highway miles, turned suv off. 10


make sure proper grade of oil was fitted check with toyota see if special grade oil is recommended

Jan 07, 2010 | 2003 Toyota Highlander

1 Answer

No spark. Have a '91 S-10 4.3L. Drove to work,


check crank position sensor, run scanner for trouble codes , some auto parts will do this for free

Sep 27, 2009 | 1991 Chevrolet S-10

1 Answer

The heater quit, service engine light, will not start now


Confirm the condition of your battery then check the ignition switch and power distribution box for any loose connections

Nov 19, 2008 | Saturn SC2 Cars & Trucks

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

36 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

yadayada
yadayada

Level 3 Expert

75797 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

Randy Ohler

Level 3 Expert

14585 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...