Question about Toyota Avalon

1 Answer

I had disconnected the battery to reset codes after finding a P0440 code. It activated the alarm I found how to shut alarm off but cannot get eng to start due to Immobilizer. I tried pushing the flashing security LED in but to no avail.

Posted by on

  • 8 more comments 
  • oldlifter50 Jul 26, 2009

    1996 model and factory system.

  • oldlifter50 Jul 26, 2009

    How are you coming on the solution?

  • oldlifter50 Jul 26, 2009

    Nope, wife bought it used and previous owner lost remote entry unit. Would it work to lock and unlock with key 5 times?

  • oldlifter50 Jul 26, 2009

    Nothing in owners manual about valet mode. Also is this done with battery connected?

  • oldlifter50 Jul 26, 2009

    OK I open the trunk, unlock the doors, put key in and turn to on. Connect the negative terminal and it is fine. The moment I do anything else air co works and cluster lights go on. The moment I open a door, turn key, the alarm goes off.

  • oldlifter50 Jul 26, 2009

    according to bill of sale it is securikey plus and wrong on year it is a 1999, wife had blonde moment. Alarm is horn sound. When I set key to on and connect neg terminal it is fine til you turn key to off.

  • oldlifter50 Jul 26, 2009

    Disconnecting the alarm feature would not hurt with the locks since I have said we do not have the controller for it. Will that also reset the engine immobilizer on this thing?

  • oldlifter50 Jul 26, 2009

    How hard is it to reach the module, I am 6 ft tall and 250 lb weightlifter. Is it a little rectangular box?

  • oldlifter50 Jul 27, 2009

    Thanks due to heavy storms cannot work on it til tomorrow after work. Will let you know what happens.

  • oldlifter50 Jul 28, 2009

    OK so I am figuring out how to do this after work today when I get an idea. I call a fellow lifter who is also a Toyota mechanic and talk to him about the problem.

    Here was his solution;

    Connect the battery and endure the alarm

    enter the car insert the key into the ignition

    push the security LED once

    turn the key to ON

    push the LED twice

    remove the key

    reinsert the key and try to start the car



    It worked. Took all of 2 minutes to fix.

×

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 15,935 Answers

Is this a Factory alarm, or aftermarket - and what year is the vehicle?

Thanks

Posted on Jul 26, 2009

  • 8 more comments 
  • blueextc3221
    blueextc3221 Jul 26, 2009

    Do you have a factory keyfob (remote) for your 1996 Avalon?



    There should be a "how to" in your owners manual to put the security system into valet mode.

    Usually key on & off 5 times (to acc position - not run position)

    I will look into that while waiting for your reply.



  • blueextc3221
    blueextc3221 Jul 26, 2009

    no - it must be in the ignition.

    if you want to remove the alarm system it is behind the gauge cluster (where the speedometer is) it is a little black box it has a long plug connected to it all you have to do is disconnect it, By doing this you will no longer have the ability to lock the doors using the remote you will have to lock them by using the key on the door. The power lock,unlock feature will not be harmed by disconnecting the alarm system.

  • blueextc3221
    blueextc3221 Jul 26, 2009

    you could purchase another remote, and marry it to the system later.

    to marry a new remote -



    1. Start with key out of the ignition, drivers door is open all others closed and
    drivers door is unlocked.


    2. Insert key into ignition (Do not turn) and pull it out.

    3. Perform these steps within 40 seconds.
    A. Using the power door lock switch on drivers door perform 5 lock/unlock cycles starting
    with lock. Use an even pace and try to go about one cycle per second.
    (1 cycle = 1 lock and 1 unlock.)
    B. Close, then open drivers door.


    4. Perform these steps within 40 seconds.
    A. Using the power door lock switch on drivers door perform 5 lock/unlock cycles starting
    with lock. Use an even pace and try to go about one cycle per second.
    (1 cycle = 1 lock and 1 unlock.)
    B. Insert the key in the ignition cylinder.
    C. Turn the ignition to ON (Do NOT Start) then back to OFF.
    D. Turn the ignition to ON (Do NOT Start) then back to OFF.
    E. Remove the key from the ignition.


    5. Within 3 seconds the power door locks should cycle automatically indicating successful entry
    into programming mode. Return to step 1 if the locks do not cycle at this point.


    6. Perform these steps within 40 seconds.
    A. Press the lock and unlock buttons on the remote simultaneously for 1 second.
    B. Immediately after letting go of the lock and unlock buttons,
    Press the lock button by itself and hold for 2 seconds. Within 3 seconds the door locks
    should cycle once indicating successful programming. If
    the door locks don't cycle or
    cycle twice, repeat steps A and B, your remote has not been accepted.
    C. Repeat steps A and B in step 6 for each new transmitter.


    7. Close drivers door.



    There is a certain procedure to get the vehicle into valet mode, and shuold be detailed in the owners manual under security section.



  • blueextc3221
    blueextc3221 Jul 26, 2009

    Are you certain this is a factory installed alarm?

    My records say it was not available pre-1998.

    Look under the dash for an alarm module.

    Drivers side - usually. behind the panel above the pedals.

    Some common aftermarket alarms are Hornet, Clifford, Viper, Code Alarm, Ungo etc.

    If the sound is an alarm sound - it is an aftermarket alarm.

    If the "alarm" is simply the horn - it is factory installed.

    If you look under the dash and see the BRAIN of an aftermarket alarm - let me know - and I will give you the steps to re-wire your starter.



    If it is factory - look as I detailed before behind the speedo cluster to unplug the factory module.





    Thanks!!

  • blueextc3221
    blueextc3221 Jul 26, 2009

    i know you dont have a controller - I was simply stating that - in the event you remove the alarm module - you CAN reinstall it after purchasing a new keyfob - if you so desire.



    Yes - unplugging the module will allow the vehicle to operate normally.

  • blueextc3221
    blueextc3221 Jul 26, 2009

    Ok, try this.
    Put the key in the ignition, and turn forward
    all the way just before cranking. Then within
    5 seconds, press and hold in the valet/overide
    button, found under the dash area,
    until the installed LED (the blinking light)
    in your dash area goes on solid, and the horn chirps once.
    (Your valet switch might be the toggle (on/off) type.
    in this case, key on, flip switch in opposite direction,
    key off.)

    This should reset the alarm.

    However there are many styles of alarms toyota installed. Factory alarms - installed at the factory - PORT alarms and Aftermarket alarms installed at the dealership - and marketed as factory.



    There are many different systems...... RS-3000, RS-3200, RS-3200 VIP and the VERY vanilla keyless entry. Anything that beeps is an RS. Anything with an LED on the dash that is labeled SECURITY is an RS. An un-labeled LED is likely an aftermarket.

    You can have a dealer run your VIN with a phonecall to the service department - and they can let you know what alarm is installed on your vehicle too.



    But if you want to simply disable the factory alarm - remove the module behind the speedometer as I stated before.



    :D

  • blueextc3221
    blueextc3221 Jul 26, 2009

    Tilt the wheel down and remove the trim (usually 2 screws at the top)

    Remove the trim.

    The cluster will be held in by 4 screws.

    Remove the screws, and unplug the cluster.

    There will be a black rectangular box with a molex plug going into it mounted on the back wall. Just unplug it.

  • blueextc3221
    blueextc3221 Jul 26, 2009

    I'm 6'4" 300lbs, and I have been installing alarms, and stereo equipment professionally for 17 years :D

    You should see me squeeze into a fiero to install a radio :D

    The Avalon is a piece of cake!!



    The 2 screws to remove the cluster trim are on the top side. And should be 7mm or 10mm socket head.

    (in red)

    Then tilt the top toward you first.



  • blueextc3221
    blueextc3221 Jul 27, 2009

    No problem.

    Thanks

  • blueextc3221
    blueextc3221 Jul 28, 2009

    you got it in valet mode - great!



    :D

×

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How can I be sure if my PCM is bad???


I would try disconnecting battery again. Disconnect both cables and touch them together for a few seconds. This will reset all modules. Wierd that you had so many codes after just disconnecting battery. Sometimes very hard to tell if ecm is bad.

Dec 01, 2014 | 2006 Pontiac Torrent

2 Answers

How to reset Service Engine Soon light after replacing gas cap? Took to AutoZone when the Service Engine Soon light came on Error code P0440.


Disconnect the negative battery cable for 30 minutes. Reconnect after and the code will clear. However if the problem persists, the code will come back with in 20 miles or 30 minutes.

Aug 02, 2014 | 2000 Buick Regal LS

1 Answer

How do i reset the service light after a p0440 code?


disconnect the battery for ten minutes then reconnect. or you can clear codes with an obd handheld analyszer

Sep 28, 2013 | 2003 Chevrolet Monte Carlo

1 Answer

Could a low battery cause car alarm to activate .....I have a Audi a4 1800 turbo Cabriolet ?


the alarm system for audi/vw/seat/skoda is based on power drop,so yes is the answer and you need to reset alarm system/remotes if you replace battery or disconnect it for any reason not forgeting the radio code...

Apr 30, 2010 | 2004 Audi A4

1 Answer

Car won't start


security code? or check engine light? the check engine light can be reset sometimes depending on the vehicle by disconnecting the battery, but you might have an alarm system on the vehicle, that is active so the car can not be stolen, and disconnecting the battery reset it all but the car thinks it is stolen, you may have to flat bed the car over to the dealer to have them reset the computer the right way.... hope this helps.

Jun 14, 2009 | 1995 Buick Regal

2 Answers

Check engine light on. Code P0440.


wow thermostat >>>> shucks i believe its evep emissions code like faulty gas cap ....you can reset any computer the chck eng light will come on in 50 to 100 miles if not fixed....

May 07, 2009 | 2001 Buick Regal

1 Answer

Alarm reset


Try shutting you door with you in it, lock it and then puch unlock it then you alarm should be reset. If you would like to find your code for your key less code let me know. or change you code,
Nikki2913

Dec 14, 2008 | 1996 Ford Explorer

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

222 people viewed this question

Ask a Question

Usually answered in minutes!

Top Toyota Experts

yadayada
yadayada

Level 3 Expert

76682 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8531 Answers

Are you a Toyota Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...