Question about Ford Focus

1 Answer

Hi ford ka seem to lose power a couple of days ago seemed to be revvin badly now car broken down still fires up ok n goes into gear but just revs there in no drive smells like cluch but also a fair bit off oil under engine on drivers side any one help on what it might be and rough costs its a 02 model with 42000 on clock

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 909 Answers

Could be the crank oil seal, behind the flywheel, leaking oil onto the clutch assembly. Check oil level and look under the engine for oil droplets on the engine/gearbox joint or the underpan and crossmembers.

Posted on Jul 26, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Gear wont engage


Low fluid level, plugged filter or a bad valve body. Could be a bad transmission control module too

Aug 14, 2016 | 2006 Kia Cerato 2.0

1 Answer

Coughing feels like its missing


be looking at emissions controls vacuum systems for leaks or broken hoses..

Dec 23, 2013 | 2003 Jaguar X-Type

1 Answer

Why is my ford ka back firing?


Check you fuel pressure and MAS sensor,and clean it.

Mar 17, 2013 | 2000 Ford Ka

1 Answer

Toyota Prado 97 (petrol). Can jump start but has loss of power when put in gear or lights, whipers or anything else turned on. Battery indicator says ok.


It sounds like you might have a bad alternator. You can't always trust you gauges. Jump it off again and check the voltage at the battery. You should have 14 volts. If it is less then that you have a bad alternator. Good luck.

Feb 03, 2013 | Dodge Ram 3500 Cars & Trucks

1 Answer

We have a 2002 Sante fe Automatic AWD. We seem to lose power and cannot get up to highway speed. The ransmission down shifts the engine revs but we constantly lose power and the engine is at max rev. I...


It sound like a plugged up catalytic converter to me. If you have more question about this feel free to ask and I will answer then as soon as possible Thank You

Jan 27, 2011 | 2002 Hyundai Santa Fe

1 Answer

1994 Explorer running rough


I would get the timing checked . backfiring is a real good indicator of that problem

Mar 16, 2017 | 2003 Ford Explorer

4 Answers

Peugeot 206 1.4 HDI Power Loss


i have a 206 1.4 hdi 52 plate and the last couple of days it has started to loose pwer and the revs drop what could it be

Dec 15, 2008 | 1991 Peugeot 405

1 Answer

1999 ford tauras transmission and speedometer


Replace the speed sensor on the trans that will cause exactly what you describe is happening.

Sep 18, 2008 | 1999 Ford Taurus

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

221 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

fordexpert

Level 3 Expert

5546 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...