Question about Cars & Trucks

Open Question

When it snows, my Xterra bucks and seems to lose power.It doesn't happen every time it snows and only lasts a short time. What causes this?

Posted by Anonymous on

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad
crayzeetrayn
  • 837 Answers

SOURCE: every 4 or 5 days mt car starts bucking and loses power

Have you tried replacing the fuel filter? It is located in the fuel line under the right rear(passenger side)of the vehicle, adjacent to the fuel tank.

Posted on Mar 24, 2009

Ad
  • 161 Answers

SOURCE: losing power,and sometimes it bucks when i am

fuel pump fuel filter

Posted on Aug 29, 2009

  • 18 Answers

SOURCE: Car loses power after driving for a while

fuel pump may be going out stand by the end of the car and try to ear the pump making sounds if it dosen't make any sounds then it bad hope this info helps

Posted on Mar 06, 2010

SOURCE: 2000 es300, sometimes surges - last time it seem to lose power could only drive about 20 miles per hour

Check for failed EGR Valve or system component

If the valve has a vacuum hose going to it ,disconnect,
plug hose & test drive to evaluate bad valve & high vacuum
signal as you suggested

Posted on Sep 30, 2012

davidfuell
  • 290 Answers

SOURCE: I have a 2004 Chrysler Sebring that's been bucking

ok im go on a limb here. the check engine light usually dont mean hey i can take later its an indication that something is going bad. so im going to tell you what i think is the problem but this could have saved you a lot of money two years ago buy replacing the O2 sensor only 50.00 maybe less hey i would have installed it for only cost plus 30.00 but now your going to replace the O2 sensor and a catalytic converter thats around 150.00 you could get one cheaper but they only last a year or little more im sure by now there is other problems but those above are your problems now with the bucking and cant get over 2200 rpms

Posted on Apr 05, 2013

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

3 Answers

The vehicle bucks and loses power


Check fuel pressure. Bucking, hesitation is often caused by low fuel pressure. Have a fuel pressure test done.

Sep 02, 2013 | 1992 Toyota Previa

1 Answer

2000 es300, sometimes surges - last time it seem to lose power could only drive about 20 miles per hour


Check for failed EGR Valve or system component

If the valve has a vacuum hose going to it ,disconnect,
plug hose & test drive to evaluate bad valve & high vacuum
signal as you suggested

Sep 30, 2012 | 2000 Lexus ES 300

1 Answer

In burn a fuse when I turn on the lights,checked all the wiring can't find the short


sounds like you have a ground wire lose. What lights are they?

Aug 18, 2012 | 2003 Nissan Xterra

1 Answer

The a.c. clicks off and on yet blows cold air when clicks on,but doesn't stay on very long


The common cause of this is that the AC system has a small leak and is low on charge.

Apr 15, 2012 | 2001 Nissan Xterra

1 Answer

2000 nissan xterra~ feels like i got watery gas (checked, no) or running out of gas (not). sputters and jerks and loses power badly until can push gas pedal to floor and won't go above 5 mph. first time it...


Mass air flow sensor might be dirty or failing.
Clean sensor when cold with mass air sensor cleaner only.
that controls the throttle opening and closing.

Jun 22, 2017 | 2000 Nissan Xterra

1 Answer

I have a 05 Cavalier that keeps dieing while i'm driving. (no enigine power, electical system seems to work normal, dash lights, head lights, etc...) At first I thought it was the a/c putting to much drag...


Sounds like a fuel problem. you could try hooking a pressure gage up to your check valve on your fuel rail see if you are losing fuel pressure. maybe a fuel filter or something thats just one thing it could be out of a bunch of things something you may want to try. does is start bucking or anthing or just straight lose all power and die?

Nov 13, 2010 | 2005 Chevrolet Cavalier

3 Answers

I have a 2001 Pontiac Grand Am 3.4l automatic, 159XXX miles. Have been having a problem with hesitation. It happens at idle, cruising, or accelerating. It seems very random, some trips, it doesn?t happen...


My wife's car had a somewhat similar problem. Her car would stall out when it would idle at a stop light, but only once every couple of months. The check engine light kept comming on and the codes read something about the transmission. To keep a long story short, we took it to a transmission shop and the torque converter solenoid wasn't working properly. $1000 later the problem was fixed and we noticed the car shifting much smoother. You may have a similar problem as the torque converter helps regulate the power between the engine and the transmission and could cause slipping and cutting out. You could always have a trans. shop check it out just be prepared to fork over the cash

Sep 21, 2009 | 2001 Pontiac Grand Am SE

2 Answers

2003 nissan xtrail accelorator sticks will not return to idle speed


Had same problem on a Nissan Patrol, happens more to me in winter time when some rust builds up around the cable (because the little rubber thing that prevents dirt from getting in the cable sleeve disappeared a long time ago - Normally I just lubricate it and it remains fine for another 8-10 months). Check accelerator cable for dents or splinters, if it seems ok, lubricate it and assemble again. If not, replace cable.

Jun 11, 2009 | 2003 Nissan Xterra

1 Answer

Every 4 or 5 days mt car starts bucking and loses power


Have you tried replacing the fuel filter? It is located in the fuel line under the right rear(passenger side)of the vehicle, adjacent to the fuel tank.

Mar 24, 2009 | 1992 Plymouth Acclaim

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

15 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

yadayada
yadayada

Level 3 Expert

76109 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Randy Ohler

Level 3 Expert

14585 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...