Question about Nissan Cars & Trucks

Open Question

Hi I have a nissanpatrol 2008 3.0lt there is a flat spot there was a recall throttle position sensor was replaced with previous owner it's doing it again has anybody got any ideas Trevor

Posted by on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 90 Answers

SOURCE: throttle position sensor

HI
did your car have (ETS) electronic throttle control system
the TPSis a part of this system
but you can test it by using diagnoses scan tool to check the TPS value when press or depress the accelerator pad.
so you can tell us the NO. of DTC for example(P0122)
ASK FOR MORE INFORMATION

Posted on Jul 14, 2008

motor1258
  • 6674 Answers

SOURCE: where is throttle position sensor located on 2000 honda passport

Normally attached at opposite end of throttle linkage. Remove your air cleaner intake hose at throttle body, and observe throttle plate that opens & closes as you press accelerator, it will be at the end of that, on outside of housing.

Posted on Jan 10, 2009

  • 206 Answers

SOURCE: I am needing to replace the throttle position sensor

It is located in the large hose coming from the air filter it just pulls out

Posted on Jun 01, 2009

motor1258
  • 6674 Answers

SOURCE: 2001 Cavalier throttle position sensor

Look where your throttle cables etc are attached at throttle body, it should be at opposite end of the shaft that operates throttle plate in front of throttle body opening. Usually held on with Torx screws

Posted on Jul 01, 2009

  • 1 Answer

SOURCE: Where is the throttle position sensor on a

Lightning bolt on dash starts blinking and the freakin truck shuts off on the highway in the center lane. Real nice Dodge. Nice way to kill someone. Any body have aclue what happens to the fbw.

Posted on Oct 15, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My 1991 Dodge Dakota has a flat dead spot when you take of from red lights. Where do I start?


The most likely cause would be the throttle position sensor on the throttle body, it is cheap and easy to replace.

Jan 09, 2017 | Dodge Dakota Cars & Trucks

1 Answer

Any fuel additives that work


My question is--- What Product that comes in a 16 oz
container & then diluted in 16 to 18 gallons of fuel,
would do much of anything?

So my answer is,there is nothing wrong with those
products & they won't hurt anything,but they won't do
anything either

So the answer is-- to properly diagnose the vehicles problems & try & return it, as close to new as built condition, as possible

You may have a Flat Spot in the TPS Sensor (throttle position sensor)
located on the throttle body. But that has to be tested

Also replacing the Oxygen Sensors closest to the engine,
every 80 to 100,000 miles, will give you better throttle response

Jun 03, 2012 | 1998 Mazda Protege

1 Answer

Check engine light is on something about the TAC?


Hi there:
DTC P0638 - Throttle actuator control range/performance
The engine control module (ECM) opens the throttle blades by applying a pulse width modulated voltage to the throttle valve motor. The ECM reverses the polarity on the throttle valve motor control circuits in order to close the throttle blades. The ECM increases the pulse width as necessary to open the throttle blades. The ECM monitors the throttle position (TP) sensors 1 and 2 to determine the actual blade position. If the ECM detects the required pulse width modulation (PWM) to move the throttle blade exceeds a predetermined value, DTC P0638 sets.

According with recalls...
REPAIR ACTION:
* Replace the Throttle Position Sensor (TPS)
* Perform the ECM software update.

NOTE :Always perform a GDS ECM Update by Automatic Mode first as it performs error checking to ensure the correct data is flashed into the vehicle. Always select the latest available ECM Update event data at time of your update.

Feb 28, 2012 | 2007 Volvo S60 2.5T

1 Answer

My '01 impala 3.4 v-6 flat spots when COLD, at around 20mph. the idle is ruff with random misfires. acceleration is overall poor. when HOT, most symptoms go away leaving only some slight acceleration...


depending on mileage, but possible tune-up could fix it. if already done then check ignition coil pack and ignition wires also spark plugs, check vacuum hoses for leaks or porous, last injectors clogged - use some techron fuel injector cleaner (wal-mart has them). Also get the throttle body and iac valve cleaned by throttle cleaner . Also this other possibilities are to be checked and confirmed.:---- Engine running rough or misfiring can be cause by the following:

1.Defective spark plugs
2.Inadequate spark/coil, defective spark plug wire.
3. Lack of compression
4.False air leakage.
5. Faulty fuel injectors.
6. Insufficient fuel pressure.
7. Contaminated fuel.
8. EGR valve that is leaking.
9. Oxygen sensors.
10. Throttle position sensor.
11. Manifold absolute pressure sensor
12.Mass Airflow Sensor
13.Idle air control valve

--------- This should help.Keep updated.Thanks.Helpmech.

Mar 27, 2011 | 2001 Chevrolet Impala

1 Answer

Speed and crankshaft sensors problem. Need to find location and how to replace this parts. Check engine light is on because of this problem.


Recall Number: 07V527000 Dates Manufactured: JAN 2004 to OCT 2006 Number of Vehicles Affected: 653910 Date Owners Notified On: DEC 2007 ON CERTAIN PASSENGER VEHICLES EQUIPPED WITH A 2.5L ENGINE, THE CRANKSHAFT POSITION SENSOR CAN OVERHEAT CAUSING A BRIEF INTERRUPTION IN THE SIGNAL OUTPUT FROM THE SENSOR. Consequence of Defect:
IF THE INTERRUPTION IN THE SIGNAL FROM THE CRANKSHAFT POSITION SENSOR IS SO BRIEF THAT THE ELECTRONIC CONTROL MODULE (ECM) LOGIC DOES NOT HAVE TIME TO DIAGNOSE THE CONDITION, THE ENGINE MAY STOP RUNNING WITHOUT WARNING WHILE THE VEHICLE IS DRIVEN AT A LOW SPEED INCREASING THE RISK OF A CRASH. Corrective Action:
DEALERS WILL REPROGRAM THE ECM FREE OF CHARGE. CERTAIN MY 2006 ALTIMAS WHICH HAVE BEEN PREVIOUSLY REMEDIED UNDER RECALL CAMPAIGN 06V223 (NISSAN R0606) ARE NOT INCLUDED IN THIS RECALL SINCE THE REPROGRAMMING FOR 06V223 ALSO INCLUDED THIS REPROGRAMMING. THE RECALL BEGAN ON DECEMBER 31, 2007. OWNERS MAY CONTACT NISSAN AT 1-800-647-7261.

Feb 01, 2011 | 2005 Nissan Altima

1 Answer

Sevice engine light on tranmition speed sensor and throtle position code


if it isnt broken wires to the speed sensor youll need a new sensor, same with throttle position sensor,they sometimes quit working and sometimes just have flat spots (no signal)

Jan 07, 2011 | 1998 Ford Windstar

1 Answer

Car just stalls usually after startup, and usually within the first 15 minutes of running.. restarts no problem.. replaced everything to do with fuel, and electric.. ie: ignition parts, distributor...


hi,
an educated guess would be the throttle position sensor and/or maybe a vacuum leak. If the throttle position sensor gets a flat spot in it the computer gets lost. its one of the few sensors that has moving parts.
jm

Oct 03, 2010 | 1994 Lincoln Continental

3 Answers

93 GRAND AM, STUMBLE,FLAT SPOT ON ACCELL 3300 ENGINE


HI! Can you please tell me more what happens to the car? THis will help to sort out the problem. Thanks!

Jun 19, 2010 | 1993 Pontiac Grand Am

2 Answers

I have a 95 mercury mystique and it starts but but


THE ENGINES THROTTLE BODY HAS A TPS WICH IS CALLED A THROTTLE POSITIONING SENSOR

It has a built in reostat inside of it which can get a flat spot anywhere in its circuit explaining why your car hesitates or sounds like it is ready to stall out
'
I would replace it and have the voltage set at 1.5 volts when set at the idle position
Then it should run fine again

Apr 10, 2010 | 1995 Mercury Mystique

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

25 people viewed this question

Ask a Question

Usually answered in minutes!

Top Nissan Experts

yadayada
yadayada

Level 3 Expert

75197 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Thomas Perkins
Thomas Perkins

Level 3 Expert

14251 Answers

Are you a Nissan Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...