Question about Cars & Trucks

Open Question

My b14 engine idles fine but sputters when revved

Posted by on

3 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 104 Answers

SOURCE: check engine light is on: engine idles rough

IT SOUNDS LIKE THE IAC (IDLE AIR CONTROL) MOTOR IS BAD OR GOING BAD, BUT THE QUICK SOLUTION IS GO TO ANY AUTO ZONE,OR ADVANCE AUTO PARTS STORE, AND THEY WILL CHECK IT FOR FREE,& TELL YOU WHAT SIGNAL CODE MADE THE CHECK ENGINE LIGHT COME ON, I WOULD DO THAT JUST TO BE FOR SURE, BECAUSE THERE ARE A FEW OTHER THINGS THAT CAN CAUSE IT AS WELL,SUCH AS MAF SENSOR DIRTY,OXY SENSOR GETTING A BAD READING,ETC.

Posted on Dec 05, 2009

  • 10 Answers

SOURCE: Rough idle, sputtering, and backfiring.

try turning ur idle up its the pin on the throtle body just make sure u tuen the engine off and on again fter each adjustment to reset ur computer on ur engine

Posted on Apr 04, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1997 Lumina starts but has to revved until engine warms up. Idle is fine when the engine is up to operating temps.


The idle air control (IAC) may be sticky or defective and cannot move to allow in extra air for a proper cold engine idle speed.

May 08, 2017 | Cars & Trucks

1 Answer

Engine sputters or misfires when free revving or letting clutch out to start moving. 1996 2.2 sonoma


Broken vacuum lines usually cause a rough idle. At high rpm's it smooths out. Low fuel pressure, timing, and the engine is just old and tired will cause your problems.

Feb 11, 2015 | 1996 GMC Sonoma

2 Answers

I have a 1993 ford festiva its a good little car it runs good when the engine is cold but when it warms up it sputters and dies on me when it dies it fires right back up like nothing ever happened It...


If it has an automatic choke, this will keep it revving more when the engine is cold and less when hot. Maybe adjust the idle setting screw on the carburettor so it revs slightly more. Try that before it is running hot. Only increase the revving gradually to the stage where stalling would be avoided when hot. Gradually so that there is not too much revving when cold. Adjusting and testing over a few runs could be a good strategy

Feb 28, 2014 | Ford Festiva Cars & Trucks

2 Answers

Sputtering when in idle and check engine light on. revs now when I put it in Park.


too many questions such as vac leaks ,throttle body cleaned,throttle cable binding or frayed.any work done on car lately?

Oct 07, 2012 | 2005 Volkswagen Jetta

1 Answer

05 taurus spits and sputters on startup when cold


This can be caused by a problem in the fuel pressure check valve of the fuel pump. Have a pressure leak down test run by a shop, if the system is losing pressure then the pump assembly must be replaced. The fuel pump is located inside the gas tank and is electric

Sep 19, 2012 | 2005 Ford Taurus

1 Answer

My 1994 Honda civic dx idles rough and sputters like its going to stall . but it runs fine at an increased RPM. when at a stop it acts like it is going to stall ... i was told it was the map-sensor.whitch...


Check your throttle plate and housing, as it could have buildup preventing a stable idle. Can be easily cleaned with an aerosol throttle cleaner with engine off, then starting and moderately revving the engine until it clears out the remains of the cleaner.

Aug 26, 2011 | Honda Civic Cars & Trucks

1 Answer

Engine runs but sputters when put in gear


Sounds like leak in high pressure side of turbo to inlet manifold tube.
Results in gutless or no performance but idle & revving in neutral ok.
Check for splits or loosened joints.

May 26, 2010 | 1987 Nissan 200SX

1 Answer

Rough idle, sputtering, and backfiring.


try turning ur idle up its the pin on the throtle body just make sure u tuen the engine off and on again fter each adjustment to reset ur computer on ur engine

Apr 04, 2010 | 1994 Oldsmobile Eighty Eight

2 Answers

Chevy 1/2 ton 2wd 4.3 vortec rough idle tried everything I know


I had the same problem with my 96 Chevy 4.3. It idled rough enough to shake the truck at a stop. It revved up fine but sputtered on take off. My truck did not want to stay in overdrive because of the low rev. I changed cap, rotor, plugs, wires and this did nothing. Finally I took the intake off and found corrosion on the side intake gaskets near the rear of the engine causing a vacuum leak.

Oct 10, 2008 | 1996 Chevrolet K1500

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

18 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

yadayada
yadayada

Level 3 Expert

75822 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Randy Ohler

Level 3 Expert

14585 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...