Question about Cars & Trucks

Open Question

Battery went dead over winter. Boosted and everything fine except no sound from radio speakers, whats wrong?

Posted by on


6 Suggested Answers

  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017

  • 14 Answers

SOURCE: Car radio dead after dead car battery

you are right, some Honda's have a radio code, most of the time on the radio chassis itself, but like my sisters she had to gone online and give them her VIN and they sent her the code

Posted on Sep 06, 2008

  • 1 Answer

SOURCE: radio not working

i ended up getting a new radio dealer told me jump starting fried radio said it was manufacture flaw

Posted on Nov 25, 2008

  • 1 Answer

SOURCE: 2003 Acura TL Radio Code needed after battery went dead

I had the same problem. You can call any Acura dealer and tell them you are traveling out of town and you need them to look up your radio code. I live in Cleveland, and our dealerships were closed for the day. I called California, where the time zone is 3 hours behind and told them what I told you to say, and they looked up the code and gave it to me immeditley!

Posted on Jan 31, 2009

  • 667 Answers

SOURCE: I have a 2001 BMW Z3. The battery went dead last

most new BMW's the fuse block is located behind the glove box. There should be a pair of twist plastic fastners at the back of the glove box, twist and remove the plate and you should find the fuse box and fuse locater list.

Posted on May 12, 2009

  • 408 Answers

SOURCE: The stereo in my 2001 mercedes slk 320 produce no

hello,good day,try to check your number 14, for your left and rigth speaker amplifier control module,also try to check the fuse in your amplifier,ty

Posted on May 13, 2009

Add Your Answer

Uploading: 0%


Complete. Click "Add" to insert your video. Add



Related Questions:

1 Answer

I have a 2007 yamaha roadliner, hadn't started it in 3weeks. It started just fine. I Rhode it about 10 miles parked it for about 5 hrs, (was in the rain) when I cam out to start it, the lights came on when...

Sounds like a corroded connection at the battery terminals. Note: these can appear fine and still be bad. Remove terminals and clean with tool designed for this job, apply die-electric grease and reinstall. If this doesn't fix it, look for other bad electrical connections or grounds.

Dec 29, 2014 | Cars & Trucks

2 Answers

Dead battery boost

The battery is probably exhausted as they do not like to be completely flat and hate high current charges.

Dec 16, 2017 | 2003 Audi TT

1 Answer

Radio turns but no sound


Dec 03, 2013 | Toyota RAV4 Cars & Trucks

1 Answer

Just put a new battery in my Cadilla STS because I thought the old one was dead, but after putting the new one in everything seemed fine and trunk, doors, radio, lights all worked. I turned the key and...

Sounds like a loose connection on the battery. Clean and tighten them, and check the battery ground. Is the starter cable on tight? If still nothing, a shop needs to check the ignition switch for a defect.

Mar 22, 2013 | 1995 Cadillac Seville STS

1 Answer

My 92 vette sat all last winter and I needed to replace my battery. After I replaced the battery I started the car, the stereo had a high screach sound thru the speakers, you could not hear anything...

its interference from the alternator ,for whatever reason which i think is your problem but i could be wrong it could just be the radio has damp inside it and may dry out with use like have the heater on ,without hearing the noise its difficult to pinpoint exactly what the noise is ,yes their is a difference in the type of noise as to a clue as to what is causing the noise .

Jan 27, 2011 | 1992 Chevrolet Corvette

1 Answer

Replaced factory radio one week ago with

sounds like its wired up wrong, remove the radio unplug the connector and remove the radio, then check all your fuses must have blown one when radio was installed, after that charge battery and with radio removed see if battery goes dead, if not recheck wiring to radio, common problem with vw aftermarket radio,they are installed wrong,good luck,

Nov 16, 2009 | 2003 Volkswagen New Beetle Convertible

1 Answer

2005 golf radio does not power up

replace the fuse if its broken or u might need to check the fuse of the radio itself if it has one. if it still not working then u might need a radio replacement

Jul 02, 2009 | 2005 Volkswagen Jetta

2 Answers

I ran my battery dead and now my cd player wont work, just the radio.

Good day;
Is it a after market system? Did you put a new battery in or just boosted the old one? Please let me know then I will know which way to go to help fix your problem.


Aug 25, 2008 | Pontiac Vibe Cars & Trucks

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

15 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts


Level 3 Expert

77932 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22306 Answers

Thomas Perkins
Thomas Perkins

Level 3 Expert

14403 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides