Question about Ford Cars & Trucks

1 Answer

I replaced an alternator and battery on a 2000 ford windstar sle with a 3.8 and it won't even crank the engine.

The vehicles charging system had an issue and after replacing the alternator and battery the vehicles engine won't crank over or the warning lights on the dash don't light up either

Posted by Anonymous on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Ford Master
  • 9,324 Answers

Check the fuse links for a loose connection. A shop manual will show the locations.

Posted on May 04, 2017

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why won't my 2000 Ford Expedition turn on. Is the battery dead when lights won't come on or it won't light up inside. Dash won't light up. Nothing comes on.


IF you have no power then 99.99999% the battery will be dead. So it will either need to be charged if it will still hold a charge or it will need to be replaced. There may also be other issues(see 2) but that is where to begin.

You might also try and start the vehicle using jumper leads connected to another vehicle. After the leads are connected properly , start the engine in the other vehicle and then try to start your engine. You do not always need to start the other car but you will if the battery fitted to the other vehicle has insufficient cranking amps to turn over the starter motor in your car. If your vehicle starts and you have normal power to lights and accessories once your engine is running (and you are disconnected from the other vehicle) then you know your battery is possibly the only issue.

How to Jump Start Car


2. However, your alternator must also be providing power to the vehicle when it is running and the alternator also charges the battery whilst your engine is running.. If the alternator is faulty and not generating the power supply, your battery will be the only power source and it will run down very rapidly. In your case(with a 2000 model vehicle) I would definitely have the alternator checked to ensure it is generating the required power because eventually these components do fail and need to be replaced.



================================================

Jan 30, 2016 | Ford Cars & Trucks

1 Answer

Battery light stays on after changing battery,alternater & plugin.


Is the system charging? You should have 14.2 14.6 volts at the battery. The charge light is controlled by the alternator internally. If the charging system is working, you could have a bad diode inside the alternator keeping the light on or a short/grounded circuit to the battery light

Apr 11, 2015 | 2003 Ford Windstar

2 Answers

Alternator was replaced now battery needs charging but only gives one hour of working


If the vehicle is not even running or begins to die after as you say an hour that means you still have a charging problem. basically the only reason the battery is there is to start the vehicle. The alternator/charging system is what runs the electrical system in the vehicle. In the power distribution box (a fancy name for a fuse box) under the hood of the vehicle there is a fuse for your charging system. Below is a picture of the layout of the fuses in the panel under the hood of the vehicle in the engine compartment. I marked the fuse you need to check. It's a 15 amp fuse and will cause the same thing as if the alternator was bad. I hope this helps.

11_7_2011_12_53_30_am.jpg

Nov 06, 2011 | 1996 Ford Explorer

3 Answers

Won't start, even w/a jump it just clicks


since this type of engine have a safety low voltage sensor the battery have to have a minimum voltage power to start. if the battery doest not receive the adequate charge they will not start even with the jump cables connected to other car. looks like the battery have to be re-please, refer to a manual for the adequate battery for this windstar since the connections change in some years. also check the alternator and alternator belt for proper tension and charging capabilities.

good luck

Jul 10, 2011 | 1996 Ford Windstar

2 Answers

Dear sirs, I have a 2000 Ford Explorer which won't start. All light in the dashboard turn on but the engine won't crank. We've tried to crank the engine direct from the battery and it cranked....


yea got get you more troubles
just check the alternator is charging well and no battery light on dashboard it indicate the bad alternator
monitor your battery if it got old and cannot hold the charge any more
you said when you used another one your car turned on

Jun 06, 2011 | 2000 Ford Explorer

1 Answer

What kind of battery is recomended fora Ford Winstar 1999 in terms of durability and capacity to feed the alternator properly?


There are two different engines Ford installed in the Windstar. The following information is assuming your vehicle has the 3.8 liter v-6...850 cold cranking amps, 750 cold cranking amps, 650 cold cranking amps, or 720 cold cranking amps. It is highly probable that your vehicle has the 3.8 liter, as 94% of Windstars had that engine installed. Hope this helps you out.

Jun 23, 2010 | 1999 Ford Windstar

1 Answer

2000 ford windstar check charging system light stays on when I just replaced the alternator and the battery, and both have been checked again after installation


If it's a 3.8 it should have a 130 amp alternator. Sounds like you have a 110 amp alternator and not putting out enough amperage. Ecm thinks that since it's only getting 110 amps instead of 130 amps, something is wrong, so it's warning you that there is a problem.

Feb 27, 2010 | 1998 Ford Windstar

1 Answer

I have a 2000 Ford Windstar, The vehicle will be running good but once in a while when it is idling the rpm will go down then the car will kill. When I try to start it the engine will not even turn over...


CHeck your battery,the connections for dirty,or loose connections.Have your charging system tested the battery,the alternator,and do a load test as well on the battery.Make sure the belt is in good condition,no cracks and it is good and tight,when your belt is tightened correctly you will be able to push down on the belt in the middle of the top about a half inch,never more than that.

Aug 08, 2009 | Ford Windstar Cars & Trucks

1 Answer

Charging Light On After Replacing Alternator/Battery1999Windstar


Hi, I can't tell you exactly what is wrong because there is too much involved at this point, what with 2 shops working with it, but I can give you some advise on what else to check. On the alternators and the wiring that supports them a small volt charge is taken off one of the slip rings, where the brushes ride, for the purpose of turning out the light. As I remember, this is a yellow wire that runs back to the dash.

To the alternator, it would be one of the wires that plug into the side of the alternator case.
jetski

Nov 20, 2008 | 1999 Ford Windstar

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

22 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

74945 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

fordexpert

Level 3 Expert

5467 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...