Question about Cars & Trucks

Open Question

Took the airfilter out no change run good for a while then seems to loose power turn of engine start nit again and ok for a while then no good again

Posted by on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 580 Answers

SOURCE: mercedes 300sl intermittently runs rough

Change your MAS Mass Air Sensor this will exhibit the problem you have if it is dirty. You can try cleaning it, yet it is normally easier just to replace it

Posted on Jul 20, 2009

outdoorsman5
  • 631 Answers

SOURCE: cold starts ok warms up shakes and stalls

check engine coolant temperature when it gets warmer, or at operating temperature, and verify that the temperature gauge is showing warmed up to operating temperature. If the coolant temperature sensor tells the computer the engine is cold it will over fuel and miss and the engine will die. When cooled down it will run fine until it warms up. Also could be coil if it starts missing after warmed up.

Posted on Aug 18, 2009

Testimonial: "we found a hole in the freeze plug causing the heat and we agreebwith his dignosistmthax much help love your site (the emergency crew Sf ca)"

  • 11 Answers

SOURCE: saab 9-5 3.0 tid 2004,turning over but not

have you tried bleeding the injectors by just cracking the unions until you see fuel leaking then tighten them as i stupidly run out of fuel and my 3.0tid wouldnt start even when recovery company tried and that is what it turned out to be an air lock

Posted on Apr 04, 2010

  • 96 Answers

SOURCE: 2000 suzuki esteem runs good at idle no codes

clean/change maf sensor maybe

Posted on Aug 22, 2010

jbeska
  • 130 Answers

SOURCE: My 04 cadillac srx v6

i would check for obd codes and see if it still is misfiring and what cylinder

Posted on Dec 05, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 1997 lumina with 3.1L. the problem started with loss of power under load and p0300 code. check coils and vacuum leaks both OK.change spark plugs and wires.[same problem] check compression OK.


Since you changed the sensor we will assume it is working. When you disconnect it you put the computer in limp mode which stops it from using sensor values. If code 300 is the only code we will assume the coolant temp sensor and others are ok.
I would check fuel pressure with a gauge next.

Aug 21, 2012 | 1997 Chevrolet Lumina

1 Answer

How to fix a1998 buick century to start fuel filter new and airfilter turning over but not starting gets gas


Did you check for spark? It sounds like you're not getting spark. Check for spark. If you are not getting spark then it sounds like you might have to replace the coil packs. Is it running a L4 engine? If its running a standard chevy L4 its probably the coil packs. Try to replace them check again for spark.

May 25, 2012 | 1998 Buick Century

2 Answers

1998 s10 sometimes will not start. Have new fuel lines, tank, and pump on it. Trying to fix it have replaced Fuel Pump relay seemed to help then started again. Truck starts, but stalls out when started...


Am I correct in understanding that the truck will start and stall out and then keep running on the restart? If so I would be looking at the cold start circuit. Perhaps a loose wire or corrosion. Maybe the cold start valve is going bad. Hope this helps.

Oct 05, 2011 | 1998 Chevrolet S-10 Pickup

2 Answers

Do you need to change spark plugs on 1999 mercury mountaineer i was told they never needed changing also why would it stall or die when cutting the wheels a little sharp


Yes they eventually need changed. If you never had a tune up your probably due. Plugs, wires ,cap,rotor,airfilter, and fuel filter. All these affect the performance of the engine. Looses power, and can make it stall or cut out under loads, like when you make hard turns and the power steering pump is putting a load on the engine

Dec 03, 2010 | 1999 Mercury Mountaineer

1 Answer

In park the engine dies; only will run if given gas


It sounds like there is a problem with the Idle Air Control (IAC) valve. Its job is to open and let air into the manifold when the throttle is closed at idle. If it does not open, the engine dies at idle. The IAC is mounted on the throttle body. Possibly the valve is clogged or stuck, in which case it could be ok again if it is removed and cleaned. Or it is broken, and needs to be replaced. Or, there is a problem with its electrical connection, that needs to be traced. Good luck, let me know if you have any questions.

Mar 30, 2010 | 1993 Chevrolet Lumina

1 Answer

My check engine light has come on but the car seems to be running fine. The water and oil is fine... What might be the cause?


transmission fluid, power steering fluid, a sensor may have malfunctioned, needs new airfilter or even a wire has loosed from the engine sensors.

Dec 13, 2009 | 1999 Subaru Legacy

1 Answer

Mercedes 300sl intermittently runs rough


Change your MAS Mass Air Sensor this will exhibit the problem you have if it is dirty. You can try cleaning it, yet it is normally easier just to replace it

Jul 20, 2009 | 1993 Mercedes-Benz Mercedes Benz Sl Class

1 Answer

P0336 Code


The code P0336 is crank shaft sensor performance code.The sensor could be faulty and not picking up a good signal.The after erasing the code,the problem still exists ,so it is then a pending code and when you shut the car off and restart it the code reappears.Just another idea here ,if you have not had a tune-up recently(plugs,wires,airfilter,etc.)you could get unwanted codes and your engine will not perform as it should.This could cause poor gas mileage as well.John.

Mar 07, 2009 | Hyundai Sonata Cars & Trucks

1 Answer

No power nothing


not really charge battery n try again

Jan 06, 2009 | 1996 Chevrolet Cavalier

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

19 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

yadayada
yadayada

Level 3 Expert

75822 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Randy Ohler

Level 3 Expert

14585 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...