Question about Cars & Trucks

Open Question

650h1 not running right - Cars & Trucks

Posted by on

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Car not running right


is the check engine light on- Denny

Dec 07, 2013 | 1997 Mitsubishi Galant

1 Answer

Signals and brake lights work when the vehicle lights are off , but when the vehicle lights come on my right turn , right brake , and right running lights don't work at all


I would render a guess that there's a bad ground somewhere. If you have the service manual, or a recent Chiltons, there may be a usable wiring diagram. You'll need a wiring diagram like that to troubleshoot. Otherwise, you'll be lost.

Nov 21, 2011 | Cars & Trucks

1 Answer

I have a 88 sierra and put a 350 w/ 7o,ooo on it.changed heads for carb.ect. anyways i cant seem to get it to run right. At night i wanted to see if spark was arking and it wasnt but i noticed the headers...


Were the new/ used heads in good shape? Did you have them checked for leaks? How about the plane, were they flat? Did you mix up the push rods? Did you run the engine with the rocker covers off to see if anything bends? Is there an adjustment on the rocker or is it a fixed thing? , Like a Ford? I think the valves might be stuck open and the flame is going right down the exhaust. Did you hear the engine run before you put it in? Probably wouldn't matter, it will run like **** with it the way it is no matter what. You have to check the rod length first, before anything else, just a visual on there should tell you what is wrong. Check it out.

Mar 01, 2011 | 1999 Chevrolet Silverado 1500

1 Answer

How do i time my truck it wont run right i cut out


try advancing ur timing mabey 3 degrees it should work alot be6tter

Jul 24, 2010 | 1989 Chevrolet S-10 Blazer

1 Answer

The vehicle does not run right.


you might need to clean the throttle body and/or replace air intake filter

Jun 09, 2010 | 1996 Ford Windstar

1 Answer

My 98 expedition will crank right up and run at a


high idle it may have a big vaccum leak that could cause the whole problem check all vaccum lines for cracks, collapsed, or off

Oct 21, 2009 | 1998 Ford Expedition

1 Answer

Stalls sputters, does not idle well


You need to take it in and have them clean you fuel system and fuel tank, or the problem could get worse and cost alot in the long run.

Apr 22, 2009 | 1987 Chevrolet Blazer

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

11 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

yadayada
yadayada

Level 3 Expert

76070 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Randy Ohler

Level 3 Expert

14585 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...