Question about Rover Cars & Trucks

1 Answer

03 range rover cranks but, will not start. getting fuel injector and camshaft sensor codes. Getting fuel to fuel rail at 40psi. Old sensor still works. sprayed starter fluid in intake car started.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 1,792 Answers

Must be the injectors then. 40psi to the fuel rail should be good.

Posted on May 04, 2017

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Accord 91 nostart cranks spark at plugsNo fuel coming from injectors pressure at fuel rail. code 14humming sound fromeckey turned to on position.already replaced main fuel relay coil dis cap and rotor


chexk to see if ur antitheft isnt keeping ur injectors from coming on. also check camshaft sensor that what controls injector pulse along with ur ckp sensor.crankshaft position sensor

Jun 28, 2015 | Cars & Trucks

2 Answers

99 escort zx2 2.0l, replaced engine, no spark, no injector pulse, I replaced the crank position sensor, I'm getting 40psi at the fuel rail.


check all the plugs from/to the sensors (camshat,crackshaft,starter,etc and make sure the grond wire it\'s firmly attached to the chassis/or engine...it seems like a little electrical bugger

Jul 14, 2014 | 1999 Ford Escort

1 Answer

No Injector Pulse


run fault codes as there is a problem sensor in the system. volts at the injector is suspect as the voltage will vary with the fuel requirement.

Jan 05, 2014 | 2005 Mazda Tribute

2 Answers

Engine turns over but won't start. plugs and wires changed


A diagnostic check of the vehicle will pinpoint your no starting problem,but if that isn't an option for you and you want to do the work yourself, follow these step's:
Check for spark WHILE TRYING TO CRANK THE ENGINE. If no spark is present,check to see if there is power coming from the switch during cranking. If you have spark,check to see if you are getting fuel. If you aren't getting fuel,check your fuel filter(it coud be clogged) and check ALL fuse's. If you aren't getting spark AND fuel,then check the crank sensor as it is the controller for spark and fuel delivery.

Mar 28, 2011 | 2000 Mercury Cougar

1 Answer

Engine cranks but will not start. i have new fuel filter installed new plugs installed .i have fuel pressure at fuel rail ,i have spark at plugs and the injectors all read 11 to 14 ohms resistance per shop...


If you've got spark and fuel, it should fire up. Crank the engine for about 20 to 30 seconds then immediately pull one spark plug. if your getting fuel, it should be wet with gasoline. No wet,no gas. But then again, the code says rich mixture. Doesn't add up. Check all the connections at the mass airflow sensor and the crankshaft and camshaft sensors.

Dec 20, 2010 | 2003 Pontiac Sunfire

1 Answer

1999 range rover se changed fuel pump, truck still wont start, relays and fues look good.


why you have replaced the Fuel pump? who advised you to do so?
be guided as follow 1. on the Engine Side on the top there is a fuel rail for the injectors. turn the ign. key to the second position (on) and check the valve located on the fuel rail if fuel is coming pressurized and still won't work. then open on of the spark plugs wires and check if spark is there. (Be Careful doing that). if no spark then is there any message comes up on the Dash? if not messages then you can check the Crank Sensor if no current being generated from the ign. coils.

Jul 03, 2010 | 1999 Land Rover Range Rover

1 Answer

2003 land rover freelander will not start


cheaper to have codes read than replacing parts that may not be required, but yes could be crank sensor

May 26, 2010 | 2003 Land Rover Freelander

1 Answer

Freelander td4 bmw engine will not start


fuel rail preasure rgulator valve may be faulty

Sep 12, 2009 | 2003 Land Rover Freelander

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

21 people viewed this question

Ask a Question

Usually answered in minutes!

Top Rover Experts

yadayada
yadayada

Level 3 Expert

75066 Answers

Thomas Perkins
Thomas Perkins

Level 3 Expert

14204 Answers

Rob
Rob

Level 2 Expert

62 Answers

Are you a Rover Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...