Question about Suzuki Cars & Trucks

1 Answer

The oil light is flashing on the dash. I have a 2016 Suzuki 50 hp

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 70 Answers

Most likely, low on oil, clogged filter or bad sensor.

Posted on May 02, 2017

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why does my 2007 Suzuki XL7 has "jerking" sensation between 30-50 MPH?


How many miles since a tune-up? Could just be dirty gas? Try adding a bottle or 2 of injector cleaner through the gas tank...I like the Lucas Oil brand...about $3.88 at Walmart...Hope this helps.

Oct 15, 2015 | 2007 Suzuki XL-7

1 Answer

F650 V10 engine. How many quarts of oil and the part number for the oil filter?


2016 Ford F-650-750 Work Trucks ' View Full Specification ...

www.ford.com/commercial.../f650.../specifications...
Ford Motor CompanyRead detailed 2016 Ford F-650-750 work truck exterior, interior, engine, specifications& more. ... Ford 6.8L V10 engine - 320 HP ' 460 lb.-ft. (standard - gas).

Aug 12, 2015 | Ford Cars & Trucks

1 Answer

My 1998 suzuki esteem will not go into overdrive flashing warning on dash


this is a transmission issue, not engine.
the TCM detected that OD is inoperative.
at the least the OD solenoid is bad.

Feb 19, 2013 | 1998 Suzuki Esteem

1 Answer

Suzuki swift ddi 1.3 oil light flashing when first start but goes off after 30 seconds. Does it every time start car, hot or cold. Oil level fine. Can't find anything in the manual or on line to help....


might need to reset sensor, my van does that every three thousand miles, computer controls that tracking of milage to estimate the next change, try this to see if it clears------turn on ignition so dash lights up ,right before you turn ignition for a full start,this is so the computer turns on( dont have car running) then pump gas pedal three full times and hold it down on a fourth for about ten seconds,( pump,pump,pump,hold), hopefullt this should reset the computer sensor. turn off car wait ten to fifteen seconds, and start normally, hopefully it should have the oil light on after that, if it does you might need to check with a mechanic.

May 07, 2012 | 2007 Suzuki Swift 1.5

2 Answers

Had oil changed at first service as light was flashing didn't take to suzuki dealership ,garage couldn't reset .how do you reset and stop the light flashing . my car is 08 suzuki swift


Okay in your owners manual look up oil service light and it will give you a few steps on how to reset it this has to be done every time you change the oil and most mechanics should know how to do it except wal mart their not certified mechanics. But you can take it to any mechanic or say like a Jiffy Lube or who ever doe's oil changes like these guys and have then help you reset the light but it should tell you in the owners manual.

Feb 07, 2010 | 2007 Suzuki XL-7

1 Answer

Flashing light on dash, circle with exclamation


hi think its brake fluid warning light if it flashes if doesnt flas then it just parking brake indicator my i reckon it first one so check brake levels if necessary top up above minimum if not theres a fault either the light it self or braking system hope this helps

Jul 16, 2009 | 1999 Suzuki Swift

1 Answer

93 audi 100 ran fine yesterday wouldn't start today


Sounds like a bad ignition switch. It has terminal 50 (starter activation) but no terminal 15 (ignition on) activation.

Apr 24, 2009 | 1991 Audi Quattro

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

21 people viewed this question

Ask a Question

Usually answered in minutes!

Top Suzuki Experts

yadayada
yadayada

Level 3 Expert

76673 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Boyet Soriano
Boyet Soriano

Level 2 Expert

293 Answers

Are you a Suzuki Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...