Question about Cars & Trucks

Open Question

No cold water from Genuine Joe model22552 - Cars & Trucks

Posted by on

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2008 toyota highlander cam actuators


sounds like a dealer trick--sounds like timing chain is bad--dont turnit over no more u mite hurt valves--get away from that place and go to an honest independent to remove the cover and inspect chain--water pump and front seal are in same area-checkum out too

Oct 23, 2011 | 2008 Toyota Highlander

1 Answer

I have 97 dodge stratus that only blows cold air please tell me why


Hi lil..... The most common cause of the cold air problem is a stuck thermostat under the hood. Replace the thermostat and your problem will be solved. Joe

Dec 19, 2010 | Dodge Stratus Cars & Trucks

1 Answer

Won't start in cold. It's not the battery. The starter has been replaced, but I'm not sure if the part was genuine.


If the temperture is below 30 deg. it could be you have water in the fuel lines and freezes and stops the fuel from getting to the engine. use gas line anti freeze.

Apr 28, 2010 | 1998 Saturn SL

1 Answer

Why does my heater blow only cold air?


Hello. The most common cause of your problem is a thermostat under the hood and in the radiator line which is frozen and preventing the flow of hot water into your heater core. Drive to any auto zone or similar auto parts store where one of the technicians will come out to your car and check for you. Replacing the thermostat is not a difficult job and many auto parts stores these days will talk you through it and loan you the tools. Regards, Joe
PS please rate my answer. Thank you.

Jan 15, 2010 | 1999 Ford Taurus

3 Answers

Heater blows cold, temp gauge rises 1997 Camaro Z28, 50,000 miles...Florida, freezing in NJ Car just started blowing cold air today...always smeeled anitfreeze...always has water level light on as long as...


heater core is probably what was changed,..a little radiator under the dash that the hot water runs through and a fan behind it to blow at it thus giving you heat,...pretty much thats it in a nutshell,...sounds like something still leaking under there, (anti-freeze smell),... fill it back up with anti-freeze (non-toxic type so you don't polute) and drive to where you gotta go,....go to your mechanic to find that leak,.good luck, and do a hole shot for me! thanks, cracklin joe

Jan 08, 2010 | Chevrolet Camaro Cars & Trucks

1 Answer

Cold air blows when engine warm, some hot air than back to cold. antifreeze full


Hello. The symptoms you describe indicate that your car's thermostat is due to be changed. Go to any auto zone or similar parts store where they will sell you the proper part, and even help you change it. Regards, Joe

Dec 19, 2009 | 2001 Oldsmobile Alero

1 Answer

Rough engine on cold start. CEL blinked, now on all the time.


Take it to a different autoparts store and bring pen and paper. Write down codes. You can use search on browser and key in "Mercury code xxx" xxx means whatever number you are told by autoparts. Internet explorer will pull up code. Chances are the second autoparts store may be more knowledgable.

Your cold start circuit is not working and your friend may be right about coolant sensor. Also, the reader Advance used will not reprogram your car. It only reads problem so you have to change physical parts yourself.

Good Luck Joe

Jul 20, 2009 | 2005 Mercury Mountaineer

1 Answer

Kia Sedona overheating. New radiator/compressor. Now what??


Hi,
To start with you have to do this:
With the engine cold, start the car and say after 30 to 40 secs. open the radiator cap.
Carefully and slowly, cause if the problem is either in the cylinder block or cylinder head this shows immediately as water would be compressed in the radiator ( even though the motor is still cold ).
If nothing happens and you would not notice any bubbles in the radiator, then we have to talk again.
Joe ( Malta )

Jul 10, 2009 | 2002 Kia Sedona

3 Answers

No heat when idle


might be an airlock in the heater box. joe

Dec 05, 2008 | 2004 Infiniti G35 Sport Coupe

1 Answer

Powersteering hose blowing


do you have water or a coolant in it. check the antifreeze.joe

Nov 21, 2008 | 1996 Ford Aerostar Extended

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

17 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

yadayada
yadayada

Level 3 Expert

74945 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Randy Ohler

Level 3 Expert

14585 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...