Question about 1998 Chevrolet Blazer

1 Answer

1998 4x4 blazer, 4.3 vortec. Just changed out TPS and Maf, ran great, drove to store, wouldn't restart.

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Chevrolet Master
  • 3,482 Answers

Have you done any testing? Engine cranking, you have spark at the plugs and fuel injector pulse? Use a gage and check proper fuel pressure, key on engine off, 60--66 psi. The spider fuel system is noted for problems.
Any applicable trouble codes?

Posted on Apr 30, 2017

  • Toni Burns
    Toni Burns Apr 30, 2017

    Recently cleared codes, so none coming up. Truck ran fine after changing out TPS (old one broken) . Has fuel pressure, spark,

  • jack layton
    jack layton Apr 30, 2017

    At the moment, my thought would be to check fuel pressure specs.
    How long since overall tune-up? I want to check fuel trims.

×

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2003 Rav 4 periodically stalls at low idle, intersections


Start with the throttle body. I use brake clean and a toothbrush. Clean the plate and were it sits. Wouldn't hurt to spray down the MAF sensor, if it has one. Once you do it, it will take a few seconds to start. Once started, rev it up and spray inside the throttle. Keep it running. Most times this is a $4 fix.

Aug 20, 2016 | Cars & Trucks

2 Answers

Our fuel pump stopped working on our 98 Chevy Blazer V6 4.3L Vortec Engine, so we bought a new one. A couple days later (before replacing the fuel pump) it started up and ran but ran crappy. So we did


what did you do (replace it) if you still have a miss you may need to tune it up / make sure the fuel pump you bought is for the right psi for your blazer

Mar 27, 2013 | 1998 Chevrolet Blazer

1 Answer

I changed my spark plugs and cleaned my mass airflow sensor with maf cleaner. The truck didn't want to start but it finally did. When if did it had a sulfur smell but went away. The truck wouldn't...


When you cleaned your maf sensor did you disconnect your negative battery cable. If you cleaned the maf senor without disconnecting the battery cable there is a chance that you shorted out the sensor. Try unplugging the sensor and see if the truck runs any different. If it does not run any different with the maf sensor unplugged then you will know you found your problem. I hope this helps you out, and good luck

Aug 27, 2011 | 2004 Ford F150

1 Answer

Vortec 4wd 2dr auto trans stalls while drive


you might want to look at your O2 sensors, they can cause the motor to run lean or rich. also you might have an electrical issue that is tripping your ECM. your electronic control module might be faulty. best solution is to get a trouble code reader and find out what your on board computer has stored. from there you can repair and clear the codes.

May 05, 2010 | 2002 Chevrolet Blazer

2 Answers

94 Blazer, 4.3L Vortec Engin runs fine for a


Could be a fuel issue, Start by changing the fuel filter, if that doesnt work you might want to drop the gas tank and check the strainer on the fuel pump and make sure the tank is clean.

Jan 20, 2010 | Chevrolet Blazer Cars & Trucks

1 Answer

1995 blazer has rough idle, i replaced the EGR and TPS it ran great for 2 days and now is back to the rough idle.the comp codes are the same as before replacing the two parts,could one be defective,can...


When you changed the egr valve did you clean out the carbon build up inside the intake? if not that could be the problem, if you did, than a peace of the carbon got stuck in the valve, either way your local auto parts store sells a screaned gasget for the egr valve to prevent peaces of carbon from the intake geating into the egr valve, same exact thing happend to me on my 95 blazer.

Aug 23, 2009 | Chevrolet Blazer Cars & Trucks

1 Answer

My 95 4.3 vortec blazer wont idle after its warmed up


IAC(Idle air control) and or TPS(throttle position sensor)

Jul 21, 2009 | Chevrolet Blazer Cars & Trucks

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

41 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76132 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8273 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...