Question about Cars & Trucks

Open Question

New t120 bonneville. MIL light wont go out when engine starts. Bike seems to run normally. Have had 2 cold starts up to running temp via a road run.

Posted by on

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad
dgjtex
  • 405 Answers

SOURCE: Temperature gauge shows hot but the engine is normal operating te

replace temp sensor for the emission system. there are two on the engine.

Posted on Dec 26, 2008

Ad
  • 15 Answers

SOURCE: bonneville wont start

Check your battery cables,, they are probably loose or corroded. Side mount batteries that hold multiple cables have this problem that occurs over an extended period of time. Cleaning the connections and retightening the hold down bolt may fix it. Sometimes a 3/8 bolt and a washer with a nut can be used to get
a more positive holding force to keep the cable tight.

Posted on Feb 06, 2009

  • 13 Answers

SOURCE: 2003 vw jetta tdi 1.9lt, temp light flashes on cold days

Hi it sounds like you have a temp sender playing up I think there are 3 on your engine,

Posted on Sep 03, 2009

  • 70 Answers

SOURCE: 1997 Bonneville SSE, when the heater is turned on, only cold air

you may have a failed blend air door motor/actuator. this part will regulate the amount of air from the heater core depending on the temp setting on your electronic climate control unit. if it has failed, it will be stuck at the temp that it was last set at when it quit working. it is also possible the heater core may be plugged up, but using the gm recommended dexcool coolant and flushing it out every 5 years, it should not be plugged up. you can pull the 2 heater hoses off the heater core on the passenger side of the engine compartment firewall and see if the heater core is the problem. caution-do not use a high pressure air hose to blow through the heater core as this could damage it and cause a leak!

Posted on Oct 28, 2009

samtoler
  • 666 Answers

SOURCE: Car won't start after it is hot. Turns over and

that would be a wet soak concern, Likely fuel pump failure

Posted on Jun 09, 2010

Testimonial: "I changed the fuel pump (actually pretty easy )thanks; so far 3days its worked every time so far "

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Wont start and run engine stalls after about 1or 2 seconds


Any engine light? Can you hear the fuel pump run for a couple seconds when you turn the key to ON?

May 13, 2013 | 1996 Ford Thunderbird LX

1 Answer

During cold weather the engine runs fine but during warm weather the engine dies


Could be a problem with your intake air temp sensor or your coolant temp sensor. The most likely would be the coolant temp sensor. It may be reading cold and will make it run good as the engine is cold but as it warms it is not adjusting the air fuel ration to the proper levels making it run rough hot

May 23, 2010 | 1992 Pontiac Bonneville

1 Answer

My Xtype 2.5 Y Reg suffers from a strange fault. After driving on the Motorway for approximatly I hour or more the MIL light comes on the Temp gauge motors to full scale the overtemp light comes on. If you...


1. check electric fan comes on.( this is done by bridging the wires coming from the switch on the rad
2. replace themostat could be intermitant sticking, i am not sure but there may be 2 one in the engine and one in the water pump, depends on the engine set up

Dec 05, 2009 | 2002 Jaguar X-Type

2 Answers

1997 Bonneville SSE, when the heater is turned on, only cold air


you may have a failed blend air door motor/actuator. this part will regulate the amount of air from the heater core depending on the temp setting on your electronic climate control unit. if it has failed, it will be stuck at the temp that it was last set at when it quit working. it is also possible the heater core may be plugged up, but using the gm recommended dexcool coolant and flushing it out every 5 years, it should not be plugged up. you can pull the 2 heater hoses off the heater core on the passenger side of the engine compartment firewall and see if the heater core is the problem. caution-do not use a high pressure air hose to blow through the heater core as this could damage it and cause a leak!

Oct 15, 2009 | 1997 Pontiac Bonneville

1 Answer

2003 vw jetta tdi 1.9lt, temp light flashes on cold days


Hi it sounds like you have a temp sender playing up I think there are 3 on your engine,

Sep 03, 2009 | 2001 Volkswagen Beetle

2 Answers

99'concorde stalls,wont start until cool again..


When cold, your engine runs from a different computer mode than when warmed up...It seems that when you reach temp, the normal "run" program transitions in (undercomplicated version) Usually when the signal from the temp sending unit does not change (bad sender) the engine will remain running but will run rich. Usually if the sending unit wire is disconnected it will also remain in "cold" mode. I'm thinking that possibly the sender is internally shorting out or the computer isn't working correctly. If you have an engine light on, likely you can retrieve a code that may point you to something in that area. Or, since sender isn't very costly, change it and see if the problem clears up. (I'm not a big fan of just putting in parts without testing, but in this case it may pay off)
Good Luck

Jul 27, 2009 | 2000 Chrysler LHS

1 Answer

2000 Bonneville runs rough when cold


you need to get it scaned.auto zone will do it for free but most of the time it a o2 sensor or coolant sensor

Jul 17, 2009 | 2000 Pontiac Bonneville

1 Answer

99 explorer running rich check engine light wont come on


coolent temp sensor to pcm . the truck thinks it cold and its riching the fuel mixture . its a cheap part . i would have a good shop with a good scaner check it fist but thats up to you

Jun 12, 2009 | 1999 Ford Explorer

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

19 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

yadayada
yadayada

Level 3 Expert

76164 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Randy Ohler

Level 3 Expert

14585 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...