Question about Cars & Trucks

Open Question

New connector for a speed sensor.. 2 wires on new connector....4 wires on the pigtail from the harness...which wire connects to which wire

Posted by on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

dustyboner
  • 331 Answers

SOURCE: Installing universal Oxygen sensor

here is the 97 civic electrical diagrams. after you download and unzip the file, try 17252.pdf.

Posted on Oct 11, 2008

TheAsian
  • 93 Answers

SOURCE: Connector for Speed Sensor on1996 Honda Accord Auto Trans.

If you are talking about just plugging into the speed sensor yes. A VTEC and NON-VTEC are one and the same.

Posted on Dec 13, 2008

inf12
  • 13 Answers

SOURCE: need wiring diagram for taillights on 2000 chevy venture van

d7d3cd6.jpg3a50d5e.jpg80738de.jpg8d3e722.jpg GOOD LUCK

Posted on Feb 08, 2009

  • 14 Answers

SOURCE: 1987 Suzuki Samurai alternator wiring. No original wire harness

yes the b goes to the battery.

http://bbs.zuwharrie.com

heres the site for you.. we have all the answers.

http://www.acksfaq.com/diagram_color_86-88_sam.htm

i drew this up a while back. it could help you out alot.

Posted on Apr 22, 2009

  • 17 Answers

SOURCE: o2 sensor wiring diagram

A new 02 sensor will come with new wires and connector. If not get back with me I think there is a repair kit for that problem.

Posted on Jun 01, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How to change crankshaft sensor on a 2001 cad catiera


Its on the side of the block firewall side ... REMOVAL Numbers in text in parenthesis correspond to numbered components in image. Disconnect the wiring harness (1) from the Crankshaft Position (CKP) sensor pigtail. Securely attach a scrap piece of wire about 36 inches long to the CKP sensor pigtail. Later, this piece will be used as a pull wire to guide the new sensor pigtail back through the same routing. Raise and support the vehicle. Remove the oil filter and capture any lost engine oil in a container. Loosen the oil cooler lines at the engine block. Back out the fittings far enough in order to gain sufficient clearance for the sensor pigtail connector to pass between the oil cooler lines and the side of the engine block. Remove the fastening bolt for the CKP sensor (1). Remove the CKP sensor and the O-ring seal from the engine block. Remove the CKP sensor pigtail. Observe the routing of the pigtail. Gently pull the CKP sensor pigtail down through the routing path and out. Guide the pigtail connector along the top of the oil cooler lines around to the side of the engine block. Pass the connector between the lines and the block at the point of the widest gap. Stop when the pull wire is exposed at both ends of the routing path. Disconnect the sensor from the pull wire. INSTALLATION Securely attach the CKP sensor pigtail to the lower end of the pull wire. Pass the pigtail connector between the oil cooler lines and the engine block. Using the pull wire as a guide, pull the sensor pigtail along the top of the oil cooler lines and around to the rear of the engine. Use the pull wire to pull the pigtail into position. Disconnect the pull wire from the sensor pigtail. Connect the sensor pigtail to the harness connector. Thoroughly clean the mating surfaces of the CKP sensor and the engine block. Install the CKP sensor with a new O-ring seal into the engine block. Install the fastening bolt (1) for the CKP sensor. Check the harness for proper routing. Make sure that the wiring cannot come in contact with the exhaust manifold. Tighten the oil cooler lines at the engine block. Install the oil filter. Lower the vehicle. Recheck the engine oil level.

Jun 22, 2016 | 2001 Cadillac Catera

1 Answer

Wiring pigtail input speed sensor on my 2000 sonata. The new plug came with three white wires but the wires from car are different colors. color wiring diagram ?


the connector is the same on both the old harness and the new pigtail. As long as you orientate the connectors the same way you just match up the wires. let me try to explain it this way. If you hold the old connector so the part that holds the connector to the sensor is facing up. Hold the new connector exactly the same way. cut the left wire on both and connect the new connector wire to the old wiring harness. Then cut the center wire and connect them. then cut the right wire and connect. No wiring diagram needed.

One thing I will add is to stagger the new connections. Meaning do nut cut them at the place. Cut one wire then cut the next about an inch or so further and then cut the next about an inch or so further than that. This will prevent the new connections from potentially shorting to each other and will keep the harness from becoming really bulky with all the but connectors in the same location.

Oct 02, 2015 | Cars & Trucks

1 Answer

Trouble shoot


I believe that's a Speed Sensor issue.

Diag:
1. Ensure mainshaft and countershaft speed sensors are installed properly. Disconnect mainshaft speed sensor harness connector. Using a DVOM, measure resistance between sensor terminals.

2. If resistance is not 400-600 ohms, replace mainshaft speed sensor. If resistance is 400-600 ohms, disconnect 25-pin PCM harness connector "B". Check for continuity between ground and 25-pin PCM harness connector "B", terminals No. 15 (Red wire) and No. 14 (White wire).

3. If continuity is present, repair short to ground in Red or White wire between PCM and mainshaft speed sensor. If continuity is not present, reconnect mainshaft speed sensor harness connector. Measure resistance between 25-pin PCM harness connector "B", terminals No. 15 (Red wire) and No. 14 (White wire).

4. If resistance is not 400-600 ohms, go to next step. If resistance is 400-600 ohms, go to DTC
P0720 (FLASH CODE 9) . Check for loose PCM harness connectors. Replace PCM with a
known-good unit if necessary.

5. Disconnect mainshaft speed sensor harness connector. Check Red wire for continuity between 25-pin PCM harness connector "B", terminal No. 15 and mainshaft speed sensor harness connector. If continuity is present, go to next step. If continuity is not present, repair open in Red wire between 25-pin PCM harness connector and mainshaft speed sensor
harness connector.

6. Check White wire for continuity between 25-pin PCM harness connector "B", terminal No. 14 and mainshaft speed sensor harness connector. If continuity is present, check for loose PCM harness connectors. Replace PCM with a known-good unit if necessary. If continuity is not present, repair open in White wire between 25-pin PCM harness connector and mainshaft speed sensor harness connector.

Mar 21, 2014 | 1998 Acura Integra

1 Answer

Car


Speed Sensor probably. Try:
1. Ensure mainshaft and countershaft speed sensors are installed properly. Disconnect mainshaft speed sensor harness connector. Using a DVOM, measure resistance between sensor terminals.

2. If resistance is not 400-600 ohms, replace mainshaft speed sensor. If resistance is 400-600 ohms, disconnect 25-pin PCM harness connector "B". Check for continuity between ground and 25-pin PCM harness connector "B", terminals No. 15 (Red wire) and No. 14 (White wire).

3. If continuity is present, repair short to ground in Red or White wire between PCM and mainshaft speed sensor. If continuity is not present, reconnect mainshaft speed sensor harness connector. Measure resistance between 25-pin PCM harness connector "B", terminals No. 15 (Red wire) and No. 14 (White wire).

4. If resistance is not 400-600 ohms, go to next step. If resistance is 400-600 ohms, go to DTC
P0720 (FLASH CODE 9) . Check for loose PCM harness connectors. Replace PCM with a
known-good unit if necessary.

5. Disconnect mainshaft speed sensor harness connector. Check Red wire for continuity between 25-pin PCM harness connector "B", terminal No. 15 and mainshaft speed sensor harness connector. If continuity is present, go to next step. If continuity is not present, repair open in Red wire between 25-pin PCM harness connector and mainshaft speed sensor
harness connector.

6. Check White wire for continuity between 25-pin PCM harness connector "B", terminal No. 14 and mainshaft speed sensor harness connector. If continuity is present, check for loose PCM harness connectors. Replace PCM with a known-good unit if necessary. If continuity is not present, repair open in White wire between 25-pin PCM harness connector and mainshaft speed sensor harness connector.

Mar 21, 2014 | 1998 Acura Integra Type R

1 Answer

Alternator wiring harness


An alternator can run on two wires, the thick wire is the supply to charge the battery, direct to positive, via fuse box or starter supply. The thin wire possibly blue on Fords, is the energiser wire from the dash charge light, without this connected the alternator will not charge. If on the new pigtail two wires are thick (30amp) you can ignore one, some vehicles double up on the charge supply wire.

Dec 20, 2013 | 2004 Ford Escape

1 Answer

My speedometer not working? is it cause of the after-market radio i put in be the reason.. mitsubishi galant 2002 6 cylinder


So we can rule out the speed sensor and its circuit to the PCM.

I just checked through another area of my database and it seems the speed sensor is systated as on the side of transaxle, near firewall, maybe you can dheck that out to confirm, just out of curiosity and for future reference and some portion of testing requires unplugging the conections.

Anyway I will provide a complete diagnostic pocedures for you to check through and hope an answer is found.

PS. After going through the diagnostic procedure, I believe your radio is the cause of the problem. Refer to # 10

SPEEDOMETER DOES NOT WORK

1. Connect scan tool to data link connector, check for Diagnostic Trouble Code (DTC). If DTC P0500 (Vehicle Speed Sensor) is set, diagnose this DTC first. Go to step 6 . If DTC P0500 is not set, go to next step.

2. On Eclipse, if trip odometer is not working normally, go to next step. If trip odometer is working normally go to step 5. On Galant, if tachometer is not working normally, go to next step. If tachometer is working normally, go to step 5

3. Disconnect instrument cluster connector. Turn ignition switch to ON position. Connect DVOM between ground and instrument cluster connector terminal No. 52 (Black/White wire) on Eclipse or terminal No.29 (Black/White wire) on Galant. If battery voltage is present, go to next step. If battery voltage is not present, check harness connectors and harness wiring between instrument cluster and ignition switch for damage. Repair as necessary.

4. Using a DVOM, check resistance between ground and instrument cluster harness connector terminal No. 34 (Black wire) on Eclipse or terminal No. 30 (Black wire) on Galant. If resistance is less than 2 ohms, replace instrument cluster printed circuit board or speedometer and tachometer. If resistance is greater than 2 ohms, check instrument cluster connector and harness wiring. Repair as necessary. If connector and wiring are okay, go to next step.

5. Disconnect vehicle speed sensor connector and instrument cluster connector. Turn ignition switch to ON position. Connect DVOM between ground and harness side of instrument cluster connector terminal No. 29 (White/Blue wire) on Eclipse or terminal No. 16 (Yellow/Black wire) on Galant. Voltage should be 5 volts. If voltage is okay, repair or replace instrument cluster printed circuit board or speedometer and tachometer. If voltage is not 5 volts, check instrument cluster connector and harness wiring. Repair as necessary. If connector and wiring are okay, go to next step.

6. Disconnect vehicle speed sensor harness connector and connect DVOM to harness side. Check vehicle speed sensor power supply voltage between terminal No. 1 (Black/White wire) on Eclipse or (Black/Blue wire) on Galant and ground. Battery voltage should be present. If voltage is okay, go to next step. If voltage is not present, check vehicle speed sensor harness connector and wiring. Repair as necessary.

7. Using DVOM, check resistance between ground and vehicle speed sensor harness connector terminal No. 2 (Black wire). Resistance should be less than 2 ohms. If resistance is greater than 2 ohms, check instrument cluster connector and harness wiring. Repair as necessary. If connector and wiring are okay, go to next step.

8. Disconnect vehicle speed sensor harness connector. Connect DVOM between ground and harness side terminal No. 3 (White/Blue wire) on Eclipse or (Yellow/Black wire) on Galant. If 9 volts are not present, check vehicle speed sensor harness connector and wiring. Repair as necessary. If 9 volts are present, go to next step.

9. Check harness wiring between vehicle speed sensor connector to radio and tape player connector, auto-cruise control ECU ECM (M/T) or PCM (A/T) connector and instrument cluster connector. If connectors or wiring are damaged, repair as necessary. If connectors and wiring are okay, go to next step.

CAUTION: To prevent damage to scan tool, always turn ignition off before connecting or disconnecting scan tool.

NOTE: If ECM (M/T) or PCM (A/T) is replaced, immobilizer-ECU should also be replaced. Each ECM (M/T) or PCM (A/T) has an encrypted code for immobilizer-ECU, and is registered in immobilizer-ECU.

10. Connect scan tool to data link connector. Turn ignition switch to ON position. Read DTC. Disconnect radio and tape player connector. If DTC P0500 does not reset, replace radio and tape player. If speedometer does not work, disconnect auto-cruise control ECU connector. If DTC P0500 does not reset, replace auto-cruise control ECU. If speedometer does not work, disconnect instrument cluster harness connector. If DTC P0500 does not reset, replace instrument cluster. If DTC P0500 resets when any connector is disconnected, replace ECM (M/T) or PCM (A/T).
9_6_2012_10_56_48_am.gif9_6_2012_10_57_03_am.gif9_6_2012_10_57_17_am.jpg9_6_2012_10_57_28_am.jpg9_6_2012_10_57_39_am.jpg9_6_2012_10_57_52_am.jpg9_6_2012_10_58_05_am.jpg9_6_2012_10_58_16_am.jpg

Sep 06, 2012 | Cars & Trucks

2 Answers

2000 acura tl engine code PO132 what does it mean


Oxygen sensor circuit issues. Check wiring for possible melted insulation or bad connection at connector.If wiring looks good run tests to diagnose. Sensor one, bank one is below the exhaust manifold on the passenger side of the engine.

TESTING4-WIRE SENSOR
4-wire sensors are HO2 sensors.
On 4-wire sensors, one of the connector terminals is the SOUT, one of the terminals is the SGND, one of the terminals is the HPWR and the other is the HGND. To identify the 4 terminals, perform the following:
  1. Locate the O2 sensor (#2 in pic below) and its pigtail connector. It may be necessary to raise and safely support the vehicle to gain access to the connector.
jturcotte_2458.gif
  1. Disengage the sensor pigtail connector from the vehicle harness connector.
  2. Using a DVOM set to read 12 volts, attach the DVOM ground lead to a good engine ground.
  3. Have an assistant turn the ignition switch ON without actually starting the engine.
  4. Probe all 4 terminals in the vehicle harness connector. One of the terminals should exhibit 12 volts of power with the ignition key ON; this is the HPWR terminal.
    1. If the HPWR terminal was identified, note which of the sensor harness connector terminals is the HPWR, then match the vehicle harness connector to the sensor pigtail connector. Label the corresponding sensor pigtail connector terminal with HPWR.
    2. If none of the terminals showed 12 volts of power, locate and test the heater relay or fuse. Then, perform Steps 2-6 again.

  1. Have your assistant turn the ignition OFF
  2. Using the DVOM set to measure resistance (ohms), attach one of the leads to the HPWR terminal of the sensor pigtail connector. Use the other lead to probe the 3 remaining terminals of the sensor pigtail connector, one at a time. The DVOM should show continuity with only one of the remaining unidentified terminals; this is the HGND terminal.
    1. If continuity was found with only 1 of the 2 unidentified terminals, label the HGND terminal on the sensor pigtail connector.
    2. If no continuity was evident, or if continuity was evident from all unidentified terminals, the O2 sensor is defective.
    3. If continuity was found at 2 of the other terminals, the sensor is probably defective. However, the sensor may not necessarily be defective, because it may have been designed with the 2 ground wires joined inside the sensor in case one of the ground wires is damaged; the other circuit could still function properly. Though, this is highly unlikely. A wiring diagram is necessary in this particular case to know whether the sensor was so designed.

Reattach the sensor pigtail connector to the vehicle harness connector. Start the engine and allow it to warm up to normal operating temperature, then turn the engine OFF. Using a DVOM set to read 100-900 mV (millivolts) DC, backprobe the negative DVOM lead to one of the unidentified terminals and the positive lead to the other unidentified terminal.

CAUTION While the engine is running, keep clear of all moving and hot components. Do not wear loose clothing. Otherwise severe personal injury or death may occur.
  1. Have an assistant restart the engine and allow it to idle.
  2. Check the DVOM for voltage.
    1. If no voltage is evident, check your DVOM leads to ensure that they are properly connected to the terminals. If still no voltage is evident at either of the terminals, either the terminals were accidentally marked incorrectly or the sensor is defective.
    2. If voltage is present, but the polarity is reversed (the DVOM will show a negative voltage amount), turn the engine OFF and swap the 2 DVOM leads on the terminals. Start the engine and ensure that the voltage now shows the proper polarity.
    3. If voltage is evident and is the proper polarity, the positive DVOM lead is attached to the SOUT and the negative lead to the SGND terminals.
  1. Have your assistant turn the engine OFF.
  2. Label the sensor pigtail SOUT and SGND terminals.
REMOVAL and INSTALLATION
WARNING The sensors use a pigtail and connector. This pigtail should not be removed from the sensor. Damage or removal of the pigtail or connector could affect proper operation of the oxygen sensor. Keep the electrical connector and louvered end of the sensor clean and free of grease. NEVER use cleaning solvents of any type on the sensor! The sensor may be difficult to remove when the engine temperature is below 120°F (48°C). Excessive removal force may damage the threads in the exhaust manifold or pipe; follow the removal procedure carefully.
  1. Make sure the ignition is OFF, then disconnect the negative battery cable.
  2. Locate the oxygen sensor. It protrudes from the exhaust manifold or exhaust pipe (it looks somewhat like a spark plug). It may be necessary to raise and safely support the vehicle to access the sensor.
  3. Unplug the sensor electrical connector.
jturcotte_2459.gif

Fig. Fig. 5: Loosen the oxygen sensor using a wrench as shown, or use a sensor socket made especially for that purpose

  1. Carefully unscrew the sensor, then remove the oxygen sensor from the manifold or pipe.

To install:
  1. During and after the removal, be very careful to protect the tip of the sensor if it is to be reused. Do not let it to come in contact with fluids or dirt. Do not clean it or wash it.
  2. Apply a coat of anti-seize compound to the bolt threads but DO NOT allow any to get on the tip of the sensor.
  3. Install the sensor in the manifold or exhaust pipe.
  4. Attach the electrical connector and ensure a clean, tight connection.
  5. If raised, carefully lower the vehicle.
  6. Connect the negative battery cable.

Nov 02, 2011 | 2000 Acura TL

1 Answer

I have a code P320 on my 1999 Jeep Grand. What do I need to replace and how? Thanks for your help. John


Replace the crank sensor.


360dreamworx_25.gif
The Crankshaft Position (CKP) sensor is mounted to the transmission bellhousing at the left/rear side of the engine block. The sensor is adjustable and is attached with one bolt. A wire shield/router is attached to the sensor.

REMOVAL
  1. Disconnect sensor pigtail harness (3-way connector) from main engine wiring harness.
  2. Remove sensor mounting bolt.
  3. Remove wire shield and sensor.
INSTALLATION
New replacement sensors will be equipped with a paper spacer glued to bottom of sensor. If installing (returning) a used sensor to vehicle, a new paper spacer must be installed to bottom of sensor. This spacer will be ground off the first time engine is started. If spacer is not used, sensor will be broken the first time engine is started.
  1. New Sensors: Be sure paper spacer is installed to bottom of sensor. If not, obtain spacer PN05252229.
  2. Used Sensors: Clean bottom of sensor and install spacer PN05252229.
  3. Install sensor into transmission bellhousing hole.
  4. Position sensor wire shield to sensor.
  5. Push sensor against flywheel/drive plate. With sensor pushed against flywheel/drive plate, tighten mounting bolt to 7 Nm (60 in. lbs.) torque.
  6. Route sensor wiring harness into wire shield.
  7. Connect sensor pigtail harness electrical connector to main wiring harness.

Jul 12, 2011 | 1999 Jeep Grand Cherokee

1 Answer

My speed don't work


Speed Sensors REMOVAL & INSTALLATION Front Fig. 1: The speed sensor sits directly over the exciter ring in the front knuckle 89609p51.jpg
Fig. 2: Detach the speed sensor connector in the engine compartment 89609p55.jpg
Fig. 3: Remove the speed sensor harness from the routing clips 89609p53.jpg
Fig. 4: A special E6 Torx® socket is required to remove the speed sensor retaining bolt 89609p52.jpg
  1. Disconnect the negative battery cable.
  2. From inside engine compartment, detach sensor assembly 2-pin connector from the wiring harness.
  3. Remove the steel routing clip attaching the sensor wire to the tube bundle on the left sensor or remove the plastic routing clip attaching the sensor wire to the frame on the right sensor.
  4. Remove the rubber coated spring steel clip holding the sensor wire to the frame.
  5. Remove the sensor wire from the steel routing clip on the frame and from the dust shield.
  6. Remove the sensor attaching bolt from the front spindle and slide the sensor out of the mounting hole. To install:
  7. Install the sensor into the mounting hole in the front spindle and attach with the mounting bolt. Tighten to 40–60 inch lbs. (4.5–6.8 Nm).
  8. Insert the sensor routing grommets into the dust shield and steel bracket on the frame. Route the wire into the engine compartment.
  9. Install the rubber coated steel clip that holds the sensor wire to the frame into the hole in the frame.
  10. Install the steel clip that holds sensor wire to tube bundle on left side or plastic clip that holds sensor to frame on right side.
  11. Reconnect the 2-pin connector to wire harness. Connect the negative battery cable.
Rear Fig. 5: Detach the speed sensor connector in the luggage compartment 89609p04.jpg
Fig. 6: Grasp the harness and . . . 89609p37.jpg
Fig. 7: . . . remove it from the routing brackets 89609p36.jpg
Fig. 8: The rear speed sensor is mounted on the back of the hub assembly 89609p32.jpg
Fig. 9: Remove the sensor retaining bolt and remove the sensor from the hub 89609p34.jpg
  1. Disconnect the negative battery cable.
  2. From inside luggage compartment, detach 2-pin sensor connector from wiring harness and push sensor wire through hole in floor.
  3. From below vehicle, remove sensor wire from routing bracket located on top of rear axle carrier housing and remove steel clip holding sensor wire and brake tube against axle housing.
  4. Remove screw from clip holding sensor wire and brake tube to bracket on axle.
  5. Remove sensor to rear adapter retaining bolt and remove sensor. To install:
  6. Insert sensor adapter and install retaining bolt. Tighten to 40–60 inch lbs. (4.5–6.8 Nm).
  7. Attach the clip holding the sensor and brake tube to the bracket on the axle housing and secure with the retaining screw. Tighten the screw to 40–60 inch lbs. (4.5–6.8 Nm).
  8. Install steel clip around axle tube that holds sensor wire and brake tube against axle tube and push spool-shaped grommet into clip located on top of axle carrier housing.
  9. Push sensor wire connector up through hole in floor and seat large round grommet into hole.
  10. Reconnect sensor 2-pin connector to wiring harness inside luggage compartment.

Aug 03, 2010 | 1992 Ford Crown Victoria

1 Answer

Where Are The sensor Banks On The 2004 GC


Grand Cherokee oxygen sensor locations for 4.0 and 4.7 engines

510d5d9.jpg


f8b5293.jpg


Four wires (circuits) are used on each O2 sensor:

  • 12–volt feed circuit for the sensor heating element
  • Ground circuit for the heater element
  • Low-noise sensor return circuit to the PCM
  • Input circuit from the sensor back to the PCM to detect sensor operation

O2S Sensor removal Never apply any type of grease to the oxygen sensor electrical connector, or attempt any soldering of the sensor wiring harness.
WARNING: THE EXHAUST MANIFOLD, EXHAUST PIPES AND CATALYTIC CONVERTER(S) BECOME VERY HOT DURING ENGINE OPERATION. ALLOW ENGINE TO COOL BEFORE REMOVING OXYGEN SENSOR.
1. Raise and support vehicle.
2. Disconnect O2S pigtail harness from main wiring harness.
3. If equipped, disconnect sensor wire harness mounting clips from engine or body.
CAUTION: When disconnecting sensor electrical connector, do not pull directly on wire going into sensor.
4. Remove O2S sensor with an oxygen sensor removal and installation tool.

02S Sensor installation
Threads of new oxygen sensors are factory coated with anti-seize compound to aid in removal. DO NOT add any additional anti-seize compound to threads of a new oxygen sensor.
1. Install O2S sensor. Tighten to 22 ft. lbs. (30 N·m) torque.
2. Connect O2S sensor wire connector to main wiring harness.
3. If equipped, connect sensor wire harness mounting clips to engine or body. When Equipped: The O2S pigtail harness must be clipped and/or bolted back to their original positions on engine or body to prevent mechanical damage to wiring.


Hope thats help (remember comment and rated this).

Apr 29, 2010 | 2004 Jeep Grand Cherokee

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

13 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

yadayada
yadayada

Level 3 Expert

75822 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Randy Ohler

Level 3 Expert

14585 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...