Question about Cars & Trucks

1 Answer

My S350 2008, 120,000 klm has a slight miss when accelerating. Mainly second/3rd gear I think. Has just had a service and new plugs.Would an additive injector cleaner help?

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Cars & Trucks Master
  • 46,561 Answers

A quality injector cleaner would not go astray but I would take it back to the service center for a code check to determine if anything else is faulty

Posted on Apr 17, 2017

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Mechanic can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to a Mechanic (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2008 zetec Focus 1.8, slight miss fire when accelerating in fourth gear, pulling onto motorway yesterday and tried to accelerate and it was as if something was holding me back


A miss under load on a Focus is usually a bad or failing coil on one or more of the plugs.Also how old are the spark plugs?

May 08, 2017 | Cars & Trucks

1 Answer

While running slight missing when accelerating


service the car
chage plugs and fue filter

Sep 17, 2016 | 2005 Honda Jazz 1.4

1 Answer

When accelerating through the gears as i drive. I get a vibration when i hit second gear. Then when i hit 3rd gear, it feels like it slips and revs around 3,4k rpm, accelerating really slow. When i hit 4th...


sounds like 3rd gear/clutch is worn.I don't think a service will do any good.But if you remove the pan and find debris you know you will need a trans in the near future.

Dec 03, 2010 | 1992 Buick Park Avenue

1 Answer

Service engine soon code 3rd. cyclinder miss


sorry but,,if u have a miss fire in #3 ,,that's coil or wire or plug or injector,,,dont know y they replaced the battery or alt unless they were bad??? hope it helps

May 24, 2010 | 2003 Lincoln LS

1 Answer

I have a 2000 Lincoln C with a 4.6 engine. This


I think you need transmission fluid serviced with Mercon V from a Mercury dealer. I think the friction shoes in the torque converter are "Chattering" at lock up.

Try driving the car with O/D off and then w/o going into 4th gear. Leave it in 3. See if the vibration is gone.

Feb 12, 2010 | 2000 Ford Expedition

1 Answer

On acceleration it it misses through 1st 2nd 3rd gear.......runs better when cold... might be egr... disconnected the hose to valve.. still lacks power... put new carb gaskets... thought there might be a...


Sound slike some of the things you mentioned, could likely be causeing the problem. A vaccum leak would steal from the acceleration. also the EGR. You may just need a tune up. New plug, wires, filters, the whole deal.

Nov 20, 2009 | 1983 Ford Ranger

1 Answer

Hang up in third gear loss of power


Hi All

I have a s40 1.9d / 2000 plate,
In the last month or so the car loses revs when changing up to 3rd and 4th gear, I can only get 50 mph max in 3rd gear 80mp in 4th.
The car has just clocked 185,000 miles
Its a great car but a pai at the moment, I've had a service including fuel fillter change added fuel cleaners to the deilsel all to no avail


Any suggestions

Jul 06, 2009 | 2000 Volvo S40

2 Answers

Surges on acceleration


i would really change the fuel filter, spark plugs and that should do it

Jun 23, 2009 | 2000 Chevrolet Silverado 1500

2 Answers

Slight miss in engine, hard shift from 1st to 2nd long 2nd gear


Check both O2 sensor(s) and catalytic coverter.. P0420 means catalyst below threshold. Also check the sensor at the transmission and solenoid.

Feb 06, 2009 | 1995 Chevrolet Blazer

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

14 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

yadayada
yadayada

Level 3 Expert

77169 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22265 Answers

Randy Ohler

Level 3 Expert

14585 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...