Question about Cars & Trucks

Open Question

My iveco stralis 360 has suddenly lost power no lights on dash just has no power i have changed fuel filters but it made no difference. any ideas

Posted by on

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
sawdust46694
  • 398 Answers

SOURCE: van runs great all of sudden no gas response an

fuel screen in the tank is pluged up remove tank and change pump and screen!

Posted on Nov 03, 2009

Ad
  • 117 Answers

SOURCE: lost of power when accelerate, changed fuel filter

im assuming since u say u changed fuel filter that this is acummins diesel. and when u say that made it wirse it makes me suspect a failing/failed lift pump. the lift pump supplies low pressure fuel to your injection pump which creates the pressure for your engine to make hp/torwue sounds like enigine may have been starving for fuel then when filter replaced air in system caused further starvation. replace your lift pump

Posted on Nov 15, 2009

  • 538 Answers

SOURCE: Ford ranger suddenly lost power changed the fuel

Are in a cold climate, gas line freeze? Try puting gas line anti-freeze in the tank. Otherwise, it could be the fuel pump is going out. Check the fuel pressure or have it checked if don't have the proper tools to do it.

Posted on Dec 31, 2009

elix0411
  • 3530 Answers

SOURCE: Traveling 70 miles per hr.,

Welcome to Fixya

If the power (electricity) itself dies while you are driving then the problem is more of electrical issue. If the vehicle just looses the power to move but all lights are ok, headlight are working, horn is working etc.. then the problem would be the fuel system. Check the fuel pump and the fuel pump relay since you already replaced the filter.

Thank you for using Fixya!

Posted on May 16, 2011

  • 9 Answers

SOURCE: I have a 89 dodge lancer with out turbo it was

It could be the chrankshaft sensor or the egnition coils. check to make sure that your plugs are getting spark.Can be a lot of things but this is a place to start.

Posted on Feb 18, 2012

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My iveco 430 stralis euro3 not picking up revs. Whst can be the problem?


run the fault codes and look for a accelerator position sensor or throttle position motor problem

Jan 22, 2016 | Cars & Trucks

2 Answers

What is ETC fault at Iveco STralis?


our iveco stralis truck get etc 2f / etc 30 / etc38 so how can solve the proplems

Apr 09, 2013 | Cars & Trucks

1 Answer

Iveco stralis 360 truck engine loss of power no lights on dash board


Do you mean it runs but has no grunt?
Or do you mean there is no electricity to power the dash?
Or do you mean there are no warning lights on the dash?
Have you checked the air filter element?
I need more information.

Feb 24, 2013 | Ford Mondeo Cars & Trucks

1 Answer

The engine light came on the dash and started blinking. Car is spuddering, barley accelerates, seems to have lost most of its power


this could be a fuel filter issue, but more than likely it sounds like a broken down / clogged catalytic converter. to confirm, have an exhaust back pressure test performed. this is a specialized gauge that threads into the oxygen sensor fittings and will tell you if there is excessive restriction. if you plan on keeping this car for a while (more than a year) i recommend using a genuine GM replacement, as the cheaper ones do not last long at all. in any even, it is good idea to change the fuel filter first. good luck!

Aug 31, 2010 | Chevrolet Cobalt Cars & Trucks

1 Answer

I have a 98 blazer the service engine soon light came on & I lost power I managed to limp it home. Changed cap, rotor, igintion coil, spark plugs & wires still running crappy. What next can someone...


could be fuel pump, fuel filter, air filter, o2 sensor though not usually all of a sudden. could also be that the distributor may have loosened and turned a 16th of an inch or more which would have caused this as well. check this by making sure your number one plug wire on the distributor is toward the number one plug on the motor. also you could have jumped time. check your belt or chain.

Aug 22, 2010 | 1998 Chevrolet Blazer

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

27 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

yadayada
yadayada

Level 3 Expert

76649 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Randy Ohler

Level 3 Expert

14585 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...