Question about 1999 Chevrolet Blazer

1 Answer

This evening the battery positive battery cable post melted down and rendered the battery useless. I took the battery to auto zone and got a new one .They suggested to me that a commom cause of my problem was loose connecor terminals. I n reflection I remembered having to tighten them b4 and had.nt done so lately. After installing new battery the car started ans ran fine-EXCEPT- when I applied brakes----they went all the way to floor and only rear brakes worked. Check wheels for fluid leakage= none, Checked master cylinder=full. Is there s fuse that could have blown when battery malfunctioned??I am at total loss as to what happened.

Posted by on

  • ritzkit Jul 24, 2009

    have new problem that supercedes this one!!! car running then stopped lights out nothing tryed jumping loose cables and met with sparks polarity correct as i tryed jumping new battery and it sparked put key in turn nothing nada zilch no lights nothing must be a short in system or a fuse really desperate ty

  • ritzkit Jul 24, 2009

    didnt totally solve problem but was veryhelpful

×

Ad

1 Answer

If the brake pedal goes to the floor with little resistance then the master cylinder is your problem...Is the check engine light or ABS light on in the instrument cluster dispay after you changed the battery to a new one? Did you have someone look outside the front wheel (with the tire off so you can see the caliper) to see if the front brake caliper was gripping the disc while you press the brake pedal? Try this, unplug the positive battery again and then plug it back in after a few hours and see if the situation changes and let me know if it does

Posted on Jul 24, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

3 Answers

Battery is new wont hold a charge alt is good


You might have a bad cell in the battery even if the battery is new I had that happen to me one time I took the battery in to Auto Zone thats when they told me it had a bad cell.

Mar 14, 2015 | 2007 Jeep Compass 2.4

1 Answer

I have a 1998 oldmobile intiuge. i went to auto zone to check my alternator and it was good and change the batteries post and new got a new battery and something still draining my battery


How you check a drain. First you will always have a drain if you have a clock in the dash or in your radio. It will be small. Disconnect the positive battery cable and put a test light in line. Watch the light and start pulling fuses when the go's out you will know what to look at for the draw

Nov 10, 2013 | Cars & Trucks

1 Answer

Car won't start except when charger hooked to red cable


I would expect to find too much corrosion on the positive cable end.

Jul 11, 2013 | Cars & Trucks

1 Answer

Replace battery cable ends 93 geo prism


cut old wires off with lineman pliers go to auto zone and buy 2 ends weather it's side post or top post and strip about half a inch of the insulation off and tighten the bolts down

Jul 23, 2012 | 1993 Geo Prizm

2 Answers

How to change the battery the connections are on the side of the battery never changed this type theyre usually on top of the battery


Just remove the bolts with a 12 point socket or wrench. Just turn them counter-clockwise and they will come out

Oct 06, 2010 | 1992 Cadillac DeVille

2 Answers

OVERHEATED BATTERY CABLE


Hi, this normally indicates high amperage draw. If your check engine light is not on and all seems to be working fine, take a good look at this cable for acid build-up. Dirty connection will cause this. You may have acid build-up inside the insulation on this cable you can't see, as it will crawl up the cable to its other connection point, ground or starter solenoid. Check the condition of the battery also. If you run it by a Auto-Zone parts store, they can for no charge run a load check on the battery for free to check its values. Theses are the things to look at. Keep me posted.
Sincerely,
Shastalaker7

Mar 11, 2010 | 2000 Ford Focus

1 Answer

I have a 96 Ford Probe that I purchased a few weeks ago. I had both of the belts and the thermostat replaced and then I started losing power so I was told to replace the battery cables and terminals. I did...


Sorry I can't so much for you on this one except tell you that you have a hot wire or cable grounding out somewhere. I obviously is a large power line since it melts the positive post when contact is made. Check the positive cable that runs down to the starter. It may have been pinched or possibly melted through the rubber case that encloses the cable. Follow the cable from the batery or soleniod down to the starter and check where it may have come into contact with the hot exhaust and melted through. Good luck I hope this gives you a good starting point. Let me know the outcome. I would be glad to help more if you need it.

Feb 24, 2009 | 1996 Ford Probe

1 Answer

1995 olds 88 positive battery cable stuck together


Crazyshaws:

Normally the bolt that tightens the clamp that fits down over the positive post of the battery can be removed from the cable. What happens on older cars is the bolt get all fouled up and corroded. This happened recently to me on my 94 F150. What I did was to cut the bolt in the middle with a hacksaw, then went to the auto parts store and bought a new bolt & nut for the cable and installed it. They even have packages of 2 nuts and bolts right near where the batteries are sold.

Hope this helps Good luck Loringh PS Please leave a rating if appropriate Thks

Nov 15, 2008 | 1995 Oldsmobile Eighty Eight

1 Answer

2003 Ford Ranger (Mazda B2300) won't start via starter or push


Did you remove the faulty cable and replace it with a new one? sometimes a cable can be so badly corroded it's rendered useless, as the corrosion can travel all the way along the cable, if you have a multi tester check the resistance ( Ohms ) using the top and end of the affected cable, you should get a high pitched sound when you connect both ends ( to the meter ) thewad001

Mar 31, 2017 | 2003 Ford Ranger Regular Cab

Not finding what you are looking for?
1999 Chevrolet Blazer Logo

Related Topics:

21 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76109 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8269 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...