Question about Mitsubishi Eclipse

1 Answer

My aftermarket gauge lights don't work anymore and my panel lights have turned off. the gauges will work after messing with the rear windshield wippers. very strange. but i don't know when to start

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 12 Answers

If its mugan fix em if its ebay sell em and go stock

Posted on Jul 23, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Mechanic can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to a Mechanic (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I just bought a 1983nissan 280zx 2+2 non turbo.drivers side rear running light ot wing But drivers side turn signal is checked bulb fuses ect. also oil gage volt and clock work sometimes and sometimes


You said same socket, so it couldn't be a bad ground or then neither light would work. And you also said there is no power on the tail light wire at the socket? There should be voltage on the wire with park lights on. Find the rear tail harness. Somewhere there at the rear of the car the park light wire (the tail lights, running lights, all the same) will splice off to both sides of the car. You have passenger side lights, so you know the signal is good that far. Somewhere between the splice and the driver's side, the power is lost, maybe right at the splice. So find the harness, it will be either under the car along the frame, or inside the trunk. That's an old effin car, Howard. Are you sure you want to nurse it back to life? lol. Buy a Haynes manual for it - it will save you money in repairs. Good wiring diagrams, too.
Are those gauges in the instrument panel, and not aftermarket? If they are in the dash, I may know what it might be. I have an '87 Sentra. Fuel gauge, temperature gauge, and warning lights, and turn signals would only work intermittently. Car would start and run, but those things- sometimes not, or they would come on way after down the road. I traced it down to a faulty ignition relay in a relay block above the instrument fuse panel. The run wire out of the ignition switch trips this relay on, and it sends power to a portion of the fuse panel that has the fuses for the gauges and turn signal lights. Replacing the relay was the answer-they always work now. Your gauges may be similar, but almost as likely a loose connection somewhere.

Mar 31, 2014 | 1983 Nissan 280ZX

1 Answer

Light switch is controling my gauges


some thing not grounded proplery

Jun 09, 2013 | 1999 Jeep Cherokee

1 Answer

Light is flicking in cab when turn them on and gas gauge is messed up


Your voltage meter will be located in with your insturment panel, If you don,t have a voltage guage, There will be a idiot light that stays on while you are opperateing the vehicle,To let you no that there is a problem with the chargeing system,Hope this helps you out, Have anouther (Beer) LOL:

Nov 03, 2012 | Cars & Trucks

1 Answer

2005 Dodge Durango. Amp Shortage?? suspect water leak in area of amp. Now no sound at all. No radio, navigation system, cd player, sattelite radio


many of these 04-06 durangos have a leak problem at the top of the windshield on passenger side which leads to water getting into the passenger kickpanel where the amplifier is located. I had my windshield replaced for a crack and there was rust forming behind the top passenger side of windshield...( same with the rear hatch above the passenger side of the chrome molding that covers the handle. My radio went on and off depending on when it rained. Now it doesn't work at all. I plan to check for fuses related to the amp tonight to decipher whether the fuse just blew or that the amp was fried from the water.

Feb 24, 2012 | 2005 Dodge Durango

1 Answer

I have a 1996 ford explorer, the person who had it before had someone install an aftermarket cd player in it and now the door speakers nor the rear speakers work anymore, also the dash lights no longer...


Look for inst. lites fuse and clean the connectors at the fuse panel. The stereo speakers might have come loose from a poor wiring job. Look under the dash below the radio. Sometimes the dash light switch gets worn and doesn't work until you mess with it a little.

Mar 15, 2011 | 1996 Ford Explorer

1 Answer

I have a 1983 Chevy S10 pickup. With headlights off all gauges work normal. When you pull the headlight switch on all the panel lights except the windshield wiper switch locator light never turn on and all...


take a look at the dash ground wire located next to the right of ebrake release handle. if the bole holding the ground wire is loose, which was quite common it will cause all kinds of feed back problems, like described in the comments section to your question.

Dec 11, 2010 | 1983 Chevrolet S-10

1 Answer

1984 FIERO 4 CYL STICK. had a aftermarket elec temp gauge mounted on console, replaced with a mech temp gauge. after replacing temp gauge is when the fuel gauge messed up. now when you turn on the key or...


I assume you replaced the temperature sending unit when you installed the aftermarket gauge? You need to put the proper sending unit back in for the OEM gauge to work.

You can find a sending unit here (and a gauge if needed):

http://www.fierostore.com/

Hope this helps

Nov 06, 2010 | 1984 Pontiac Fiero

1 Answer

Water temp mal function


Unfortunately No, All of the Guages run straight into the Computer. If you bypass them you will have error codes out the Wazzu and lights on the Dash Constantly. Try a Salvage yard for a Replacement Guage Cluster.

Jan 24, 2009 | 1999 Plymouth Neon

2 Answers

Dash Instrument Panel Lights are dead - gauges work fine


do you have taillights? most of the time there on the same fuse. also chk. to see if plug is all the way in on your headlight switch.

Jan 21, 2009 | 1993 Buick Park Avenue

1 Answer

Removed aftermarket radio from 1999 Wrangler, no gauges work now


first, you have to tape any open wires with electrical tape, so they DON"T short anything out again. second, check your gauge fuse.

Dec 04, 2008 | 1999 Jeep Wrangler

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

127 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mitsubishi Experts

yadayada
yadayada

Level 3 Expert

77186 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22265 Answers

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8737 Answers

Are you a Mitsubishi Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...