Question about 2000 Ford Expedition

1 Answer

I have replaced the camshaft sensor twice in the

I have replaced the camshaft sensor twice on a 7.3 diesel in the last few months and it has gone bad again not sure what is causing the problem

Posted by on

  • yadayada
    yadayada May 11, 2010

    MOST LIKEY THE CONNECTOR IS DEFECTIVE.

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 64 Answers

The 7.3 diesel has a recall on the crankshaft position sensor, if it is black it needs to be replaced, make sure this is not the problem leading you to false codes and makeing the camshaft sensor seem faulty.

Posted on Jul 22, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My honda dio is not giving ignition current 'sometimes'. Starter motor cranks when initiate the ignition but doesnt start.have replaced ignition coil & cdi unit but still its not fixed.


It might be the camshaft position sensor that has gone bad. Power does not go to the ignition coil at all when this sensor is bad. Most of the time the check engine does not come on at all when the camshaft position sensor is bad.

Sep 14, 2015 | Honda Cars & Trucks

1 Answer

03f250 7.3disel runs good gets hot shutsoff replaced camshaft sensor


Ford F250 Truck Overheating Why - Ford-Trucks

www.ford-trucks.com > ... > Powertrain > Cooling System
Nov 13, 2014 - Here are a few reasons why your Super Duty truck is overheating. ...6.0 Diesel · 1999-2003 7.3 Diesel · 1994.5-1997 7.3 Diesel · 1983-1994 7.3&6.9 Diesel... This article applies to the Ford F-250, F-350 Diesel (2005-2014).

Aug 26, 2015 | Ford Cars & Trucks

1 Answer

Problems with the oil sensor plug


Is this the oil pressure sensor or the oil level sensor?

Apr 30, 2014 | 2001 Buick Regal

1 Answer

I have a 2007 Mazda CX-7. It has been driving just fine (after a timing chain replacement and a turbo replacement in. The last 7 months. Last night (Friday) my check engine light came on. The guy at...


Here's what it says Heather,
  • The crankshaft position sensor identifies position of the crankshaft to the ignition control module (ICM), engine control module (ECM) or powertrain control module (PCM)
  • When not replaced, vehicle could experience no- or hard start, long crank time, misfire, lack of power, excessive hydrocarbons in oil, spark plug fouling, catalytic converter failure, poor fuel economy, CEL/MIL illumination or intermittent shutdown.I would say,go for it.

Mar 23, 2013 | 2007 Mazda CX-7 Grand Touring

2 Answers

Codep0016 what does it mean?


P0016 Chrysler

Crankshaft -camshaft timing misalignment bank 1 sensor 1
- The pcm detects that the camshaft position is out of phase with the crankshaft position

Probable Cause[s]

  1. Engine oil dirty or contaminated /Incorrect engine viscosity
  2. Open or short circuit condition
  3. Camshaft 1/1 position solenoid, camshaft phaser ,camshaft1/1 position sensor
  4. Crankshaft position sensor ,crankshaft,tone wheel or flex plate
  5. Camshaft,tone wheel or pulse ring

Mar 13, 2011 | 2006 Dodge Caravan

2 Answers

Where crank shaft and camshaft?


There are two cam shaft sensors and one crank sensor Nissian did sell a kit at one time with all the sensors in it one cam sensor is in the left cylinder head a one is in the right cylinder head

May 29, 2009 | 2002 Nissan Altima

1 Answer

BMW X5 2000 problem


There can be many causes for the car not starting. Generally it is usually a fuel or a distribution problem. Many fuel problems of this kind are related to electronic injection and ECU. This kind of troubles often need special equipment, and can be fixed only at a well equipped garage, where they can test fuel flow pressure and volume in monitoring ECU feedback at the same time.
Simple things you can do are
Checking and eventually replacing fuel filter.
Checking and eventually replacing air filter.
Check that there is no oil on top of new spark plugs.
In last case try to listen if car is running on three cylinders, this can leave uncombusted oil on cylinder, and mean there are troubles with distribution or camshaft.
It is useless replacing one of the sensors without testing them, and when a sensor is gone you usually get some additional light on your instrument panel. At a garage they will connect straight to the computer and get an error message in return, in case one of the sensors is bad.

Jul 23, 2008 | 2005 BMW X5

Not finding what you are looking for?
2000 Ford Expedition Logo

160 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

75005 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

fordexpert

Level 3 Expert

5470 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...