Question about 2001 Mercury Villager

1 Answer

Van begins to hesitate at 45 to 55 mph, speedometer quits working when this happens, what is wrong?

Posted by on

  • Joseph Weisenberger
    Joseph Weisenberger May 11, 2010

    Look into your vehicle speed sensor or PCM

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Mercury Master
  • 4,369 Answers

Speedo gets signal from Vehicle speed sensor on trans (VSS). It may be going bad. Go to autozone for a free computer scan. Does O/D light flash too?

go here for more help for villagers

http://groups.yahoo.com/group/villagerquest/

Posted on Jul 23, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Speedometer not working


my speedometer will work every now and then but most the time it will read all the way up to 120 mph or stay at the wrong speed its not the speedometer or the dashboard cluster that's been checked out its a 2007 Pontiac Torrent FWD 5 speed transmission and it runs great. What do you think it could be?

Jan 04, 2014 | 2002 Pontiac Grand Prix

1 Answer

How to fix a speedometer cable


Well you know it does not have a speedo cable since you replaced the speed sensor in the transmission.
My guess would be a problem with the speedo or cluster.

Jan 09, 2013 | 2004 Oldsmobile Silhouette

1 Answer

I have a 1996 Ford Windstar that just got a tranny flush on. While driving my van on a short trip; The speedometer and odometer quit working. I got home and took the van to where I got it serviced and they...


the fluid was overfull to begin with and on the trip trans got warmed up the fluid expanded and was forced out a vent hole and possibly a blown out seal from the pressure

Mar 23, 2010 | 1996 Ford Windstar

1 Answer

1998 Isuzu Rodeo 2WD.My speedometer / odometer has quit working.


You need to replace the speedometer gear that drives the sensor.

Dec 07, 2009 | 2000 Isuzu Rodeo

1 Answer

Speedometer Quits Working on Cruise Control


Pretty common problem with these. Here's a guide to learn how to fix GM instrument clusters yourself, I used it to fix mine and it worked great.How to guide for Impala instrument cluster repair

Nov 30, 2009 | 2005 Chevrolet Impala

1 Answer

Speedometer surging. actual speed 40 mph,


Its a loose connection on the speedo cable. its a b*tch to get to. I had the same problem on my truck, it would fluctuate in 5th gear on the highway. i spent the money and had a professional do it.

Aug 09, 2009 | 1990 Cadillac Allante

1 Answer

Speedometer problem


try replacing the vehicle speed sensor in the rear of transmission

May 29, 2009 | 1998 Chevrolet C2500

1 Answer

2002 Toyota Sienna speedometer quit


Yes it is all related. It sound's like your speed sensor (VVS) has gone bad. There are two of them, one is an in put Velocity sensor and the out is the out put Velocity sensor.
Your going to have to get the Van scanned to find out which on has gone bad. Most of the time it's going to be the out put sensor and it not that hard to replace. 
You can do it your self or a transmission shop, as for getting your Van scanned for the codes to let you know which sensor when bad. Auto Zone or Parts source will scan for free and can give you instructions on how to locate and replace the sensor.
Good luck and hope this helps.

May 04, 2009 | 2002 Toyota Sienna

2 Answers

I'm having a problem with my 98 Chevy Express G1500


if you have replaced ther speedometer sending unit then your dash cluster is the problem chances are that the sending unit was only part of the problem. the cluster is static sensitive so have a mechanic replace it for you, if your not familiar with newer dash clusters, static electricity can short not part but the whole dash unit which is quite costly, so be sure to have a shop replace it, if your not up to the task

Apr 17, 2009 | 1998 Chevrolet Express

1 Answer

Intermittent speedometer failure


Try replacing the speedometer sensor, located on the transmission under the car. There will be a few wires going to it with a plug. The speed sensor is a retivly low cost part, and most of the time when it begins to quit it will give irratic readings on the dash.
Hope this helps!

Dec 16, 2008 | 1995 Lincoln Mark VIII

Not finding what you are looking for?
2001 Mercury Villager Logo

Related Topics:

112 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercury Experts

yadayada
yadayada

Level 3 Expert

75744 Answers

fordexpert

Level 3 Expert

5495 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

Are you a Mercury Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...