Question about 1987 Ford Ranger

1 Answer

Runs fine then half way to work there is great loss of power.....

ENGINE TEMP READS LOW,wants to die but doesnt, so i limped the rest of the way there and it did the same on the way home. Died a month ago, replaced fuel filter and did the trick. Last owner said the plugs and wires were new in jan.( I'm going to look at them now) New cap,rotor and heater core... smells like GAS... fuel pump? THANKS. Nail bender guy

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 113 Answers

Check the coolant sensors. engine may be in a rich cond from that.

Posted on Jul 22, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

3 Answers

2002 malibu runs hot.


Sounds like you have a faulty head gasket or maybe a cracked head.This can cause overheating and the check engine light to come on.The code for the o2 sensor is probably caused by coolant getting into the exhaust system and coating the sensor.The coolant fan may work but it cannot remove enough heat from the rad to make the engine cool off.Try some engine coolant stop leak to see if it will help.This maybe only a temperary fix.Let me know if you need more.MOE

Jun 22, 2010 | 2002 Chevrolet Malibu

1 Answer

Runs fine til the temp out gets hot enough then dies. Wait ten mins and it will start again and run for a few mins then dies again


you didn't say if it was hot on the temp gauge? no matter, it sounds like you have a stuck t-stat. when the engine is cold, a mechanical valve keeps the water from coming out of the engine block until warmed up, then opens and lts the cooler water in. this cools down the engine and the colder temp of the water shuts the valve again. this happens constantly while the engine runs, and if your t-stat is stuck, the engine heats up the water in the block, but with nowhere to go, simply overheats the motor. a good repair book will locate the thermostat housing for you and should you the repair procedure. (i assume you have checked the water in the rad. low water will give you same symptoms). good luck.

Jun 10, 2010 | 1998 Chevrolet Express

2 Answers

Ford 460 loses power then dies. Starts back up. Idles fine.


It sounds like you might have a clogged catalatic converter on the exhaust system.

Apr 23, 2010 | 1999 Ford Super Duty F 450

1 Answer

I turn the car on and it runs fine volt meter reads in the positive, temp of the vehicle is fine and everything reads fine. The only thing blinking is the Change oil sign and it has just begun to flash....


you have a underhood fuse box. in that box you mayhave circut breakers. they click when going off and some have a rest time 15 minutes. check all of those and make sure no underhood , truck wires are rubbing on something causing a sort.

Dec 31, 2009 | 2002 GMC Sierra 2500HD

2 Answers

Runs fine till warms up then losses power and dies


Does the fuel line still have 55 PSI when engine warmed up? Any other codes show up?

Aug 22, 2009 | 1998 Chevrolet Blazer

3 Answers

Misfires when ran cold


You have low fuel pressure, check fuel filter and fuel pump.

Aug 10, 2009 | 2000 Volkswagen Passat 4Motion

1 Answer

Car Dies


My car idled OK but not great and used to die during stops at times. I replaced the spark plugs and wires without a difference. Shortly after the car died with very little power, just enough to limp home. I had a shop fix it so I didn't guess what was wrong. They replaced the Ignition Module and some of the Coil Packs. They had to replace the Spark Plugs I just put in due to fouling. If you are smelling gas you are putting your cat at risk and might have a more expensive problem later. It cost me $500 but it runs better than ever.

Nov 13, 2008 | 1995 Buick Regal

1 Answer

Saab 2.2tid car loses all power when warm, rev counter goes to zero


Check fuel feed is ok and fuel pump pressure also check cold start injector could be running on this til warm.

Sep 16, 2008 | 1999 Saab 9-5

1 Answer

Intermittant loss of power


Try the crankshaft sensor.

Jun 04, 2008 | 2001 Jeep Wrangler

Not finding what you are looking for?
Cars & Trucks Logo

76 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

76164 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

fordexpert

Level 3 Expert

5520 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...