Question about Cars & Trucks

1 Answer

Changed water pump now it stopped the leak but when I start the vehicle it idels funny sometimes only when heater is on now it's doing it continuesly and check engine light just started blinking

Posted by on

  • David Ellis Rhea Jan 03, 2017

    Hi devon obryant, I want to help you with your question, but I need more information from you. Can you please add details in the comment box? Please share the year, make, and model of the vehicle.

  • devon obryant
    devon obryant Jan 03, 2017

    03 Chevy trailblazer

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 80 Answers

Did you fully flush the coolant system in both directions when you had the water pump off? Quite often when they fail, pieces of the (usually) plastic impeller travel through the system and get lodged there. You need to flush the system in one direction, then reverse several times. If it has been flushed properly, you might still have air trapped in the system.

Posted on Jan 03, 2017

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 2039 Answers

SOURCE: corolla, 2001

did you get the car on computer to see what our check engine light i seen problem with temperature sensor the temperature sensor if it defect let say in morning its colder like 60 degre 15 celcius but the sensor is reading 80 degre the computer will not give the same anough of gas hard start not enough gas hesitation hope it FIXYA our problem thanks pierre

Posted on Jul 04, 2008

lovelle40
  • 26 Answers

SOURCE: Engine running really rough...whine sound when it isn't.

The run rough problem is due a cyl.mis firing,it becaused buy a bad plug,plug wire,coil,or even the ing.module. the servive eng.light flashing is warning you that you have a cyl.misfire that can cause damaget to your catltic converter if you continue to drive it.with may lead to why you think you have a exhaust problem,it may be colgged.

Posted on Dec 27, 2008

  • 1 Answer

SOURCE: 96 Grand Am SE2 2.4L starts and dies immediately

I had the SAME thing with my car!! Remove your air bag module its a grayish looking box that deploys your air bags, my air bag light was on but it was on and off. I pumped gas in my car one night and when i went to crank it my car cut right off after a split second. My mechanic took time on it but discover that it was a secrity issue. He removed the air bag module and presto it fired right up. I thought it was a fuel filter or fuel pump. It was just the air bag module, people freaked out about it once i told them what it was....it should be under the passenger seat, i believe u may have to take out the seat to get to it.

Posted on Jun 26, 2009

  • 603 Answers

SOURCE: My check engine light is on and it often shakes

Bring it in so that the check engine light will be off and it will run smoother.

Posted on Jan 12, 2010

  • 50 Answers

SOURCE: 2004 cheverolet impala 3.4L engine

Sounds like you have an air;lock in your cooling system.Try placing a bleeder on the return hose to the heater core ........looks like a small tap

Posted on Aug 18, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why does my car overheat and i get no heat in car


Have you recently changed your engine coolant? Have you checked your engine coolant? If you just changed the coolant you probably have an air lock in the system and it needs bleed out. To do this i would need to know more info about the vehicle. Another possibility you could have a coolant leak, IE the water pump, radiator hose, heater hose leak. with low coolant the radiator can't do its job and cool the engine. You could also have a broken water pump impeller. No impeller no engine coolant flow threw the engine and heater core.

Nov 09, 2012 | Cars & Trucks

1 Answer

1996 acura tl 3.2 overheats and no heat in car\


Have you recently changed your engine coolant? Have you checked your engine coolant? If you just changed the coolant you probably have an air lock in the system and it needs bleed out. To do this i would need to know more info about the vehicle. Another possibility you could have a coolant leak, IE the water pump, radiator hose, heater hose leak. with low coolant the radiator can't do its job and cool the engine. You could also have a broken water pump impeller. No impeller no engine coolant flow threw the engine and heater core.

Nov 09, 2012 | 1996 Acura TL Series

1 Answer

Sometimes when i start the car it starts runnin funny and i can hear air somewhere round the air filter then idel and starts running smooth again


i would check, for any vacuum leaks, you could have a vacuum hose with a hole in it, or one that is disconnected.

Apr 04, 2011 | 1998 Oldsmobile 88

1 Answer

My 2003 is not getting hot air i changed the heater hoses and put more antifreeze in and it still wont get hot air


One of two things: 1)Heater core may be plugged - on most vehicles you can switch the heater hoses around to reverse the flow of water to try to remove the blockage. This will be a temporary fix however because the foreign material will be in the coolant system and will eventually plug the core again. If you try this and it helps I would suggest flushing the coolant system to remove any loose material. 2)Failed water pump - Sometimes the impeller on the water pump gets corroded to the point where it will not move the coolant correctly. The solution for this is to change the pump. You can do some troubleshooting buy A)draining enough coolant from the system to drop the level below the upper of the two heater hoses B)remove the upper heater hose on the engine end and position the open end higher than the engine, allow coolant to drain to the point where it naturally stops C)Have a friend start the vehicle breifly and see if coolant flows from either the hose or the fittting it was connected to. If coolant flows from the hose, the core is not plugged. If coolant flows from the fitting, the water pump is working. If coolant doesn't flow at all, try switching the ends on the core if possible and repeat test. If the coolant still doesn't flow, you probably need a water pump.

Feb 11, 2011 | 2003 Pontiac Grand Am

1 Answer

Heater blows hot air while car is moving but cold air while idling. The intake manifold was changed last spring, the thermostat has been changed 3 times and the temperature sending unit has been changed....


That sounds like the coolant level is low. If it is not the use of "stop leak" has probably caused a partial clog which restricts the flow of water unless the vehicle is turning higher RPMS. While sitting still raise the RPMS to about 2000 and see if the heater blows hot air to see if the above mentioned problems are fact.

Nov 21, 2010 | 2002 Chevrolet Impala

1 Answer

2004 cheverolet impala 3.4L engine - Started running hot. Had never changed antifreeze, bought a flush and refilled with antifreeze. Ok for several weeks, started running hot again. Replaced the...


Sounds like you have an air;lock in your cooling system.Try placing a bleeder on the return hose to the heater core ........looks like a small tap

Aug 18, 2010 | 2004 Chevrolet Impala

1 Answer

Small hole in bottom of radiator drips


There are products out there like stop leak that MIGHT stop the radiator leak. However... the only real repair is either to have it soldered (if the end caps are not plastic) or replace the radiator all together.

Adding a product like "Stop Leak" most often starts to introduce other problems to your vehicle like a future water pump seal failure or clogs in the smaller water passages in the engine block, heads and manifolds and the thermostat heater bypass hole. Anyone that has ever done any major engine repairs will know immediately if stop leak was used in a cooling system.

The best fix is to replace the radiator.

Many radiators today can not be repaired

Stop leak is in most any auto parts store. Just be advised of what you can expect down the road.

specifically

1. warmer than usual engine operating temps
2. water pump seal failure
3. heatrer core clog (no heat)
4. passenger heat control temp valve clog (no heat)
The choice is yours. Personally I would not do the "Stop Leak" treatment attempt. Sometimes it works other times it does not.

Feb 14, 2010 | Saturn L300 Cars & Trucks

1 Answer

1991 honda accord- coolent leaked out from water pump area but water pump seems fine-also when car is ideling car would have little power surges and come close to dying - any ideas


for the water pump leaking, get some engine coolant stop leak from any automotive store, it usually contains pump seal lubricant also. the power surges are a separate problem from your pump leak.

Oct 17, 2009 | 1991 Honda Accord

1 Answer

1. My grand prix gtp has problems with leaking on the passenger side. I cannot locate the leak. 2. My engine runs too hot when ideling. I changed the thermostat but this did not help. I need your assi


Make sure your cooling fans are coming on when the temp heats up. Are you talking about a leak inside the car or outside? Inside is usaully a drain tube for the A/C stopped up. Outside, look for a water pump or intake gasket.

May 12, 2009 | 1997 Pontiac Grand Prix

1 Answer

1989 toyota 3.0v6


Did you check the thermostat? brand new thermostat sometimes went bad too; happen too me once on my 1989 toyota supra....; Check the water pump and hoses. Flush the radiator really good then get 50/50 mix water & coolant;

Aug 19, 2008 | 1991 Toyota Pickup

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

14 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

yadayada
yadayada

Level 3 Expert

75197 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Randy Ohler

Level 3 Expert

14585 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...