Question about Cars & Trucks

Open Question

My mg4502 is reving high as if under load with nothing pluggedin and no lights on

Posted by on

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Corsa 1.3i over revs


run fault codes and check for MAF/MAP sensors and HO2S and HO2 sensors.

Feb 18, 2014 | Cars & Trucks

1 Answer

I bought a 87 bmw 325 between 2 and 3000 rpms it acts like it spits and sputters but as soon as u get over 3000 it is just fine nothing wrong with it please any ideas will be helpful


Hi there?
The HT leads do this normally. They brake down when under load just like reving the engine up. I recomend you clean the distributor cup and replace the spark plugs and the HT leads. Good luck....

Jun 05, 2011 | 2001 BMW 325

1 Answer

Ive replaced my cam shaft sensor still indicates it im reving high rpm and im wondering if that is part of my issue


any time you replace a sensor you have to clear the codes or they will stay there for awhile is the check engine light on ? is the engine reving high at idle ? you need to give all info when asking questions

Aug 04, 2010 | Dodge Ram 1500 Cars & Trucks

1 Answer

2002 Ford Windstar p0300 skips and backfires under load


Just put a coil on a 2002 today. Coils fail a lot with no codes given

Mar 09, 2010 | 2002 Ford Windstar Cargo

1 Answer

Reved the motor , it died, no dash lights , no


battery connection bad/dirty/ loosed or battery died....usually a dirty connection dont use those cheap auto parts store cable end clamps they wont work for very long..............

Dec 18, 2009 | 1994 Honda Civic

1 Answer

Clicking Noise Coming From Under The Hood


Have you checked your belts? A piece of belt may have come off and been slapping under your hood, and then fell off completely. While it was slapping, your computer would have detected the slow down of pulleys etc. and caused your engine light to come on. Then when the piece broke off, everything would be back to normal. Let me know!

Apr 08, 2009 | 1998 Lincoln Town Car

1 Answer

Reving High


Did youmtry disconnecting the battery for five minutes, then reconnect, start engine and let it idle for 5 minutes with everything off, including radio and heater. If this don,t work you may have a faulty position sensor. I hope this helps.

Jan 21, 2009 | 2001 Hyundai Accent

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

16 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

yadayada
yadayada

Level 3 Expert

75005 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Randy Ohler

Level 3 Expert

14585 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...