Question about 2009 Mercury Mariner

Open Question

09 mariner shacking at idle - 2009 Mercury Mariner

Posted by on

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

09 mariner thats steering shakes at idle.does the electronic control module need replacement


Any number of things can cause this problem. Get a free scan at a major auto parts store. If there is no trouble code a Dealership diagnostic tool may be needed. There are only so many things available in a handheld scanner.

Even a bad motor mount can cause your problem.

Jan 02, 2017 | 2009 Mercury Mariner

1 Answer

2005 mariner will crank but idles very rough. All relays an fuses seemed ok. what could it be?


There are many things it could be. in no particular order:
bad plugs
bad ignition wires
vacuum leak
bad valves
blown head
bad piston rings
bad injectors
there are more, but that's the short list. Any codes? check engine light?

May 10, 2015 | 2005 Mercury Mariner

1 Answer

O3 3.9 dakota starts but dies unless i rush the engine


  • My 2001 Dodge Dakota has a 4.7 liter engine but the problem you are experiencing is the exact one I had a while back. Here's the fix I used. 09/09/2013 - 87,250 mi. Problem, (engine wouldn't low idle) Idle Air Control Valve totally clogged with grease & soot. I cleaned thoroughly with "Carb & Throttle Body Cleaner".... Problem solved.... I hopes this helps.... L. Smith

Jun 10, 2014 | 2001 Dodge Dakota

1 Answer

Rear view mirror stays very dark during daytime on my 09 mariner is sensor in mirror bad and would it stil be under warnty


Hello and welcome to FixYa!

It can be a sensor issue. I strongly suggest that you take it in to the dealership for it's only a year old. This is safer to avoid forfeiture of warranty.
Hope this helps and thank you for using FixYa! Have a good one!

Jul 17, 2011 | 2010 Mercury Mariner

1 Answer

My mariner outboard hard to start when cold


mcdevito75 here, It could be a faulty cold idle sensor, or a leak at the intake manifold, have your local shop check it out.

Jun 18, 2010 | 2007 Mercury Mariner Premier 4WD

1 Answer

94 ciera 3.1 new fuel pump,strainer,filter9/9/09,new crank sensor,new cam sensor7/10/09 new IAC, maf 6/29/09 after disconnecting batt. for 1hr,starts,idles 30 sec. dies now what?


May have a vacuum leak somewhere these are sometimes hard to find. Start at the throttle body should be a couple lines there look for holes,cracks in the lines at throttle body and continue down the lines.

Sep 11, 2009 | 1994 Oldsmobile Cutlass Ciera

Not finding what you are looking for?
2009 Mercury Mariner Logo

Related Topics:

23 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercury Experts

yadayada
yadayada

Level 3 Expert

75197 Answers

fordexpert

Level 3 Expert

5481 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Are you a Mercury Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...