Question about Cars & Trucks

Open Question

Put recon injectors in .and got machine to put codes in but sangyong not showing .help

Posted by on

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Diesel 2013 kuga shows a miss fire on 1 cylinder when hooked on diagnostic machine show a fault code. When they swap electrical leads to different cylinders same fault code. Any ideas


Check compression on all cylinders. Get injectors checked.

If you also hear a knocking noise at idle, than the injector was defective and damaged the piston. If you discovered this early enough, maybe just fixing the injectors will solve the problem.

If your car has a particulate filter, get it removed along with the EGR valve, as many times this bogus emission control systems can be the root of all problems, but the diagnostic fault codes mislead you.

Dec 11, 2017 | Cars & Trucks

1 Answer

Trouble code: p0300 I have only had it for about


That code is showing that one or more of your cylinders aren't firing properly, or better known as misfiring.
This could be caused by a myriad of different things such as faulty spark plugs, ignition coil, clogged fuel injectors, possible improper fuel pressure, intake air leak, or not enough cylinder pressure-
There's also the possiblity that you could have some shorts or poor electrical connections between the ignition coil and/or fuel injector harnesses.
The handheld code reader that we all have can give you an idea of what it is by giving you the code...but take it to a mechanic who has a diagnostic machine and they'll be better able to pinpoint the exact issue.
Hope this helps.

Aug 07, 2013 | 2005 Chrysler 300

1 Answer

Peugeot 306 52 plate,pulled out the garrage one morning all perfect,left for 30mins tried to start to go to work turns over but wouldn't start,tried everything even diognostic machine of mine and the


Did you check for fuel pressure with a gauge on motor
or scan tool, if that data is avail?
Did you put one of those HEI Spark Plug testers in a plug wire
or cop coil
Do the cams turn
I'm not into the Peugeot, but is expect you may have a timing
belt ?
You may not have data on the ignition switch & its contacts
Do you have battery voltage to the ignition & injectors with key on
Injector pulse when cranking ( crank sensor !!)

Jul 26, 2013 | Cars & Trucks

1 Answer

I have a Sangyong Rexton 270Xdi year 2004. The signal '4WD Check' coming out at the dash board. The gear position only show 'D' at all time.(Normally it will change from D1 to D5) The max speed hardly...


The most likely problem is the Throttle position sensor, which is attached to the side of the injector pump. If this sends the wrong signal it will be interpreted as a TCU fault.

It can be tested seperately with a volt meter and reset.

The electrical connections leading to the TPS and other parts of the gearbox should also be checked to make sure they are clean and well connected. This is a common fault with this type of vehicle.

I doubt if the TCU itself is faulty. Dont let the garage just throw parts at your car in the hope it will fix it.

Apr 20, 2011 | Mercedes-Benz M-Class Cars & Trucks

1 Answer

I got a 2.4d toyota that whe overhaul the motor but it still smoke heavy black and under power.whe put a recon pump on and injectors new cam and head and a sprocket on cam for valve timming but it still...


After you reconditioned the motor, pump and injectors, it shouzld work fine. Firstly, recheck the valeve and injection pump timing. If that is ok, then its possible that the exhaust is too blocked and full of carbon and unburnt fuel. I would suggest that you take the car to an exhaust specialist, who can measure the exhaust pressure to see if it is indeed blocked. If so , then you will need to replace it.
Hope this helps

Dec 12, 2009 | Toyota 4Runner Cars & Trucks

1 Answer

Has a 6.0 L with bad misfire under a load and is


Hi Brad,
I ran into the same problem your going thru,
swapped cylinder plug and wire ,and the scan kep telling me it was still seeing the problem on the same cylinder,
smoked it too,nothing made sense!
Until i took the whole fuel rail off carefully not to let the fuel run out all over the engine,Had a white rag folded up and handy,tilted the rail assembly and left the fuel run on the cloth,OMG! the rust that came out of there,
I pulled every injector out of the rail,cleaned the inside of the rail with air pressure and carb cleaner.
Its when I was checking the injectors that I found the culprit,the rust pieces had made it thru the injector but were trapped in the screen of the injector!
I hope this cures your.

Dec 10, 2009 | 1999 Chevrolet Silverado 1500

1 Answer

Number four cylender is dead as four o clock. checked fire on plugs and wires. they are fine. pulled number four injector, no gas spraying. can i take the injector apart


you could but its not going to work again????
try it out on a different cylender first if it still wont go
just put in a recon injector or a second hand one

Oct 30, 2009 | Alfa Romeo Spider Cars & Trucks

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

17 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

yadayada
yadayada

Level 3 Expert

79865 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22326 Answers

john h

Level 3 Expert

14512 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...