Question about Cars & Trucks

1 Answer

My Fisher speed cast plow will lift and lower. It will angle to the left and will center but will not angle to the right past center. Any ideas?

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

    Welcome Back:

    Visited the website for 2 consecutive days.

  • Contributor
  • 22 Answers

Check wire connectors for corrosion and check to make sure hydraulic lines are properly connected...also may have water in the system. if not that then you probably have a bad actuator valve.

Posted on Dec 18, 2016

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Fisher plow angles left only


check your plow to truck connectors some cleaning and some Dielectric grease goes a long way.
when you lose sol. control the hyd. flow defaults to a certain direction.
Make sure they are clean. and lightly greased try that to start.

Feb 08, 2018 | Cars & Trucks

1 Answer

I have a minute mount plow, when I try to use it only goes to left and right side but doesn't go up, when I try to lift the plow goes to the right. What can I do


2002 Fisher Minute Mount Inst-Act Wont Angle [Archive] - PlowSite ...

www.plowsite.com > ... > Truck & Equipment Repair

Nov 17, 2011 - 90 posts - ‎9 authors
My plow went up it was jerking and did it in steps , but , it got there . Now , it onlyjerks when i try to angle it right or left or up . I filled the fluid ... Drop it and if it doesn'traise you can just use a jack and shorten the transport chain to hold it. .... I do havecontinuity on the plow side for all 3 wires going to the plug . Hooking Up A Fisher Minute Mount 2 In Under 1 ...
54 posts
Feb 1, 2011
Plow Wont Angle
32 posts
Oct 19, 2010
What's wrong with my plow?
21 posts
Jan 9, 2003
Looking For Minute Mount Tips
57 posts
Feb 13, 2002
More results from www.plowsite.com

Ultramount Intermittent Angle Problem - Snow Plow Forum - L


Dec 27, 2015 | Cars & Trucks

1 Answer

Plow doesn't always go down


Did you try angling in both directions? If the blade is angled all the way to one side (most likely to the LEFT), it could be that the valves are stuck directing fluid in that specific direction. Check that you are getting power to your "B" solenoid when you are trying to lift the blade, and power to the "C" solenoid when you are trying to angle in one direction but not the other.

Mar 03, 2015 | Cars & Trucks

1 Answer

My fisher minuteman 2 plow will go up and left and right but will not go down


Most of those systems don't have a driven retraction on the piston. It is gravity feed back. There is a valve that is sticking or out of adjustment. http://library.fisherplows.com/?cat=38

Jan 24, 2015 | Cars & Trucks

2 Answers

I have a fisher minuteman plow it will go up, left and right but will not go down what is wrong with my plow


If you have a Minit Mount two it's probably the valve sticking. It's electronically controlled so if it clicks, then the solenoid is working and the shuttle in the valve is stuck. Can be disassembled and cleaned. New ones are best but pricey.

Jan 24, 2015 | Cars & Trucks

2 Answers

I can hear my fisher plow motor but the plow will not lift or angle


There solinoids on pump. Check wiring and grounds. Make sure all small wires are intact and in good condition. But most likely there's a loose corroded or green wire causing issue

I’m happy to assist further over the phone at https://www.6ya.com/expert/joe_a3369546f8067589

Jan 09, 2015 | Cars & Trucks

2 Answers

When i try to lift or angle my plow all i get is a clicking sound when i push the lift button and when i let up on the button the moter on the hydrolic unit will click but will not move the plow. minute...


Not familiar with model, but valves click at the same time motor is suppose to run. Check power and ground to motor (or try running it with jumper cables, but don't be where plow can angle and squish you. If good power but won't spin, clean brushes/commutator/check bearings in motor.

Aug 15, 2014 | Cars & Trucks

1 Answer

Fisher minute mount goes up and left and locks up


check your connections, especially the main power plug in, i have used a small "c" clamp over the connection to aid in the same problem

Oct 29, 2009 | 1998 Chevrolet C1500

Not finding what you are looking for?

Open Questions:

0 Answers

2008 nissan altima a/c issues Last week the car stopped blowing cold air. After doing a pressure test, the low/high readings were both around 100. I assumed that the compressor wasn't kicking on. The compressor clutch had been working until this issue started but there was a noise that sounded like it was going bad. It had 100K miles on it so I replaced it. I also replaced the condensor (due to some damage on the front), the drier, and expansion valve. The only original component that showed a leak when I checked with my UV light was the drier....right at the based of the LP switch. After getting everything buttoned up i pulled vacuum on it for an hour and it held at 29". I then closed the valve and turned the pump off and let it sit for another hour. It was still holding at 29". I hooked up the freon to my manifold gauge and turned the car on with the a/c going. I charged the system until the low/high pressure was 37/190. The air was blowing colder about about 55 degrees. I thought it would be colder but it was an improvement. Once complete and everything disconnected, I turned the car off and went inside. I came back out a few minutes later and cranked the car....compressor wouldn't come on and warm air resumed. I ended up evacuating the system again and repeated the vacuum/recharge process again....cold air around 55 degrees. I reached over and turned the MAX A/C button on, the compressor went off and the warm air was back. I do not know if these two things are related but I also noticed that the condensor/radiator fans are not running at all. Could this be a sensor? Any help would be appreciated. I know enough about this stuff to be dangerous so if you give some tips, please simplify the best you can. Sometimes people give advice they forget that the little details stump us novices at times. ha. Thanks

Jul 18, 2018 | Nissan Cars & Trucks

Cars & Trucks Logo

Related Topics:

67 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

yadayada
yadayada

Level 3 Expert

80407 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22326 Answers

john h

Level 3 Expert

15273 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...