Question about Rover Cars & Trucks

2 Answers

My rover 75 is running out of petrol even when the fuel guage is registering fuel in the tank. I have had the sender renewed but the problem is persisting

Posted by on

Ad

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Rover Master
  • 3,554 Answers

Water in the fuel tank could be a possible cause and the sender is at the bottom of the tank and may be sucking in water. research in google metho in petrol to get rid of water in petrol.

Posted on Dec 14, 2016

  • Brett Duxbury
    Brett Duxbury Dec 14, 2016

    could be water in the fuel google removing water from petrol

×

Ad
  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Welcome Back:

    Visited the website for 2 consecutive days.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 7 Answers

You may have a fuel pump issue. my advise would be to check the fuses and make sure nothing is blown and the check to make sure the fuel pump is working. also you could check to make sure the gauge is moving when you add fuel to it.

Posted on Dec 14, 2016

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get to try the service completely Free afterwhich it costs $6 per call and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1998 toyota corolla fuel gauge not working stays in full


start at the fuel float sender part inside the petrol tank

float may be stuck or need a new sender

the fuel guage in the dash dont normally give trouble


26329283-gxgogxvuvmwbpiazwt1kca4q-2-0.jpg

26329283-gxgogxvuvmwbpiazwt1kca4q-2-1.jpg

Oct 27, 2016 | Toyota Cars & Trucks

1 Answer

Proton satria neo 007,fuel guage problem,it will show gas level and then suddelnly the guage will go down and stay there showing no gas and the petrol light dont even work


You need to determine if the sender is bad or the gauge is. If you can get to the signal wire at the fuel tank for the gauge (this goes inside tank to sender that provides a variable ground circuit) ground that wire briefly to see if dash gauge rises. If so, part inside tank is bad. If not, gauge or some part of its wiring circuit is bad.

Oct 18, 2016 | Proton Cars & Trucks

1 Answer

Why is my fuel gauge stuck on full even though there is only 50% of petrol in the petrol tank


Hi,it must be that the gauge or sender unit are faulty,check sender unit first.

Apr 09, 2016 | Cars & Trucks

1 Answer

1989 range rover not pumping petrol 3,9 runs on gas but will not pump petrol


Hi there, did you run the petrol low or out, the fuel pump will keep pumping while the key is on and if your running on gas them it's still running, I would say the fuel pump has failed due to no lubrication from fuel, be sure to keep your petrol tank at least at 1/4 of tank full

Mar 06, 2014 | Cars & Trucks

1 Answer

Rover 75 connoisseur 2.5 petrol(52 plate) starts mainly on 3rd attempt, never more.


Most common cause for this is a weak petrol pump,try renewing the pump ,its in the fuel tank

Feb 11, 2013 | 2000 Rover 75

1 Answer

My BMW X1 shut off in the middle of the road eventhough it had a 1/4 tank of petrol left. BMW suggested I fill it up with petrol and it started again. I am left confused as to why that happened...


The fuel sender unit could be faulty. It says 1/4 tank even though it is almost empty. Carry a jerry can of gas in the back , and run it down to 1/4 or less to see if the problem repeats itself.
The gas guage and trip computer are only as accurate as the float in the tank.

Feb 08, 2011 | 2011 BMW X1

2 Answers

I have a 87 ford f-150 and gas gauage does not work. what would be the cause. thanks


ONE of 3 things
NO petrol
Fuse blown
Fuel tank sender needs replacing, or broken wire under dash or under chassis

Nov 24, 2010 | Ford F-150 Cars & Trucks

2 Answers

Fuel gauge reads E when first started, jumps to F after awhile


It is more likely to be the fuel guage sender which is faulty.

Aug 21, 2009 | 2002 Audi A6

1 Answer

2004 Porche boxter - Filled petrol tank & guage still empty


It sounds like problem with either gage or sender unit in fuel tank.
What warning massage from computer.

Jan 28, 2009 | 2000 Porsche Boxster

1 Answer

Pajero NK87 petrol guage not working, shows empty even when tank is full


Sounds like the Fuel sender unit in the fuel tank needs replacing however you may want to check that the electrical plugs are contacting properly,Check that the gauge is working by putting a piece of wire from the sender unit wire to the chassis,at the fuel tank sender unit plug,Turn ignition on while watching gauge if it moves toward fill turn ignition off and remove wire to chassis.If gauge moves it means from the fuel tank to fuel gauge is intact and not your problem.

Oct 24, 2008 | Mitsubishi Montero Cars & Trucks

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

23 people viewed this question

Ask a Question

Usually answered in minutes!

Top Rover Experts

yadayada
yadayada

Level 3 Expert

76630 Answers

Thomas Perkins
Thomas Perkins

Level 3 Expert

14378 Answers

Rob
Rob

Level 2 Expert

62 Answers

Are you a Rover Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...