Question about Chevrolet Cars & Trucks

Open Question

I have a 1990 chevy 350 engine was running the other day now it wont start.it look like it wasnt getting any gas so i prime it still nothing what should i check on

The last time it was running it was backfireing in the carb and dieing also look like it was flooding out

Posted by on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 1 Answer

SOURCE: backfiring

it has plug wires crossed the firing orders is 18436572 make sure distributor is pointing toward # 1 plug wire make sure #1 cylinder is up on compression take plug out put finger over plug hole let some one crank it over until compression comes up then line your rotor button is pointing toward #1 wire on cap. then start ur #1 plug wire where the rotor button is pointing and go clock wise 18436572 and that should take care of it

Posted on Jun 12, 2008

  • 255 Answers

SOURCE: 1987 Chevy R10 project truck won't start

check the float on the carb is stuck shut not letting fuel in

Posted on Aug 17, 2009

  • 10 Answers

SOURCE: engine wont start without priming with gas first, then runs well

i have the same problem on a 98 jimmy 4.3 4x4.
i replaced the fule pump and have good pressure.
new wiers & coil (good spark) no MIL & no codes.
will only start when primed. it will run & drive all day
with no problems.
but once it has been turned off (warm or cold) i will
have to prime it once again to start it.
i have another engine that was in it before it spun a bearing.
it ran fine so i know all parts are good.
i swaped the mass air flow and throttle body but i still have
to prime it everytime to start it. am i forgetting something?
should i swap out the intake with the injectors?
any help would be sweet. thanks.

Posted on Jan 05, 2010

  • 1 Answer

SOURCE: 90 chevy 4/4 pu tbi 350 floods out

I'm having the same trouble with the flooding after warm start...if it's the temp sensor, would the temp gauge be working? It's in a 1991 Chevy van with an injected 350 carb.

Posted on Jul 25, 2010

dogturtle84
  • 45 Answers

SOURCE: 1990 chevy camaro with a rebuilt 350 Tbi

your multi port set up ran like 30 psi yor throttle body only runs 10

Posted on Dec 09, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have an 89 chevy c1500, 5.7, 2wd. Had it running and trying to get it timed. During this process i noticed the injectors quit giving gas. I put gas in it and nothing changed so i have been chasing the...


the reason the injectors stopped is because the motor is not running.this is a safety precaution built into the computer so the engine won`t flood.if the fuel pump is not working then you will have to check powers and grounds at the fuel pump connector by the gas tank to see if the unit is getting fed power and ground.someone will have to try to start the car while you check this out as there is a 2 second prime circuit if the car is not turning over.also this system uses the distributor to know that the engine is turning over to start.you may have a bad pickup coil in the distributor.this system also grounds the injectors through the ecm so you should have power to the injectors when the ignition is turned on,for your information.

Apr 08, 2011 | 1990 Chevrolet K2500

3 Answers

1990 chevy silverado 1500 single cab. 180K miles. Last few days if the truck sits for 8 hours truck has a hard time starting up. Takes a good push on the gas to get running. Oil changes and fuel...


yes sounds like the fuel filter is clogged when push gas pedal put it in clear flood mood and resets the fuel system and starts over thats why it starts when push to floor creates back pressure sucks debri bottom of filter

Sep 25, 2010 | 1990 Chevrolet K1500

2 Answers

2000 Chevy K2500 will not start reliably. It has


cant lose prime...it gets primed everythime you turn the key off and back on for more than 10 seconds.

have you had the coil pack controller checked?

any Check engine light when its running?

Jan 19, 2010 | Chevrolet K2500 Cars & Trucks

4 Answers

Engine wont start without priming with gas first, then runs well


i have the same problem on a 98 jimmy 4.3 4x4.
i replaced the fule pump and have good pressure.
new wiers & coil (good spark) no MIL & no codes.
will only start when primed. it will run & drive all day
with no problems.
but once it has been turned off (warm or cold) i will
have to prime it once again to start it.
i have another engine that was in it before it spun a bearing.
it ran fine so i know all parts are good.
i swaped the mass air flow and throttle body but i still have
to prime it everytime to start it. am i forgetting something?
should i swap out the intake with the injectors?
any help would be sweet. thanks.

Apr 28, 2009 | 2000 Chevrolet Blazer

2 Answers

1990 chevy camaro with a rebuilt 350 Tbi


fuel pressure isnt right.. need to get a fuel pressure regulator so you can regulate the gas flow..

Apr 21, 2009 | 1990 Chevrolet Camaro

3 Answers

Heater display unit not working


I have a 1990 chevy truck and i have the same issue i have checked all the wirring,fuses everything under my dash i found a relay that wasnt working correctly i replaced it and the box on the dash with on out of my other 1990 chevy truck and still nothing if some one can help with this please email me at lizzardtoung77@yahoo.com Thank You

Apr 02, 2009 | 1990 Chevrolet K1500

1 Answer

Ran fine then next day all went to /


that sounds correct and its probably electric and in the tank. turn the key to the start position then listen for a small humming noise coming from gas tank if theres no sound then thats most likely the problem.

Jun 10, 2008 | 1990 Chevrolet Corsica

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

19 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

74945 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7697 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...