Question about Cars & Trucks

1 Answer

Car stillruns very rough changed all plugs and wires and timming is on new gas filter it back fires and doesnt pick up speed

Posted by on


1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points


    An expert that got 20 achievements.


    An expert that got 10 achievements.


    An expert that got 5 achievements.

  • Cars & Trucks Master
  • 3,054 Answers

Check your exhaust system...

Once the muffler (even those Walker products) start coming apart inside... they can block the outflow...

No outflow = no intake (engine strangling).

Same possibility for the catalytic converter (if you have one)

Easy way... get it to the muffler shop ... get them to read
you hand-full of DTCs (trouble codes (some times free))...


Get that penetrating oil... soak up those header bolts
(really well)...

Open the system... if it runs you now know what has to be fixed BEFORE YOU CAN SAFELY OPERATE the VEHICLE.

Hope this helps

Posted on Dec 11, 2016


6 Suggested Answers

  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017

  • 9 Answers

SOURCE: Rough Ideal on 2004 Ford Explorer

Open hood and listen for vacuum leak sound. pcv hose is most likley cause.

Posted on Sep 04, 2008

  • 2 Answers

SOURCE: rough idle

check you throttle position sensor first then fuel pressure regulator, then fuel pump. i have a 92 and had to recently do a massive overhaul. my rough idle was caused by a malfunctioning tps with a small exaust leak causing it to race and an intake manifold gasket. also check your idle speed adjustment settings.

Posted on Dec 03, 2008

  • 1 Answer

SOURCE: 1999 SL1 running rough

Had a similar problem; started fine but lost power under acceleration and would stall. I changed the fuel sensor relay in the fuse box located on passenger side of interior fuse box. Ran fine after that.

Posted on Mar 07, 2009

  • 79 Answers

SOURCE: rough idle

Barring any mechanical issues you most likely have a failed injector.

Posted on Aug 14, 2009

  • 20 Answers

SOURCE: Just changed plugs and wires in my 1998 Chevy

Firing order on 3.1L engine is 1-2-3-4-5-6. The ignition system is a waste-spark system, which uses 3 coil packs (1-4) (2-5) (3-6). Make sure that the paired cylinders' plug wires go to the same coil pack.

Posted on Oct 12, 2009

Add Your Answer

Uploading: 0%


Complete. Click "Add" to insert your video. Add



Related Questions:

2 Answers

Wont pick up speed on take off

take the fuel filter off for fun and see if ya can blow through it at least fast and not cost but a few min s...
If burning a lot of gas ,,timing ?...bad plugs ..wires
you can check wire out by just unplugging one and seeing if that changes idle at all until ya find one that does not ...wooot bad plug or wire...

Nov 26, 2013 | 1995 Chevrolet Blazer

1 Answer

Running fine on gas rough on petrol

first you did not mention your car brand. Anyhow its not seem ens a big problem.what i understand is your car advances not working properly & secondly your car ignition coil(s) or both plug cods & coils.
in last your car can not maintaining low rpm it might be from throttle body idling switch or main butterfly ..... or might be your car Tappet sating out or some head valves are jam a proper check from codified mechanic ..... this is a basic of your car, now if you need any further help you can mail me on best of luck....

Nov 21, 2013 | Cars & Trucks

1 Answer

My car isn't doing good after a tune up..?

have you checked to make sure the spark plugs were gapped properly for your car

Nov 17, 2013 | 1989 Oldsmobile Cutlass Supreme

1 Answer

1997 chevy cavalier

Not much you can do without troubleshooting the problem. It could be a crank sensor, ignition module, low fuel pressure, a vac leak, or a list of other things.
Usually if you have a sensor problem you will get a check engine light, but not always.

May 29, 2013 | Cars & Trucks

2 Answers

Ford 1981 f 150 not running changed Coil distributor cap Roar arm plug wires did not help started bur ran extremely rough then died

motors need 3 things to run properly. gas spark and compression. the starting point. also spark timing.
the motor you are dealing with is easy. i just rebult a 1978. anyways sounds like a timing problem . first i would check the distributer. if all is ok spay a squirt of starting fluid in the air filter, or even wd40.,,,,,,,see if it is gasoline problem. isolate where the problem is.

Aug 29, 2017 | Ford Cars & Trucks

1 Answer

Why wont my chevy tahoe pick up speed ? we did everything , new spark plugs , new gas filter ,new fuel pump , new air filter , new gas filter , new spark plug wires , still it wont pick up speed . Why ?

did you check the timing? the firing order.
does the engine rpm rev up high? if it does then check the transmsission for low on fluid or slipping.
check your catalytic converter for clogged up.

Apr 27, 2010 | 1997 Chevrolet Tahoe

1 Answer

1995 chevy g 20 va 5.7 engine runs rough even

You may have picked up some debris and/or water when it ran out of gas. That got sucked up into the filter. Try changing the fuel filter I believe it's located on the right side, just ahead of the rear wheel.
Try that and see if there's any improvment. Hope this helps.
Good luck.

Jan 20, 2010 | 1995 Chevrolet G20

2 Answers

1994 olds cutlass 3.4 dohc

have you changed the fuel filter lately a plugged fuel filter will cause this concern
did the power loss start all of a sudden or did you start losing power over time ?

Oct 22, 2008 | 1994 Oldsmobile Cutlass Supreme

4 Answers

1991 GMC TBI 350 sierra stalls bad

Could be the TPI Sensor or it might be a touch out of timing.

May 30, 2008 | 1991 GMC K2500

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

18 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts


Level 3 Expert

78010 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22306 Answers

Thomas Perkins
Thomas Perkins

Level 3 Expert

14405 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides