Question about 1996 Jeep Cherokee

1 Answer

1996 cherekee 4lt cold starting idles good warms up idles rough. exhaust fums stink. fueling up spark plugs .speedo289000klm'can any one help

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Jeep Master
  • 20,706 Answers

Is the problem only on a cold engine, hot or both?
is the hot engine reaching and holding 180F or more as it must?>
its running rich
and that is misfire.
lots of causes for rich. the tests are easy in shop with tools.

  1. a full tuneup.
  2. fuel pressure to high we, use a gauge. (FPR bad?)
  3. leaking injectors.
  4. ECT failure, scan it and must read 180f, hot, if at 180f hot.?
  5. this takes 5 min work on any scan tool (real)
  6. map hose clogged. or leaking. the Map sensor must not be blocked in any way to the plenum vacuum. or it will lie and it will run real bad.
  7. on a hot engine, the 02 sensors can fail, or is good and the exhaust cracks in the header do that. on mine it did 3 times.
cracks in the exh header, there must not he any leaks in that header (or bad gaskets)
or the 02 lies. , goes to 0volts and then engine runs rich as a piggy. (my scan tool shows this is seconds, 02 flat-lined at 0v.
all cars, with 02 do that. with that issue.
02 means oxygen sensor, the front one, not the rear one.

Posted on Dec 11, 2016

Testimonial: "i will check all imformation you have given me .thanks for your time seems like your the only one that same problem"

  • shane halliburton
    shane halliburton Dec 12, 2016

    fixed jeep front o2 sensor disconected it runs great

×

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 43 Answers

SOURCE: 1993 Ford Explorer idles rough when engine is warm

try changing distributor cap & coil

Posted on Jan 06, 2009

chuck943
  • 783 Answers

SOURCE: 2000 Ford Explorerer rough idle When cold

what codes are present? If it is lean codes P0171/P0174 problem is most likely the orings leaking between upper and lower intake manifold if this is a 4.0L

Posted on Feb 11, 2009

michigan man
  • 3533 Answers

SOURCE: 99 Expedition, runs rough, won't idle, no power.

it could be two things a bad injector or a the intake gaskets are leaking

Posted on Apr 04, 2009

rockitman187
  • 2559 Answers

SOURCE: Dodge ram rough cold start idle

Change the EGR valve.

Posted on May 05, 2009

  • 77 Answers

SOURCE: 1996 Honda Accord Rough Idle Even After tune up

Perform a valve clearance inspection and adjust if necessary. Tight or sticking valves will cause a misfire or rough running concern. Note: Perform valve adjustment when the engine is stone cold. 4cyl: INT 0.26mm EXH: 0.30mm (V6 engine are hydraulic and no adjust necessary.) Also check for a sticking or stuck open EGR valve. For diagnostic purposes only: Remove the EGR valve. Place a business card over the EGR passage and bolt the EGR valve back on. This plugs the EGR ports and if the misfire goes away the EGR valve is partially stuck open and is defective.
Check for low fuel pressure. Check for low compression. Check cam timing. Check for a weak ignition coil. Also don't over look the possibility of worn or broken engine mounts which cause excessive engine movement and engine vibration. -hope this helps

Posted on Mar 05, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

4.6l. After warm-up, why does it run rough with missing?


Could be spark or fuel.
Weak or worn spark plugs, weak coil, dirty injector, and so on.

Jan 05, 2016 | 2001 Ford Mustang GT

1 Answer

I have a 1996 dodge dakota 2wd took out the 5.2 and put a 5.9 in headers no cats no 02 sencers and my problem is when i start it cold idle is good but if i take it to 2,000rpm it will bog down then...


Without input from the O2's, the engine goes into fail-safe mode and runs in a full rich fuel trim. When the engine is cold the spark plugs are being "loaded up" with unburnt fuel, and engine stumbles. Hope this helps.

Mar 14, 2014 | 1996 Dodge Dakota

1 Answer

1999 GMC Safari, rough running, knock detonation at wide open throttle


It seems like a problem with your ignition system. You could take a look under the hood at night / in the dark to see if there are any sparks between the spark plug wires and anything they touch or lay close to.
As the engine needs to be running during this test, please watch out not to touch any moving parts as it might lead to severe injury.

If you see any sparks - change the spark plug cables. If not, try to move the cables (with engine off) away from any metal parts they could be touching. Then start the engine and see if the problem persists. If it makes no change, you will have to start replacing the spark plugs, rotor + cap, wires and maybe the coil.

Dec 04, 2013 | GMC Safari Cars & Trucks

1 Answer

Hello i have a 1995 buick park avenue that has a rough idle and stalls in the mornings after sitting over night the first two or three times it will stall but after that it idles rough til it gets warm,ok...


Try plug wires, that's about all you haven't replaced. Actually if you have an ohm meter you can test them - anything over 6k ohms per foot - REPLACE them. Also run a good fuel system cleaner through it and stay away from cheap gas.

Mar 25, 2011 | Buick Park Avenue Cars & Trucks

2 Answers

1996 Concorde LXi 3.5/63k mi, won't cold start (in


it might be your fuel pump. I gotta tell you though you shouldn't start changing parts at random. it will become a money pit

Feb 19, 2010 | 1996 Chrysler Concorde

1 Answer

89 dodge shadow. hard start. normal idle cold, fast idle warm. sometimes it wont start until i hear fuel pump activate.


Hello,
The car may be hard to start because it may need a normal tune-up. If the spark plugs are pretty used, they will slowly stop burning as much fuel because the spark slowly gets lesser and lesser. On a cold day the fuel is harder to ignite with a small amount of spark.
Normal idle when its cold means that your cars idle is probably too high. If you lower the idle, the choke on a cold day will keep the idle a little higher until the motor warms and then it will kick back off. If the idle is too high, it will run very rich, smothering itself with fuel, and causing the idle to stay low. When the car warms, its creating better spark when its warm, and with the idle being too high its running at a fast idle.
The car wont start sometimes can be the cause of a few things. If the ground is bad on the fuel pump, it wont make a good connection sometimes for when you turn the key on, the fuel pump dont pump the fuel to the engine. Another one can be that your accessory switch can be loose going to the fuel pump. I think its your ground though. Good luck! Hope this helps.
Have a nice day. -Steve

Dec 06, 2009 | 1989 Dodge Shadow

1 Answer

98 chevy Z71 305 idles rough after warm up.


catalytic converter plugged restricting exhaust smells like rotten eggs/sulfur replace

Sep 29, 2009 | 1996 Chevrolet Suburban

1 Answer

My ford ranger idles low and spits gas out the exhaust


Hello,
First confirm it is either gas or eastter. Wayer/condedste collects at the tail oip as a byproduct of the caralyctic converter on cold rngine It normally occurs on firts start of a cokd enginw. the ebgine idles low because it is col, but should reyutn to normsl after warm uo.. If for sure iys gasolinem and the engine runs eiygh, then angihector is bad, good luck. I hope this helped yyou

May 15, 2009 | 1993 Ford Ranger SuperCab

2 Answers

2005 xA won't start


there's a possibility that the battery is run down. If it's the original battery, chances are you need to replace it. I'd have the alternator checked as well, however the most likely problem is a worn out battery. It's not uncommon for batteries that have been maintaining their charge through the warmer months to go bad once a cold weather comes through. As for the stinky exhaust, in your attempts to start the engine with a run down battery, the engine probably loaded up with fuel, thereby causing it to run rough and stink till excess fuel was expelled from the cylinders. Hope this helps.

Oct 29, 2008 | 2006 Scion xA

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

25 people viewed this question

Ask a Question

Usually answered in minutes!

Top Jeep Experts

yadayada
yadayada

Level 3 Expert

74896 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7688 Answers

Are you a Jeep Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...