Question about 1997 Chevrolet K1500

4 Answers

Truck cranks but won't start

1997 chevy Z71, fuel pump is working, new fuel filter, all appears to be good. we have to prime the throttle body to get it to start when cold.

Posted by on

4 Answers

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 13 Answers

I just a very similar issue with my 1997 Chevy K1500. I changed all of the fuel components and the issue turned out to be the two prong thermostat sensor on the front of the engine. If your car will start by pressing the gas pedal all the way to floor then the issue most likely is the same. A code engine reading from that sensor will cause the vehicle to not shift into overdrive, degrade gas mileage, and make the truck hard to start when the engine is warm. If it isn't starting when cold check the fuel pressure at the injectors turn the key on and the pressure should go to about 65 psi and when you turn the key off the pressure should hold to about 60 psi.

Posted on Nov 17, 2009

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 56 Answers

Check the fuel line it may have a small hole that is allowing air in. If air is getting into the line the fuel will flow back into the tank. Happend to me one day and it turned out to be the clamp.

Posted on Jul 20, 2009

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Night Owl:

    An expert who has answered 10 or more questions between 12 midnight and 6am on the same day.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

  • Expert
  • 32 Answers

Jabney27 Thanks so much been working on the same prob for the past week on my grandfathers truck and today i found out he also had no overdrive i read your post and well i'll be damned all i did was unplug to test and sure as heck got overdrive back and truck starts so tomorrow i will be getting a new censer

Posted on Jul 21, 2012

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Had the same problem and checked the temp sensor...problem solved

Posted on Jul 21, 2012

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My 1994 chevy p/u 1500 V6 chuggs when trying to start and it never completely starts


Will it start on starting fluid sprayed into the throttle body ?
Have you checked base fuel pressure at the injectors ?

Apr 23, 2013 | 1997 Chevrolet K1500

1 Answer

97 chevy blazer w/ 4.3 won't start unless i pour full directly into it....what is causing this. was driving and it just stalled ...fires but won't turn over completely


if you can put fuel in throttle body and it runs. then it is not getting any fuel. check your fuel pump fuse and the relay, if ok, then you may have a bad fuel pump or a plugged up fuel filter. check filter and fuses first. good-day !!

Jul 18, 2011 | 1997 Chevrolet Blazer

1 Answer

I have a 97 Chevy Blazer that will crank but not start. I can get the vehicle started with the help of starting fluid or gasoline put in the throttle body but throttle response while driving is poor. ...


if it starts with starting fluid. its not getting any fuel to engine. first check the fuse and relay for fuel pump. then make sure fuel pump comes on when you try to start it. its only on for a few seconds when starting. then when driving its on all the time. good-day ! fuel filter also if need be.

Jul 09, 2011 | 1997 Chevrolet Blazer

1 Answer

My 97 z71 when i putt fuel in the throttle body it will start and idle but when i push in throttle it stalls out just replaced fuel pump and filter


no fuel is getting to engine, check fuel filter, or a bad fuel pump. check the fuse and relay for pump. have a good one!!

Oct 21, 2010 | 1997 Chevrolet K1500

2 Answers

Wiring diagram for a 1997 Chevy Z71 Vortec 350


i have a 1997 chevy Z71 and it will not start. all my fuses are working and so is my fuel pump. When i turn the key on none of my guage lights come on and when i crank it all it does is keep turning over, never starting

Apr 14, 2010 | 1997 Chevrolet K1500

1 Answer

Fuel not getting to throttle body


SOUNDS LIKE YOU HAVE A PLUGED LINE OR BAD INJECTORS BUT I WOULD LOOK AT THE LINES FIRST

Jul 20, 2009 | 1997 Chevrolet K1500

1 Answer

Isuzu Hombre 4.3 (Chevy S10) 1997 won't start


Definitely check for spark next. let me know what you find.

Dec 30, 2008 | 1997 Chevrolet S-10 Pickup

2 Answers

1996 silverado 5.7 vortec cranks but wont start. fuel pump, gauges, "idiot" lights, blinkers do not work. flashers and all the rest of lights operate. Just replaced coil and this happens


Had the same problem with my '96 Silverado with 350 Vortec. The truck would only crank. It would start if fuel was poured down the throttle body. Could not hear the fuel pump hum. Fuse was good, but could not hear relay click. Relay was good, Did some electrical wiring trouble shooting. Turned out that one of the connectors that clasp onto one of the pins of the fuel pump relay wasn't making a good connection, too loose. I just stuck a peice of wire into the connector and pushed the relay back in. Relay clicked, Truck Started. It's been more than 4 yrs. since I made that McGuyver fix. Still firing.

Jul 26, 2008 | Chevrolet Silverado 1500 Cars & Trucks

Not finding what you are looking for?
1997 Chevrolet K1500 Logo

956 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75005 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7710 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...