Question about Cars & Trucks

1 Answer

I have a 1993 camaro z28 lt1 and it spits and sputters going down the road wants to die when you come to a stop sign it won't go over 30 MPh no engine lights come on the dash put seafoam and nothing

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I would change the fuel filter first, if that doesn't fix the prob. check the throttle position sensor.

Posted on Dec 01, 2016

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 2 Answers

SOURCE: 1993 honda prelude si dash lights

my 93 prelude was doing the exact same thing and for me it was my alternator was working properly.
go to a parts store and have them test it.

Posted on Aug 07, 2008

  • 25 Answers

SOURCE: 2003 Mitsubishi Outlander died and won't start back up

If it does turn over but won't start, check for fuel and spark, if not spark then check to see if the crank sensor is cover with dirt.....

Posted on Feb 09, 2009

  • 1 Answer

SOURCE: I have a 95 firebird formula LT1 that will sputter

i have a 96 formula. had the same problem. blown intake gasket. it's truley amazing how that can effect the car.
hope this helps.
David

Posted on Jul 27, 2009

  • 1168 Answers

SOURCE: engine seems to miss / sputter between 30 mph and

Hi Nascar2nd.
From what you are describing it appears like an engine misfire.
These trucks are notorious for bad ignition coils.
They don't always set a code either, it depends on several factors.
To check these out in my shop there is a mode in our scan tool called "mode 6". This allows us to look at certain engine data parameters to look at misfire to locate the offending cylinder(s).
Unfortunately without the use of a scan tool you will not be able to see this.
It may be in your best interests to get a shop to look at this for you and verify the bad cylinder.
I have had issues with aftermarket coils and use Ford originals exclusively now. They have also reduced the price of them, good thing too because we go through many.
Might be an opportune time to replace spark plugs as well. worn spark plugs can accelerate coil failure as a worn plug takes more energy to fire.
Thank you for using FixYa !

Posted on Dec 02, 2009

csmock132
  • 4669 Answers

SOURCE: where is the coolant temperature sensor located on

I do believe it is screwed into the waterpump.

Posted on Aug 01, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

When I start my 1996 Honda accord the engine seems to sputter rpm gauge revs up on its own and spits and sputters as I'm driving down the road


My sputtering & stalling 1993 Honda Accord - YouTube

? 2:12
https://www.youtube.com/watch?v=Ki2H9aq8Xis
Jun 23, 2011 - Uploaded by mdpbfly
My sputtering & stalling 1993 Honda Accord ... 1996 Acura Integra, hesitation accelerating & misfire. ... 1993 Honda Accord Start Up and Review 2.2 L 4-Cylinder ... SIR B16A Engine sputter/ power loss at higher RPM - Duration: 1:14. by ... 1994 Honda Civic Check Engine Light Code Retrieval Tutorial ...

All comments on How To Solve Honda Idle Problems ...

https://www.youtube.com/all_comments?v=L788jKEVblY
What should I do if once I turn on my Ac my idle drops as if it's gonna die, and .... to a complete stop the rpms start going up and the car accelerates on its own. ... Honda Accord LX, and my Honda just started sputtering in idle. check engine .... My cousin replaced my radiator on my 90 civic and since then my temp gauge is ...

Acceleration Bog/Sputter/Hesitation - Honda-Tech

honda-tech.com/honda-accord.../acceleration-bog-sputter-hesitation-279...
Jun 11, 2010 - 1990 Honda Accord Ex F22 209000 miles, recent alternator change When I ... When I take off from a stoplight I get a little hesitation/bogging/sputteringfeeling until about 2,000 RPM then ... My 1999 Accord had a similar problem (F18B2engine). ... It only lasted a second or so before it would actually rev up.


Dec 28, 2015 | Honda Cars & Trucks

1 Answer

I have a 1994z-28 after it running about 20mins it start spitting and spatting every few seconds. what is this?


Trouble with my new- to- me '94 z28 already - CamaroZ28.Com ...

www.camaroz28.com > ... > LT1 Based Engine Tech
Apr 9, 2012 - Couldn't reach the other side before running out of time. .... Does the carstart up after it has sat for a while and cooled off? 1994 Z-28 LT1 A4, Supercharger 6 psi, 3.73 Gears, GMPP 1.6 Rockers, LT4 Springs, ... Ten minutes into a drive it willstart to sputter and then die, ... so nice!...for about 20 minutes.

how long does it take to heat up?? - LS1TECH

ls1tech.com/forums/lt1-lt4.../1371680-how-long-does-take-heat-up.html
Jan 8, 2011 - 1994 z-28 m6 procharged all the goodies ... to get hot lol.. change back to stock if you want it to run a regular temp ... I hit the freeway almost immediately afterstartup so the car doesn't really get a chance to "get hot". ... To answer the original question my old LT1 took about 15-20 minutes to blow warm heat.

Dec 01, 2015 | Cars & Trucks

1 Answer

I just got my 1995 camaro z28 LT1 water pump replace and I went a block stopped and took off again and the car accelerated full throttle is this common in this model. after twice starting it it came...


You need to check all throttle linkage and cables. Make sure none are binding or show signs of fraying, wear etc. Doubt if that has anything at all to do with the water pump but, regardless, I cannot stress how dangerous that is. (I actually watched as one man died and another lost his leg because of the identical problem). Make absolutely sure you know the cause of the binding and that it has been corrected before driving!!!

Aug 10, 2011 | 1995 Chevrolet Camaro

1 Answer

I have a lt1 camaro that back fires


It sounds like it mite be loading up , try running some injection cleaner through the gas tank /ether concentrated or Seafoam / also check the air if you can see any light through it/if not replace it./you may have to spry out the throttle body But first give the cleaner a chance..hope this helps,if we can be of any further assistance feel free to ask. Thank You for using fixya.ps. let us know how we are doing?

Apr 09, 2010 | 1993 Chevrolet Camaro

2 Answers

1998 camaro I have replace the fuel pump and filter, car would crank but not start. The next day it started fine twice, the third time it spit sputtered coughed and did everything but start. I now think it...


its not your crank sensor its your starter. i just went through the same thing. i have a 1998 chevy camaro 350 lt1. if thats not it its in your stering colum

Oct 16, 2009 | 1998 Chevrolet Camaro

2 Answers

I have a 95 firebird formula LT1 that will sputter and want to die. This will only happen if I drive for about 30 minutes then stop and shut off the car for 15 minutes. Once I start it after that it bogs...


map censor... manafold absolute pressure censor.. the mecanics have a hard time finding this censor it is secondary to the motor circuts but it will cause the motor to die then restart in a short time...$30.00 autozone

Jul 07, 2009 | Pontiac Firebird Cars & Trucks

1 Answer

The car when hot or cold may stumble and/or die at a stop sign and it may also do it going 70 mph down the road. It will catch itself and start running.


This may be the early sign of a blown head or gasket. Check your coolant to make sure it doesn't have oil in it or appear to be oily. This is the first thing that I would check.

May 16, 2009 | 1996 Ford Thunderbird LX

2 Answers

1996 camaro z28 breaks up and goes nowhere when you floor it


I had the same problem and it was my optic spark. They have all failed between 100-140 thousand miles. I bought mine from gm it was expensive 500 bucks but no company has been able to make an after market distributor that will run with the lt1

Sep 30, 2008 | 1996 Chevrolet Camaro

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

23 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

yadayada
yadayada

Level 3 Expert

75822 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Randy Ohler

Level 3 Expert

14585 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...