Question about 2001 Saturn SL

1 Answer

1995 saturn stalls when stopped in gear replaced temp sensor changed plugs,idles fine when in park.

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Saturn Master
  • 6,674 Answers

I'd concentrate on IAC (idle air control) valve/motor . Removing it & cleaning with throttle body cleaner & port it comes out of, will sometimes cure problem, but if it happens again, replace it.

Posted on Jul 20, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My explorer idles fine in park but skips and misses when under load


K the next thing to check is the throttle position sensor. It's probably going bad. The same thing happened to me on my 1995 F250 5.8L

Sep 16, 2012 | 1998 Ford Explorer

1 Answer

Hi, I,m having trouble with my 95 Saturn SL2. It has been running fine for years now for the last year it has been running rough onces it get up to oprating temp. It starts up alright but once the temp...


Try replacing a valve called the Idle Air Control Valve, if your car has one. See if that solves it. Not sure where it is located on your specific vehicle.

Dec 11, 2010 | Saturn SL2 Cars & Trucks

1 Answer

My 95 Saturn SL2 1.9 will idle very lough when in drive or reverse. Runs fine at about 65mph but still has a little skip here and there. When the Air Conditioning is turned on the car will stall....


TYry doing a static power brake test on the vehicle, with the car in gear, wheels are chocked up so not to allow vehicle to move forward, stand firm on the brake pedal and slowly add gas to the engine, does it dance around and miss fire?
If so you may have a bad coil/plugs/wires under load they may be breaking down they should have been replaced by at least 65,000 miles if not do a featured maintenance on the engine and replace them.

Aug 08, 2010 | Saturn SL2 Cars & Trucks

2 Answers

High Idle 2000 Saturn S series


Definately have a sensor problem...but that may not be all. You can blame the sensor issue on the idling problem. The overheating in park is likely one of 2 things, provided you have adequate coolant. #1 a sticking thermostat or a bad coolant temp sensor not activating your fan at idle. What you should do is have your diagnostic codes read in order to take care of the sensor issue. Most national parts chains such as Auto Zone or Advance will do this at no charge in hopes of selling you a sensor. Good Luck! I hope you find this to be very helpful.

Feb 18, 2010 | 2001 Saturn S-Series

1 Answer

Idled high, replace IAC and PCV, now idles low and stalls


On modern day cars the parts that get fitted need to be adapted to the ECM using a decent diagnostic machine. I bet that this was not done and the car is now suffering as a result.
Something to try is resetting the ECU, simply disconnect battery for 10 minutes, reconnect, then start car from cold *without touching gas pedal* and leave idling until the rad fan comes on (this resets all the base idle settings) then take it for a drive - hopefully will solve the problem

Nov 18, 2009 | 1990 Dodge Caravan

2 Answers

1993 Ford Escort 1.9L Auto Randomly Stalls


I don't have the solution, but I have the same exact problem on my 1991 Escort 1.9L with auto with 120K miles. I replaced the IAC with no difference. In fact I unplugged it, and still had the random stalling. Also disconnected the EGR vacuum line...still stalled randomly. After it stalls it always starts right back up again. Sometimes it will act as if it's going to stall, but comes back to normal idle. Park or Drive makes no difference. Acceleration and all normal driving is fine. The next thing I was going to try is hooking up a timing light and watch to see if the timing light stops flashing as it's stalling, and/or hooking up a fuel pressure gauge somehow, to the fuel rail, to see if the pressure drops when stalling....to figure out if its ignition or fuel related.

Oct 20, 2009 | 1993 Ford Escort 4 Door

3 Answers

1990 Olds 88 Royale; engine stalls


You've got to do the obvious things, look at your spark plug wires, if you see what looks like chalky residue they are arcing replace them and your plugs. Check all vacume lines for leaks, and make sure your air filter is clean

Sep 10, 2009 | 1990 Oldsmobile Eighty Eight

1 Answer

2002 Saturn SC1 - Starts fine and runs well until the engine gets warm. Then I will step on the gas peddle and the engine will die. Sometimes it won't die it will just have no power to move. Fuel Pump?...


Most Likely Coolant temp sensor & connector.Located in cyclinder head under upper radiatior hose.Two wires to connector yellow & black.Replacement sensor is brass (from saturn) Original is ceramic & cracks cause poor performance,stalling,idle issues.Also check plugs & wires for carbon tracking.Replace plugs & wires as a set all at once.Hope this helps

May 12, 2009 | 2002 Saturn Sl

1 Answer

1995 Saturn SL1 starting problem


Change the cam positioning sensor,not the crank sensor,

Oct 30, 2008 | 1999 Saturn SL

4 Answers

1995 Chevy silverado with a 5.7. Was running fine i stopped at a stoplight and it died. It was hard starting, i had to turn the AC off to get it to start, then had to 2 feet it home. Now it starts and...


I have experienced this problem on similar vehicles. You should try and replace the coolant temp sensor. If it is not reading the correct temp to the ecm, it will not get the right fuel map. Also, the cts will not always throw a code.

Aug 04, 2008 | 1999 Chevrolet Silverado 1500

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

270 people viewed this question

Ask a Question

Usually answered in minutes!

Top Saturn Experts

yadayada
yadayada

Level 3 Expert

76164 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8273 Answers

Are you a Saturn Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...