Question about 1995 Isuzu Rodeo

1 Answer

Same thing here

I have the same problem

my error code is running rich

I have new plugs and wires, but this replacement didn't alter the condition

I am wondering if it is maf/map or o2 sensor related

Posted by on

  • clintharper Jul 20, 2009

    well I am going to clean the maf tomorrow, and hope that is the easy fix

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 43 Answers

My best advise it to go have it properly diagnosed. It could be any of those, it could be a leaking injector. If your bring it into a full service shop/dealer then they will be able to see what values for the sensors are not correct.

Posted on Jul 20, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1989 mustang 5.0 running fine then all of sudden missing and running rich


The first thing you need to do is run a fault code test on the system, go here to learn how to do that, codes are listed as well.

Oct 22, 2012 | Cars & Trucks

1 Answer

1991 2.0 talon, cuts out at higher speeds, runs rich, has new coolant sensor and o2 sensor, ,new plug and wires, did not fit the problem


A solution was given earlier and I would request for a code error check before you chnage spares at random.Check fuel and fuel filter and pump

Jun 06, 2012 | Lincoln Town Car Cars & Trucks

2 Answers

2001 pontiac grand prix. 2.8 ltr. Code says bank one sytem too rich. What could be causing the problem? It wants to die out when I take off from a stop, mostly in the mornings.


You need to get the codes,then work from a
touble chart

MAF Sensor --dirty or bad
Evap System Leaks

A rich reading,doesn't mean a rich condition,
your looking for

Have to start with codes & then start testing,
until you find something not as it should be

Jun 13, 2011 | 2001 Pontiac Grand Prix

2 Answers

I'm getting poor fuel economy, 11mpg overall. I have the 3.9 with TBI, just replaced plugs and wires, cap and rotor are new also. Replaced air filter recently. Exhaust smells weird, like the engine runs...


Oxygen sensor. They tend to fail by sending the engine computer a steady lean reading. the computer then runs the TBI rich in order to compensate for the false lean condition.

Also, the Engine Coolant Temperature sensor. If it fails and shows the engine to be ice cold when it is really warm, the computer will schedule lots of fuel.

Intake Air Temperature sensor. same result as ECT above. Computer sees nothing but cold dense air all the time and schedules more fuel.

Feb 08, 2011 | 1993 Dodge Dakota

1 Answer

I recently purchased a 2002 cavalier z24 with 100,000 miles on it. I recently noticed a gas leak, so i just had the fuel pressure regulator changed. Today the check engine came light came on with two...


To much gas going thru the exhaust. probably the #2 miss fire. Before you change plugs, make sure you have fire to cylinder #2. You could have a bad coil or ignition module. Also check the condition of the plug wire. You can change these if you like , but it may not be necessary.

Jan 31, 2011 | 2002 Chevrolet Cavalier Coupe

1 Answer

I own a 2004 avalanche with a 5.3 vortex. I was driving on the highway @ 110km/p/hr, I then accelorated to about 125 and my engine check light came on. I took it to a garage and they scanned the engine.The...


Spark plugs don't fail to fire. They are replaced at 60,000 miles or 3 years.
Scanning for codes and using an ignition scope, are two different things
I have run OEM plug wires 17,18 and currently 21 years, on different vehicles.
Replace,only if they fail and test bad. Only one wire EVER fails,not all of them
The O2 Sensor may have set a code.
You don't change it,because of that.
You look at the data, and if it is working correctly,and what caused it to go
out of range and set the check light.

Did he check for a failed injector,on the bank that was rich?
Was exhaust gas tested, to determine the rich condition?
There is no guessing or might be's

Do a cylinder leak down test
Don't like the results,pull the valve cover, and check out the valve spring theory

What was the codes that you got when driving it?
How many miles on it?
Vehicle history?

Nov 25, 2010 | Chevrolet Avalanche Cars & Trucks

1 Answer

Randem rough idel and fuel/rich mix smell. Hot or cold ? Changed the water temp sensior for the eci and also new eci? 2001 Ford escort


I'm surprised you didn't get an error code, mainly on the spark plug wires. I would try those, they can cause a bunch of trouble, including rough idle, rich burning, everytime my Grand Marquis acted up, it was the spark plug wires. Of course it was also the only thing not covered in the warranty. Check it out.

Jul 30, 2010 | 2000 Ford Escort

2 Answers

1998 Saturn SL2 engine light


Possible Causes
The following are malfunctions that could cause a rich condition:
^ Fuel pressure too high. Perform fuel pressure test.
^ Leaking fuel injector(s). - Perform pressure leak down test.
^ Vacuum leak around the MAP sensor grommet.
^ Oxygen sensor contamination.
^ Restricted exhaust or air intake.
^ Fuel Vapor Canister saturated with fuel.

IMPORTANT:
If the front oxygen reading voltage is above 600 mV and the rear HO2S is above 600 mV all the time, the O2 sensors are probably not
at fault.

Sep 22, 2009 | 1998 Saturn SL

3 Answers

1995 GMC JIMMY Runs rouph, P0306 stored rich condition, blck smoke out tailpipe


Prob needs a o2 sensor or oxygen sensor they are called

Sep 17, 2009 | 1995 GMC Jimmy

Not finding what you are looking for?
1995 Isuzu Rodeo Logo

Related Topics:

64 people viewed this question

Ask a Question

Usually answered in minutes!

Top Isuzu Experts

yadayada
yadayada

Level 3 Expert

75744 Answers

Steve Hurc
Steve Hurc

Level 3 Expert

450 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

Are you an Isuzu Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...