Question about 1983 Toyota Land Cruiser

1 Answer

Engine runs high when warmed up. Starts and runs smoothly but around 1500 RPM when engine gets warm. Suspected E.D.I.C. motor first overfuelling but upon talking to others now suspect diaphram in fuel pump itself. Please help!!!

Posted by on

  • yadayada
    yadayada May 11, 2010

    what the heck is a edic

×

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 850 Answers

Its leaning out [ not enough fuel] for theose revs! check air fuel mix

Posted on Jul 20, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

93 mustang 50v8 engine what causes engine to quit running at high rpm then restarts as rpm falls


So is this the only issue your having? Is the stang hard to start cold or warm? Hard to say with what youve asked....Is your TFI newer how about your Dizzy?

Jul 01, 2014 | 1993 Ford Mustang

1 Answer

1997 acura cl 2.2 revs up to 1500 rpm and down to 1000 rpm just several seconds after start


Cars are design to run at a higher idle at start up to warm them up quick. There is a sensor that reads water temperature and tells your car's computer how fast to idle. Your RPMs seem slightly high but not out of the norm. Does idle ever drop to around 600/800 after about a minute? If not, your engine temperature sensor maybe defective.

Mar 16, 2014 | Acura Cars & Trucks

1 Answer

Idle problem integra


check the MAP sensor (manifold absolute pressure). The ECM (car computer) uses that to keep idle at minimum 750 RPM. It's normal for it to run high when cold. These small 4 banger motors typically run hot, and they won't run right IF they're NOT running hot, ergo the idle is usually high when it is cold so as to cause it to warm up quicker. If the RPM's drop below 750, suspect the MAP sensor, &/or ECM.

Apr 18, 2013 | 1995 Acura Integra Coupe

1 Answer

2000 ford taurus ses surges when engine is warm and stalls frequently


I would take it by any auto parts store to have them pull codes from the computer. They should be able to tell you the problem. However, I would suspect the IAC (idle air controller) to be faulty.

Dec 23, 2012 | Cars & Trucks

1 Answer

Engine Runs Rough at Idle


go to auto zone,its free ck.throtle senser

Feb 19, 2012 | 2002 Ford Explorer

1 Answer

Volvo v40 2000nx reg 1.8 NON gdi engine constant high rpm can having no thermostat cause constant high rpm or can a briken lambda sensor cause high rpm cleaned all throttle body cleaned idle valve checked...


Yes, having no thermostat can cause the car to run fast as it will still be set in it's "warm up" mode and will be injecting a richer mixture of fuel/air into the cylinders. There may be an additional cold start injector that just works while the engine is cold. You will probably use more fuel like this. It's not a great idea to run with no thermostat anyway because you get uneven hot and cold spots around the engine which is bad for it. Cheers

Feb 06, 2012 | 2000 Volvo V40

1 Answer

2000 chevrolet z71 5.3 litre. when i start the truck it idles a little high about 1400 rpm and it stays there for a second then idles to about 500 rpm and it starts to shake perhaps the motor missing but...


Try cleaning the throttle body plates with throttle body cleaner.Also check for vacuum leaks around the intake gaskets.You can also check for codes.Sometimes you can have codes and not get a check engine light.Hope this helps.Good luck.

Feb 24, 2010 | 2000 Chevrolet Silverado

1 Answer

Cold idle is right at 2k rpm.


could be a vacume leak. check hose for cracks or lose conections.

Jun 13, 2009 | 1997 Land Rover Discovery

1 Answer

Po 108 fault code


Sounds more like a mass air flow sensor problem.

Jan 09, 2009 | 2001 Dodge Ram 1500 Truck 2WD

1 Answer

1991 dodge colt won't idle when engine is cold.


probably oil, it may be too thick when it's cold but once it warms up it liquefies and your engine runs smoothly. you could try changing oil, I'm guessing if you have a high performance oil the chances this is the problem may be greater since high performance things are usually geared towards working well when everything is hot

Jun 29, 2008 | 1991 Plymouth Colt

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

104 people viewed this question

Ask a Question

Usually answered in minutes!

Top Toyota Experts

yadayada
yadayada

Level 3 Expert

76848 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8589 Answers

Are you a Toyota Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...